Consulta de Novatos DNS en Multiwan



  • Hola tengo pfsense 2.0 con 3 interfaces wan, 2 wan con IP publica y una WAN con ip privada porque mi ISP usa cablemodem y no me falicita la IP publica.
    La interfaz WAN que usa DHCP (o sea la de Cablemodem) me empezo a funcionar mal, porque las paginas se cargan con delay o sea tardan en cargarse. Como el cablemodem tiene una wifi que no pasa por el Pfsense realizo pruebas y me funciona de 10. Por lo tanto mi problema es con el PFsense.
    Le sospecho a lo DNS en PFsense, es por eso que queria consultar cual es la forma correcta de cargarlo y como me deberian quedar los DNS en el archivo resolv.conf.

    Saludos..



  • En resolv.conf de pfSense tendrás lo que hayas puesto en System - General Setup.

    ¿Tus máquinas están con el DHCP+DNS de pfSense? ¿O resuelven fuera?

    Mira bien tu Dashboard y Status - RRD Graphs. Puede que algo te esté ocupando muchos estados (p2p, virus…)



  • Hola Bellera!! Las Pc estan con DHCP + DNS pfsense y ademas resuelven para afuera.
    Recien se cortaron en mi localidad las 2 conexiones que me venian funcionando bien (las 2 con ip publica) y me quede totalmente sin internet en mi pfsense. Pruebo la tercera conexion WAN con ip_privada por afuera del pfsense y si funciona. Lo reinicie al pfsense y nada sigo sin internet,
    no puedo hacer funcionar la WAN3 por mas que la WAN1 y WAN2 esten cortadas.

    Saludos..



  • Adjunto una imagen de mi topologia de red.




  • WAN3 es una subred privada, supongo porque ahí tienes un equipo de conexión de tu proveedor puesto en modo enrutador.

    Lo que me choca es que la IP del DNS sea la del enrutador de tu proveedor. ¿Es un error del gráfico?

    Los equipos de conexión a internet no suelen tener funcionalidades de DNS, a no ser que sean un poco sofisticados. Como el caso de pfSense, vaya…

    ¿Tienes el NAT saliente (otbound) en automático o en manual? Si lo tienes en manual y has añadido WAN3 te faltará le NAT saliente.



  • Gracias por la ayuda bellera. La WAN3 esta mal el DNS en realidad tiene el de google que es 8.8.8.8 y  200.49.51.11.
    El NAT Saliente lo tengo Manual voy a verificar si tengo la WAN3 como saliente.
    Al realizar ping detecte que no me esta resolviendo los DNS, porque si realizo ping a la IP (por ejemplo yahoo) si me responde.

    Saludos…



  • Una consulta en la Pestaña System –> General en el apartado DNS Server que tiene 4 campos. Los DNS de mis WAN se tienen que cargar en algún orden. Osea primeros los 2 de mi WAN1 luego los 2 de Mi WAN2.
    Pueden ir intercambiados??
    Los de mi WAN3 que es DHCP. Es necesario cargarlo??

    Saludos...



  • No necesariamente, con los DNS puedes hacer lo que desees, incluso no colocar ninguno de tus proveedores y usar por ejemplo Open DNS 208.67.222.222 208.67.220.220 (Son los que uso por defecto, al menos estoy casi seguro de que no me filtran nada :D )

    Hay quienes dirán que uses los de tu proveedor, y es lógico, porque están en la misma red y el delay será casi nulo, pero una consulta DNS tampoco es el mega paquete, es realmente imperceptible… (salvo que tengas 3000 host haciendo peticiones ;) ).

    Por otra parte... en tu gráfica me llama la atención que estés usando para tu red LAN un segmento de direcciones públicas 170.16.x.x (espero que sea un error y hayas querido colocar 172.16.x.x)

    Ahhh, se me olvidaba, arriba acoté que no me filtraban nada.... esto lo digo porque ya en una oportunidad, mi proveedor de servicios en .ve filtró ciertas páginas que estaban siendo muy consultadas porque habían cosas políticas de mi país, y pues presumo que .gob no quería que se leyeran, así que con sus DNS no hallé nunca la página, y cuando me cambié de DNS... "automágicamente" pude visitar la página... (qué cosas no?) (casualidad? no lo se) :D

    Saludos.


Log in to reply