Wlan mit pfSense einrichten



  • Hallo,
    ich möchte gerne mit meinem Lapptop, in der sich eine PCMCIA WLAN Karte ( PCMCIA Linksys WPC54G ) befindet,
    über den AP des PFsense in's Internet. Laut Monitor der WLAN Karte, habe ich auch ein Verbindung
    mit dem AP. Und pfSense zeigt mir unter Status: Wireless  auch die MAC Addr der WLAN Karte an.

    Also gehe ich mal davon aus, das beide verbunden sind. Doch ich komme, nachdem ich das
    Netzwerkkabel vom Laptop abgezogen habe, nicht in's Internet. Obwohl ich die selbe FW Regel eingegeben habe,
    wie für das Interface: Lan.

    D.h. wenn ich nicht über WLAN ins INet gehe, sondern über das normale LAN, dann klappt alles. Doch sobald ich
    das Netzwerkkabel abziehe und versuche mit der WLAN Karte ins INet zu kommen, bekomme ich keine Verbindung
    zum INet.

    DHCP habe ich nicht aktiviert. Ich habe dem AP und der WLAN Karte eine feste IP zugeordnet.
    Desweiteren hat mein Lan einen anderen IP Adresse als der WLAN Breich.

    Könnte mir jemand sagen welche (sicheren) Einstellungen ich im Bereich Interface machen ,
    und welche Firewall Rules ich evt. einstellen muß, damit ich mit der WLAN Karte
    über den AP ins INET komme.

    P.S.
    Mit den WLAN Interface über Diagnostics -> Ping www.google.de (in pfSense ) komme komischerweise aber ins Internet.

    Gruß
    Juppy  :)



  • Poste bitte mal Deine IP-Adressen am WLAN Interface (Interface-Settings der pfSense und Netzwerkeinstellungen des WLAN-Clients) hier. Zusätzlich noch die Firewall-Regeln, die Du unter Firewall>Rules, WLAN-NIC eingestellt hast.



  • @hoba:

    Poste bitte mal Deine IP-Adressen am WLAN Interface (Interface-Settings der pfSense und Netzwerkeinstellungen des WLAN-Clients) hier. Zusätzlich noch die Firewall-Regeln, die Du unter Firewall>Rules, WLAN-NIC eingestellt hast.

    Hi hobba,
    hier mal meine Einstellungen

    WLAN IF unter IP configuration bei pfSense:
    Bridge with: none
    IP : 192.168.210.112 /32

    WLAN Client
    IP 192.168.210.111
    SUB: 255.255.255.0
    Gateway: 192.168.210.112
    DNS: 192.168.210.112

    FW-Rule für WLANAP ( so heist das IF bei mir ):
    Proto  Source  Port  Destination  Port  Gateway  Description

    • WLANAP net * *           *       *   Wireless AP Regel


  • @juppy:

    WLAN IF unter IP configuration bei pfSense:
    Bridge with: none
    IP : 192.168.210.112 /32

    WLAN Client
    IP 192.168.210.111
    SUB: 255.255.255.0
    Gateway: 192.168.210.112
    DNS: 192.168.210.112

    Das Subnet stimmt auf dem pfSense WLAN Interface nicht. Da muß eine /24 hin. Dann sollte es gehen.



  • @hoba:

    @juppy:

    WLAN IF unter IP configuration bei pfSense:
    Bridge with: none
    IP : 192.168.210.112 /32

    WLAN Client
    IP 192.168.210.111
    SUB: 255.255.255.0
    Gateway: 192.168.210.112
    DNS: 192.168.210.112

    Das Subnet stimmt auf dem pfSense WLAN Interface nicht. Da muß eine /24 hin. Dann sollte es gehen.

    Hi Hoba,
    leider lag es daran auch nicht.
    Das Monitorprogramm der WLAN Karte zeigt die Meldung:
    Die Verbindung zum AP wurde erstellt aber es konnte keine Verbindung zum INet aufgebaut werden  ???



  • Was hast Du für'S LAN-subnet gewählt?



  • @hoba:

    Was hast Du für'S LAN-subnet gewählt?

    Subnet 255.255.255.0



  • @juppy:

    @hoba:

    Was hast Du für'S LAN-subnet gewählt?

    Subnet 255.255.255.0

    Hi hoba,
    du hattest recht. Es lag an der Subnet Mask
    mit 255.255.255.224 klappte es jetzt  :)

    Danke für Deine Hilfe.

    Gruß
    Juppy  ;)


Log in to reply