[Resolvido] gateway padrao + load balance



  • Pessoal, recentemente instalei o pfsense para ser meu gateway na rede, a razao para utiliza-lo foi a relativa facilidade na configuracao. Bom aqui tenho 2 links, um link dedicado e uma adsl. Fiz o balanceamento a partir de umas video aulas que vi na internet deste site http://www.exe.eti.br/index.html
    Pois bem, Num primeiro momento o link dedicado de 1mb que possui 5 ips havia ficado como gateway default mas a ideia era colocar o adsl como gateway default ja que possui 35mb de download. Mas ai que deu o problema, todos os redirecionamentos de portas que havia feito pararam de funcionar apos trocar o gateway default para o adsl. O que parece e acho que é o que ocorre é que a requisicao entra pelo link dedicado e sai pelo adsl ja que este é o default. Se eu mudar o gateway default para o dedicado os redirecionamentos voltam a funcionar. Alguma ideia para resolver isso? tem como forçar a saida para um determinado link? grato.



  • @laos:

    Alguma ideia para resolver isso? tem como forçar a saida para um determinado link? grato.

    Configure o gateway nas regras da lan, desta forma você consegue direcionar o trafego de acordo com sua necessidade.

    att,
    Marcello Coutinho



  • @marcelloc:

    @laos:

    Alguma ideia para resolver isso? tem como forçar a saida para um determinado link? grato.

    Configure o gateway nas regras da lan, desta forma você consegue direcionar o trafego de acordo com sua necessidade.

    att,
    Marcello Coutinho

    tentei isso na regra da lan associada a regra do redirecionamento. Mudei la o gateway mas nao funcionou…



  • Tira um screenshot das regras de lan e anexa aqui clicando no advanced settings do post.



  • @marcelloc:

    Tira um screenshot das regras de lan e anexa aqui clicando no advanced settings do post.

    Segue as regras, o que fiz foi editar uma dessas e mudar o gateway de default para o que recebe as requisições. Grato e desculpe a demora.




  • @laos:

    Segue as regras

    A regra de balanceamento fica na lan e não na wan.



  • Fiz de acordo com videos desse site  http://www.exe.eti.br/index.html . Ele faz uma regra que passa tudo pra tudo em todas interfaces. Segue regras da lan.

    @marcelloc:

    @laos:

    Segue as regras

    A regra de balanceamento fica na lan e não na wan.




  • E ai? alguém? alguma dica? Grato.

    @laos:

    Fiz de acordo com videos desse site  http://www.exe.eti.br/index.html . Ele faz uma regra que passa tudo pra tudo em todas interfaces. Segue regras da lan.

    @marcelloc:

    @laos:

    Segue as regras

    A regra de balanceamento fica na lan e não na wan.



  • A regra está correta, posta/cola/confere a configuração do load balance e do outbound nat.

    att,
    Marcello Coutinho



  • Bom dia

    Marcello, no outbound nat não há regra nenhuma. Para o balanceamento vou te explicar o que fiz, não se é o jeito certo mas funcionou: configurei normalmente os dois gateways e fiz um grupo, na configuração do grupo coloquei o gateway priority para tier 2 nos dois e o trigger level em packet loss or high latency . Depois nas regras mudei o gateway pro grupo e só.

    @marcelloc:

    A regra está correta, posta/cola/confere a configuração do load balance e do outbound nat.

    att,
    Marcello Coutinho



  • Tente não trabalhar com um "gateway default"!

    Veja também se as opções "Use sticky connections" e "Allow default gateway switching" em "System: Advanced: Miscellaneous".

    Abraços!
    Jack



  • Estavam desmarcadas essas opções.
    @JackL:

    Tente não trabalhar com um "gateway default"!

    Veja também se as opções "Use sticky connections" e "Allow default gateway switching" em "System: Advanced: Miscellaneous".

    Abraços!
    Jack



  • @laos:

    Estavam desmarcadas essas opções.

    Então marque-as e teste! ;)

    Abraços!
    Jack



  • Funcionou!!! seguinte agora preciso que a saida da porta 25(smtp) seja sempre no link dedicado(wangw). Segue regra que fiz, esta certo? grato e abraco

    @JackL:

    @laos:

    Estavam desmarcadas essas opções.

    Então marque-as e teste! ;)

    Abraços!
    Jack




  • quase. :)

    copie a regra da lannet e mude a destination port para 25 e mude o gateway.

    depois mova ela para antes da regra que libera tudo pelo outro link

    att,
    Marcello Coutinho



  • Assim? Segue em anexo. Abraco

    @marcelloc:

    quase. :)

    copie a regra da lannet e mude a destination port para 25 e mude o gateway.

    depois mova ela para antes da regra que libera tudo pelo outro link

    att,
    Marcello Coutinho




  • Isso mesmo, agora está correto. :)



  • E ai! quando eu acho que terminou a novela aparece outra duvida… seguinte: acesso minhas portas redirecionadas pelo link principal, que não é mais gateway default, seguindo a dica do colega desmarquei o default gateway dos dois links.. até ai tudo certo. porém tbm quero acessar algumas portas pelo link dois que é bem mais rapido.. Notei que nas rotas o default esta no link 1 Tentei trocar o gateway na regra associada ao nat para o gateway link 2.. mas nao teve efeito. desde ja agradeço. abraços.

    @marcelloc:

    Isso mesmo, agora está correto. :)



  • Por ser um firewall statefull, a regra é tratada onde a comunicação começa.

    Se o nat está feito na wan2, o pfsense vai saber devolver o pacote pela interface certa.

    att,
    Marcello Coutinho



  • Bom dia

    Tentei fazer o nat, segue as regras que fiz, porem nao funcionaram.

    @marcelloc:

    Por ser um firewall statefull, a regra é tratada onde a comunicação começa.

    Se o nat está feito na wan2, o pfsense vai saber devolver o pacote pela interface certa.

    att,
    Marcello Coutinho




  • Remova a regra do adslgvt com load balance.

    O load balance é definido na interface onde o trafego começa e não por onde ele sai.



  • Removi! vou fazer os testes e posto o resultado… a regra do nat estava correta? abraco.

    @marcelloc:

    Remova a regra do adslgvt com load balance.

    O load balance é definido na interface onde o trafego começa e não por onde ele sai.



  • testei! funcionou :) muito obrigado pelas dicas abraço.

    @laos:

    Removi! vou fazer os testes e posto o resultado… a regra do nat estava correta? abraco.

    @marcelloc:

    Remova a regra do adslgvt com load balance.

    O load balance é definido na interface onde o trafego começa e não por onde ele sai.


Locked