PfSense 1.2 beta 1 bekommt keinen DNS Server vom ISP



  • Konfiguration: 1x LAN, 1x WAN, 1x WLAN, läuft mit m0n0wall und fli4l ohne Probleme. fli4l ist mir nach Jahren der Nutzung zu umständlich zu konfigurieren und ich möchte eine einfach WebGUI. m0n0wall hat leider kein WPA und ist damit mit WLAN nicht nutzbar. Also: pfSense!

    Ich habe mir also pfSense 1.2 Beta 1 installiert. Alles so wie bei m0n0wall konfiguriert, LAN und WLAN sind gebridged. Der interne DNS Server läuft und beantwortet auch Anfragen zu internen Adressen.

    ABER zu externen Adressen gibts keine Antwort bzw. die Adresse kann nicht aufgelöst werden. Das ist wohl auch kein Wunder da in der Statusseite des WAN Interfaces beim ISP DNS gähnende Leere herrscht. Der Rest funktioniert. EInwahl, IP Adresse wird zugewiesen etc. Bloß klappt das mit dem DNS meines Providers nicht. Was wie gesagt mit m0n0wall und fli4l ohne Probleme klappt.

    Sollte ich lieber mal die Release Version probieren und die Beta vergessen oder muß man da noch irgendwo was konfigurieren?



  • do you have in "system" –> "general setup" the checkbox "Allow DNS server list to be overridden by DHCP/PPP on WAN" checked?

    EDIT: ups jetzt hab ich doch tatsächlich in englisch auf einen deutschen beitrag geantwortet......  :o

    -->
    hast du unter "system" --> general setup" die checkbox unter "DNS Server" "Allow DNS server list to be overridden by DHCP/PPP on WAN" aktiviert?



  • @GruensFroeschli:

    hast du unter "system" –> general setup" die checkbox unter "DNS Server" "Allow DNS server list to be overridden by DHCP/PPP on WAN" aktiviert?

    Soweit ich mich erinnern kann ja. Ich kann nicht nachsehen da ich ja jetzt wieder den fli4l laufen habe damit ich ins Internet komme.

    Aber selbst wenn nicht. Auf der Statusseite der WAN Verbindung sollte doch davon unabhängig der DNS Server meines DSL Providers angezeigt werden oder? Und da steht ja wie gesagt nichts. Ich werds heute abend nochmal mit pfSense 1.0.1 probieren.

    Gruß W



  • Es werden die verwendeten DNS-Server angezeigt, nicht die des ISP (es sei denn Du hast das so konfiguriert, daß die verwendet werden sollen). Ich trage immer DNS Server unter system>general ein und laße den Haken, ggf zugewiesene zu verwenden, gesetzt. Dann geht's auch, wenn mal keine zugewiesen werden. Hatte ich auch schon mal ne Zeit lang bei meinem ISP beobachtet, lag aber damals am ISP.



  • Mit der 1.0.1 und genau denselben Einstellungen läuft es jetzt….


Log in to reply