Problem with atheros 5212 pci wireless chip on wrap board



  • Dear all

    Below I attached the hole dmesg. Is there a hardware compatibility problem with this chipset?

    Copyright © 1992-2006 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD 6.1-RELEASE-p10 #0: Sun Oct 29 01:44:26 UTC 2006
        sullrich@builder.livebsd.com:/usr/obj.pfSense/usr/src/sys/pfSense_wrap.6
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Geode(TM) Integrated Processor by National Semi (233.31-MHz 586-class CPU)
      Origin = "Geode by NSC"  Id = 0x540  Stepping = 0
      Features=0x808131 <fpu,tsc,msr,cx8,cmov,mmx>real memory  = 134217728 (128 MB)
    avail memory = 121917440 (116 MB)
    wlan: mac acl policy registered
    ath_hal: 0.9.16.16 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    cpu0 on motherboard
    pcib0: <host to="" pci="" bridge="">pcibus 0 on motherboard
    pci0: <pci bus="">on pcib0
    ath0: <atheros 5212="">mem 0x80000000-0x8000ffff irq 12 at device 13.0 on pci0
    ath0: unable to attach hardware; HAL status 14
    device_attach: ath0 attach returned 6
    sis0: <natsemi 10="" dp8381[56]="" 100basetx="">port 0x1000-0x10ff mem 0x81040000-0x81040fff irq 10 at device 14.0 on p0
    sis0: Silicon Revision: DP83816A
    miibus0: <mii bus="">on sis0
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">on miibus0
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis0: Ethernet address: 00:0d:b9:00:d7:e0
    sis1: <natsemi 10="" dp8381[56]="" 100basetx="">port 0x1400-0x14ff mem 0x81080000-0x81080fff irq 9 at device 15.0 on pc0
    sis1: Silicon Revision: DP83816A
    miibus1: <mii bus="">on sis1
    ukphy1: <generic ieee="" 802.3u="" media="" interface="">on miibus1
    ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis1: Ethernet address: 00:0d:b9:00:d7:e1
    sis2: <natsemi 10="" dp8381[56]="" 100basetx="">port 0x1800-0x18ff mem 0x810c0000-0x810c0fff irq 11 at device 16.0 on p0
    sis2: Silicon Revision: DP83816A
    miibus2: <mii bus="">on sis2
    ukphy2: <generic ieee="" 802.3u="" media="" interface="">on miibus2
    ukphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis2: Ethernet address: 00:0d:b9:00:d7:e2
    Geode GPIO@ = f400
    Geode PC Engines WRAP.1C/1D/1E v1.tinyBIOS V1.4a (C)1997-2005
    isab0: <pci-isa bridge="">port 0xf400-0xf43f,0xf600-0xf63f at device 18.0 on pci0
    isa0: <isa bus="">on isab0
    pci0: <bridge>at device 18.1 (no driver attached)
    atapci0: <national geode="" sc1100="" ata33="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfc00-0xfc0f at dev0
    ata0: <ata 0="" channel="">on atapci0
    ata1: <ata 1="" channel="">on atapci0
    pci0: <multimedia, audio="">at device 18.3 (no driver attached)
    Geode CBA@ 0x9000
    Geode rev: 06 03
    Timecounter "Geode" frequency 27000000 Hz quality 1000
    pci0: <bridge>at device 18.5 (no driver attached)
    orm0: <isa option="" rom="">at iomem 0xe0000-0xe7fff on isa0
    ppc0: parallel port not found.
    sio0 at port 0x3f8-0x3ff irq 4 flags 0x30 on isa0
    sio0: type 16550A, console
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    RTC BIOS diagnostic error 80 <clock_battery>Timecounters tick every 10.000 msec
    Fast IPsec: Initialized Security Association Processing.
    ad0: 977MB <sandisk sdcfh-1024="" hdx="" 4.04="">at ata0-master PIO4
    GEOM_LABEL: Label for provider ad0a is ufs/pfSense.
    GEOM_LABEL: Label for provider ad0d is ufs/pfSenseCfg.
    Trying to mount root from ufs:/dev/ufs/pfSense
    WARNING: / was not properly dismounted
    WARNING: /cf was not properly dismounted
    WARNING: R/W mount of / denied.  Filesystem is not clean - run fsck
    WARNING: R/W mount of /cf denied.  Filesystem is not clean - run fsck
    sis0: link state changed to UP
    sis1: link state changed to DOWN
    sis2: link state changed to DOWN
    pflog0: promiscuous mode enabled

    Thanks in advance for any help
    Regards,
    Chris</sandisk></clock_battery></isa></bridge></multimedia,></ata></ata></national></bridge></isa></pci-isa></generic></mii></natsemi></generic></mii></natsemi></generic></mii></natsemi></atheros></pci></host></fpu,tsc,msr,cx8,cmov,mmx>



  • Upgrade your BIOS.



  • I've downloaded the new version of tinybios from this page:
    http://www.pcengines.ch/tinybios.htm
    , but sadly I've no bloody idea how to upgrade the bios….! Is there anyone who can give me a simple and short howto?



  • Download this file and check the readme, i prefer the "XModem" Update :

    http://www.pcengines.ch/wbios111.zip

    Flash upgrade:

    There are two ways to upgrade the flash BIOS:

    This program can be executed from a DOS bootable disk. It will
      look for WRAP.ROM, and program it into flash.

    • Xmodem update

    Using a terminal program, press S during the memory test.
      The setup screen will be displayed. Press X, then start a
      X-Modem (1K, CRC) upload of e.g. WRAP1.UPD. The .UPD files
      consist of the flash update WRAP_UP.BIN, and the flash image.
      When the upload completes, the flash update is automatically
      executed.



  • Okay, I updated the bios but still have the same issue…..

    here is the output from the dmesg:

    Copyright (c) 1992-2007 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
            The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 6.2-RELEASE-p4 #0: Mon Apr 30 11:13:54 EDT 2007
        sullrich@builder6.pfsense.com:/usr/obj.pfSense/usr/src/sys/pfSense_wrap.6
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Geode(TM) Integrated Processor by National Semi (233.31-MHz 586-class CPU)
      Origin = "Geode by NSC"  Id = 0x540  Stepping = 0
      Features=0x808131 <fpu,tsc,msr,cx8,cmov,mmx>real memory  = 134217728 (128 MB)
    avail memory = 121876480 (116 MB)
    wlan: mac acl policy registered
    ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    cpu0 on motherboard
    pcib0: <host to="" pci="" bridge="">pcibus 0 on motherboard
    pci0: <pci bus="">on pcib0
    ath0: <atheros 5212="">mem 0x80000000-0x8000ffff irq 12 at device 13.0 on pci0
    ath0: unable to attach hardware; HAL status 14
    device_attach: ath0 attach returned 6
    sis0: <natsemi 10="" dp8381[56]="" 100basetx="">port 0x1000-0x10ff mem 0x81040000-0x81040fff irq 10 at device 14.0 on pci0
    sis0: Silicon Revision: DP83816A
    miibus0: <mii bus="">on sis0
    ukphy0: <generic ieee="" 802.3u="" media="" interface="">on miibus0
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis0: Ethernet address: 00:0d:b9:00:d7:e0
    sis1: <natsemi 10="" dp8381[56]="" 100basetx="">port 0x1400-0x14ff mem 0x81080000-0x81080fff irq 9 at device 15.0 on pci0
    sis1: Silicon Revision: DP83816A
    miibus1: <mii bus="">on sis1
    ukphy1: <generic ieee="" 802.3u="" media="" interface="">on miibus1
    ukphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis1: Ethernet address: 00:0d:b9:00:d7:e1
    sis2: <natsemi 10="" dp8381[56]="" 100basetx="">port 0x1800-0x18ff mem 0x810c0000-0x810c0fff irq 11 at device 16.0 on pci0
    sis2: Silicon Revision: DP83816A
    miibus2: <mii bus="">on sis2
    ukphy2: <generic ieee="" 802.3u="" media="" interface="">on miibus2
    ukphy2:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    sis2: Ethernet address: 00:0d:b9:00:d7:e2
    Geode GPIO@ = f400
    Geode PC Engines WRAP.1C/1D/1E v1.tinyBIOS V1.4a (C)1997-2005
    isab0: <pci-isa bridge="">port 0xf400-0xf43f,0xf600-0xf63f at device 18.0 on pci0
    isa0: <isa bus="">on isab0
    pci0: <bridge>at device 18.1 (no driver attached)
    atapci0: <national geode="" sc1100="" ata33="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfc00-0xfc0f at device 18.2 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata1: <ata 1="" channel="">on atapci0
    pci0: <multimedia, audio="">at device 18.3 (no driver attached)
    Geode CBA@ 0x9000
    Geode rev: 06 03
    Timecounter "Geode" frequency 27000000 Hz quality 1000
    pci0: <bridge>at device 18.5 (no driver attached)
    orm0: <isa option="" rom="">at iomem 0xe0000-0xe7fff on isa0
    ppc0: parallel port not found.
    sio0 at port 0x3f8-0x3ff irq 4 flags 0x30 on isa0
    sio0: type 16550A, console
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    RTC BIOS diagnostic error 80 <clock_battery>Timecounters tick every 10.000 msec
    Fast IPsec: Initialized Security Association Processing.
    ad0: 977MB <sandisk sdcfh-1024="" hdx="" 4.04="">at ata0-master PIO4
    GEOM_LABEL: Label for provider ad0a is ufs/pfSense.
    GEOM_LABEL: Label for provider ad0d is ufs/pfSenseCfg.
    Trying to mount root from ufs:/dev/ufs/pfSense
    sis0: link state changed to UP
    sis1: link state changed to DOWN
    sis2: link state changed to DOWN
    pflog0: promiscuous mode enabled</sandisk></clock_battery></isa></bridge></multimedia,></ata></ata></national></bridge></isa></pci-isa></generic></mii></natsemi></generic></mii></natsemi></generic></mii></natsemi></atheros></pci></host></fpu,tsc,msr,cx8,cmov,mmx>



  • Wich version of PFsense do you use ?
    My WRAP works fine with the 1.0.1 Release…


Log in to reply