AON not working and routing problem



  • Hi!

    I've been struggling with this for the past couple of hours and it seems like nothing I try works.  I have two pfsense 2.0.1-release-amd64 boxes with OVPN running on them.  The ovpn tunnel is on 192.168.101.0/24, the subnet behind pfsense1 (ovpn) is 192.168.140.0/24 and subnet behind pfsense2 (ovpn client) is 192.168.105.0/24.  I get out the internet through the 192.168.140.0/24 subnet (goes to my gateway/router/nat box -> isp).  On this box, I have multiple VLAN's configured, one of them being 192.168.1.0/24.

    By default, I can ping and access everything on the 192.168.140.0/24 subnet from pfsense2 and 192.168.105.0/24.  On pfsense1, I can ping 192.168.1.1 without any problems.  When I try to ping 192.168.1.1 from pfsense2, I don't get replies.

    Now, if I add a route to that on pfsense2 in the ovpn advanced options (route 192.168.1.0 255.255.255.0;), I can ping everything just fine from pfsense2 and 192.168.105.0/24.

    Previous posts have indicated that I needed to enable AON.  I tried this, but nothing worked.  On the pfsense2 (client), I enabled Manual Outbound NAT rule generation on…

    (WAN, OpenVPN, LAN) Interface and 192.168.140.0/24
    (WAN, OpenVPN, LAN) Interface and 192.168.105.0/24

    On the server, I did the same thing.

    I also added...

    push "redirect-gateway def1";

    on the client and server, but nothing.

    I'm sure it's something simple and stupid I'm doing, but how can I get it to route all traffic over the openvpn tunnel, without adding a route for every IP out there?

    Thanks in advanced...


Locked