Captive Portal Login Problem



  • I just uploaded a custom captive portal page and now users cannot login. After they type username/password, the page simply refreshes with no internet access. I cannot type a url either (e.g. www.google.com). Here is the content of my portal page:

    –----------start----------------

    <form name="frmLogin" method="post" action="http://192.168.1.1:8000/">

    <center>

    |

    ****** Wireless Access**

    |
    |

    <center>

    |

    <center>

    <center>

    |

    <center>

    |

    <center>******* Wireless Internet Access Login**</center>

    |
    |   |
    | Acceptable Use of the Service: |
    |

    <center>

    Activities conducted online through the Service shall not violate any applicable law or regulation or the rights of Downtown Lofts, or any third party. Downtown Lofts will fully cooperate with law enforcement upon receipt of notice that use of the Service is in violation of applicable law. If you are unsure whether your use of the Service and activities conducted online may violate these Terms of Service you are advised to cease the activity immediately. Examples of prohibited activities include, but are not limited to:

    - Spamming and Invasion of Privacy

    - Intellectual Property Right Violations

    - Hacking, Scans, or other subversive Information Gathering Activity

    - Distribution of Internet Viruses, Trojan Horses, or Other Destructive Activities

    - Facilitating a Violation of this Agreement of Use

    - Resale of the Service

    </center>

    |
    | I agree to the acceptable uses of the service |
    | Username: | |
    | Password: | |
    |   |
    |

    |
    |

    <center>Reset Your Password</center>

    |

    </center>

    |

    </center>

    </center>

    |

    </center>

    |

    </center>

    </form>

    ----------------------------------end--------------------
    I would appreciate any input.
    Thanks



  • your Continue button is disabled.



  • No, that is set to be disabled until they accept the agreement. The page works on my VM, but not when I upload to the firewall.



  • Oh. Start with a very basic HTML page with simply the form as shown on the Services>Captive Portal page. Then move on to adding things bit by bit, keeping all the javascript out at first but having your page design as a whole. See where things stop working. There isn't anything captive portal-specific about it, it's just a matter of having a functional page that properly submits the form.



  • The captive portal runs on the OPT1 interface 192.168.2.0/24 and the firewall prevents most traffic between the 192.168.1.0 and 192.168.2.0 subnets.

    Is it possible that this page needs 192.168.1.1 replaced with 192.168.2.1?



  • Yes, I believe that is the problem. Somehow, the wrong IP address got in there and the firewall was blocking the authentication request.



  • You need to put the variable rather than the IP in there so it fills in the appropriate URL to use.



  • friends I am new to the forum I have a problem with the authentication of my site I tell you exit the portal nowhere and I followed the tutorials and guides nothing helps this is my mail romeo12335@hotmail.com



  • @maikc12335:

    friends I am new to the forum I have a problem with the authentication of my site I tell you exit the portal nowhere and I followed the tutorials and guides nothing helps this is my mail blabla.

    That an easy one.
    The answer starts here : http://forum.pfsense.org/index.php/topic,50246.msg269884.html#msg269884 - last message.


Locked