Resolving IP from MAC Address

  • no not really. might be easier to reset that, than try to ping that within that area.
    Because, you'll have to have subnet mask and default-gateway set right on both router and ap before that ap can answer any ping from outside of it's lan

  • LAYER 8 Global Moderator

    if you can just sniff the traffic, you could look for it sending out arps – ie if its looking for its gateway it should be sending arps - from those arps you would see its IP.

    So you don't have the manual - how are you going to get to the web ui, even if you know the IP - do you know the password or default password and just hoping?

    If you can sniff or if you have dhcp server - some devices look for dhcp if no ip set, or by default, etc.

  • install wireshark, you should see mac-address from the wireless packet itself.

  • I'm Actually passing traffic through it and turned my wireless off on my laptop.
    MAC still not present in ARP table.

    I got a hold of the sales guys at Fortinet and they are "working on it"

    I have wireshark and will install it now and i guess i will have to do a capture and see whats up…

  • I think i may have found something…
    after about 500 packet captures i ran a filter for the MAC address of the switch
    and i got a hit :D

    Internet Protocol, Src: (, Dst: (


    Now all i have to figure out the factory reset procedure :)

  • Well that was easy :)
    The main board has a coin cell on it. i pulled it and waited 30s.
    When i went to log in just put in admin and left the password field blank and BAM im in :)

    Thanks guys..
    Now its time to put that quad 10GBe backbone at work :D

  • Netgate Administrator

    So was the default IP?
    Useful info for someone. Like you said there almost no info on those switches available.


  • And…
    I'm locked out now :@

    I set a password for it and then saved the settings. Moved the switch into its rack and powerred it up.
    Went to log in and assign ports to associated Vlans and NOTHING :@

    Not very happy right now :s

  • can you even access webgui? if not try to access straight to that device, without switch, if that helps, then you'll have to change management vlan to the ap or do the following until you have vlans up and running. You might have to put switch port to vlan1(untagged default), and this port should be towarded to AP and setup similar one to the management pc and you should be in it.

    Oh yes, for future use of finding AP's (virtual)mac-addresses ease of use tool is Ekahau Heatmapper it's free tool, but requires registration. That tool is site survey tool, but it also find's mac-addresses for you.

  • The IP address is the same, but cant access the web GUI without the log in credentials and make any changes to the settings.

    So until I figure out what happened im hooped :@

  • @Metu69salemi:

    First of all...
    My switch isnt on the list.

    I already changed the default password and now it doesn't match up.

    I have to get in touch with the guys at fortinet again for a hardware reset :/

  • Let me know if they tell you something else than factoryreset command on cli

  • Will do…
    email him again this morning. Hopefully they have something for me as i dont even have the factory CLI cable :/

  • I just witnessed FortiGate 80c to be DOA or in very similar condition. I tried four different kind of RJ45-RS232 cables and two different terminal softwares and only thing which came to screen was character €.

    Only help which i got from everybody was quota for new device.. I must admit that that i don't know how old that device was, but it was sent from that customers HQ..

  • this one is working…
    I mean i get to the login screen where it wont let me go any further because of the password protection.

    I did receive a reply from the canadian fortinet rep.

    He helped me as much as he could as its an EOL switch but i have to admit the user manual is quite impressive... Nearly 700 ( 693 to be exact ) pages !!


    ! Supports 48 10/100/1000BASE-T RJ45 Ethernet ports
    ! Supports two different daughter boards
    ! - WV-TRX100-CX4: four powered CX4 interfaces
    ! - WV-TRX100-SFP: four SFP+ interfaces
    ! Supports 802.1D STP, 802.1S MSTP, and 802.1w Rapid Spanning Tree for redundant back up bridge paths
    ! Supports 802.1Q VLAN, GVRP, GMRP, IGMP snooping, 802.1p Priority Queues, Port Channel, port mirroring
    ! Multi-layer Access Control (based on MAC address, IP address, VLAN, Protocol, 802.1p, DSCP)
    ! Quality of Service (QoS) customized control
    ! 802.1x (port-based) access control and RADIUS Client support
    ! Administrator-definable port security
    ! Per-port bandwidth control
    ! IEEE 802.3z and IEEE 802.3x compliant Flow Control for all Gigabit ports
    ! SNMP v.1, v.2, v.3 network management, RMON support
    ! Supports Web-based management
    ! CLI management support
    ! DHCP Client and Relay support
    ! DNS Client and Relay support
    ! Fully configurable either in-band or out-of-band control via RS-232 console serial connection
    ! Telnet remote control console
    ! TraceRoute support
    ! Traffic Segmentation
    ! TFTP upgrade
    ! SysLog support
    ! Simple Network Time Protocol
    ! Web GUI Traffic Monitoring
    ! SSH Secure Shell version 1 and 2 support
    ! SSL Secure HTTP TLS Version 1 and SSL version 3 support
    ! ARP support
    ! IP Routing support
    ! OSPF support
    ! RIP v1 and v2 support
    ! Router Discovery Protocol support
    ! VLAN routing support
    ! Virtual Router Redundancy Protocol (VRRP) support
    ! IP Multicast support
    ! Protocol Independent Multicast - Dense Mode (PIM-DM) support
    ! Protocol Independent Multicast - Sparse Mode (PIM-SM) support
    ! IGMP v1, v2, and v3 support
    ! DVMRP support
    ! 10 GE uplink interfaces, CX4 or SFP+ depending on the selected daughter board

  • @Metu69salemi:

    I just witnessed FortiGate 80c to be DOA or in very similar condition. I tried four different kind of RJ45-RS232 cables and two different terminal softwares and only thing which came to screen was character €.

    Only help which i got from everybody was quota for new device.. I must admit that that i don't know how old that device was, but it was sent from that customers HQ..

    Maybe this will help you…

    2.5 Set Up your Switch Using Console Access
    Out-of-band management requires connecting a terminal, such as a VT-100 or a PC running a
    terminal-emulation program (such as HyperTerminal, which is automatically installed with
    Microsoft Windows) to the RS-232 DCE console port of the switch. Switch management using
    the RS-232 DCE console port is called Local Console Management to differentiate it from
    management done via management platforms, such as DView or HP OpenView.
    Make sure the terminal or PC you are using to make this connection is configured to match these
    settings. If you are having problems making this connection on a PC, make sure the emulation
    is set to VT-100 or ANSI. If you still don’t see anything, try pressing <ctrl>+ r to refresh the
    First-time configuration must be carried out through a console, that is, either (a) a VT100-type
    serial data terminal, or (b) a computer running communications software set to emulate a
    VT100. The console must be connected to the Diagnostics port. This is an RS-232 port with a
    9-socket D-shell connector and DCE-type wiring. Make the connection as follows:
    1. Obtain suitable cabling for the connection.
    You can use a null-modem RS-232 cable or an ordinary RS-232 cable and a null-modem adapter. One end
    of the cable (or cable/adapter combination) must have a 9-pin D-shell connector suitable for the Diagnostics
    port; the other end must have a connector suitable for the console’s serial communications port.
    2. Power down the devices, attach the cable (or cable/adapter combination) to the correct ports, and
    restore power.
    3. Set the console to use the following communication parameters for your terminal:
    . The console port is set for the following configuration:
    . Baud rate: 115200
    . Data width: 8 bits
    . Parity: none
    . Stop bits: 1
    . Flow Control none</ctrl>

  • well that 80c is a firewall and have different baudrates, that device is doa, tried everything what manuals told.. but thanks anyway

  • Have you attempted to force a flash ??

  • No I haven't(why would I), I had no time because customer were losing some during offhours, i just need the get them to Internet. I sent that piece of cr.. to their HQ and put pfsense up and running in the mean time.

  • Nevermind…
    Just saw what the FG-80c is LOL

  • I bought a Switch:

    You have the manual?

    Can you help me set up?

  • I also just bought this switch, and am looking for a manual. I see you have a lot of the same ideas as I. I'm running an HP DL365 with 2 x Dual Core Opterons @ 2.6Ghz, 32GbRam, and a pair of Myricom 10GB Ethernet cards as well as the onboard 1Gb Nics for Management, and Bridging over to my Apple Network. I'm running the Astaro Internet Security Gateway as my OS on that part of the DMZ. But now that I have additional 10Gb cards in my ESX boxes, I needed a switch to connect everything up instead of going direct from 10Gb Nic to 10Gb Nic.

  • Got this from my companies Dell rep. Apparently Dell encompases Fortinet, who Bought out Woven, and the FortiSwitch-100 is the same thing as the Woven Switch. So here's the link to the manual. Just click on the FortiSwitch-100

    Hope this helps everyone out.

Log in to reply