Change captive portal login page url



  • Hi guys,

    I'm using pfsense 2.0.1-RELEASE (i386).
    I use a default login/error/logout page and set "after authentication Redirection URL" to http://www.google.com
    After I activate the captive portal service and open a web browser and trying to navigate to www.google.com (After insert the username and password, no redirect page to www.google.com.), I had noticed that my login page url is http://209.85.175.94:8000/index.php?redirurl=http%3A%2F%2Fwww.google.com.my%2F. I don't know where is the ip 209.85.175.94 came from  ???.

    Anyone can advice me where and which file I need to edit so I can point it to my pfsense LAN interface (192.168.0.1) or WAN interface. I wish my login page url is something like this  http://192.168.0.1:8000 or http://my-pfsense-wan-interface:8000  ;D

    Thanks in advance  :)



  • http://209.85.175.94/ is google.com
    Did you enable CP too run on the WAN or LAN interface?



  • Good day Alan87i,

    Thanks for the reply. CP was enable on LAN interface.
    You stated that 209.85.175.94 is a google.com and when I put the IP on firefox address bar it shown a google page, so I remove http://www.google.com from "after authentication Redirection URL".

    I had try navigate several pages and I had noticed that each address page I try to navigate , the cp will prompt a login page with the url format
    http://the-ip-page-you-want-to-brows:8000/index.php?redirurl=http%3A%2F%2Fthe-human-readable-address-page%2F.

    google - 209.85.175.94 -
    yahoo - 106.10.170.118 -
    facebook - 69.171.237.32 -

    After inserted the username and password, the page not redirected to redirurl (redirurl=http%3A%2F%2Fthe-human-readable-address-page%2F). Under cp status the user is online and I can navigate to any address I wish using another browser tab. Yeaaaaaaa seem like I need to seek for redirect page solution and I can remove http://192.168.0.1:8000 or http://my-pfsense-wan-interface:8000 from my wishes list ;D

    Thank you..

    p/s: If cp enable on WAN, cp not prompt a login page  :(



  • I messed with it on 2.1 beta and noticed the same thing. I'm using radius2 as well , I had to re save CP and radius users to get things working again with the redirect url blank.


Locked