Проблема со squidguard…?



  • Warning: Invalid argument supplied for foreach() in /usr/local/www/pkg_edit.php on line 423

    Вот такое сообщение вываливается в бегущую строку, при попытке внесения изменений. Раньше не было. Изменения не сохраняются -  Config восстанавливается с бэкапа самим pfsense.

    log

    un 27 15:39:02 php: /pkg_edit.php: XML error: Undeclared entity error at line 1533 in /conf/config.xml
    Jun 27 15:39:02 php: /pkg_edit.php: pfSense is restoring the configuration /cf/conf/backup/config-1340799092.xml
    Jun 27 15:39:02 php: /pkg_edit.php: New alert found: pfSense is restoring the configuration /cf/conf/backup/config-1340799092.xml
    Jun 27 15:39:02 check_reload_status: Syncing firewall
    Jun 27 15:39:02 check_reload_status: Syncing firewall

    Появляется эта ошибка только на вкладке : Proxy filter SquidGuard: Groups Access Control List (ACL) при нажатии "save" даже БЕЗ внесения изменений

    На других - НЕТ!



  • Посмотрите что за ошибка в строке файла.

    Undeclared entity error at line 1533 in /conf/config.xml
    


  • @dvserg:

    Посмотрите что за ошибка в строке файла.

    Undeclared entity error at line 1533 in /conf/config.xml
    

    Тогда вопрос, - не вручную же считать? Как пронумеровать?
    И вот еще.

    Proxy filter SquidGuard: Target categories - тычу "save" и вот:

    Jun 28 08:24:06 php: /pkg_edit.php: XML error: Undeclared entity error at line 1468 in /conf/config.xml
    Jun 28 08:24:06 php: /pkg_edit.php: pfSense is restoring the configuration /cf/conf/backup/config-1340860703.xml
    Jun 28 08:24:06 php: /pkg_edit.php: New alert found: pfSense is restoring the configuration /cf/conf/backup/config-1340860703.xml
    Jun 28 08:24:06 check_reload_status: Syncing firewall



  • Попробуйте выгрузить/загрузить конфиг без пакетов, потом настройте пакеты заново.



  • @dvserg:

    Попробуйте выгрузить/загрузить конфиг без пакетов, потом настройте пакеты заново.

    Восстановление в заводские с поднятием бэка - не помогло. Зато новая установка с поднятием бэка - все ок(вот тут респект разработчикам - все БЫСТРО и ПРОСТО не в первый раз убеждаюсь).

    Возможно, возможно дело было в "установке" language pack для сенса. Хотя точно не знаю. Но это было единственное глобальное изменение, которое, кстати, не помогло(язык так и не изменился).



  • @artemvst:

    Возможно, возможно дело было в "установке" language pack для сенса. Хотя точно не знаю. Но это было единственное глобальное изменение, которое, кстати, не помогло(язык так и не изменился).

    Очень странно, что вы не указали это при создании топика.


Locked