How to allow 1 website to pass through the firewall



  • ????
    sounds easy but i have been looking into it hours and hours but i can't figure it out, on a previous router i had i would just insert the name on a list and that was it, here on PFSense there are so many options and technical stuff i can't understand…
    thank youuu



  • You want to run a website from your network, accessible from the Internet?

    You'll want to forward port 80 (and 443 if you're using HTTPS) to the LAN IP of the web server. See this FAQ on port forwarding.



  • Hi Cry Havok, thanks for your reply.
    What i would like to achieve, is being able to use Facebook.
    Right now i can reach the login page, but as soon as you try to login, it takes you nowhere, as the PFSense firewall is blocking this step (firewall rule "1/0 match case" ???).
    On my WAN (192.168.5.1) everything is working fine, all machines connected with a network cable don't have any issues.
    The problem is on my wireless network (LAN 192.168.1.1), as soon as you try to login, it just goes to a blank page.
    Right now i am testing with my telephone (192.168.1.15), i forwarded the HTTPS port (443) to it, but it still doesn't work.
    Googling up a bit, i did read that apparently Facebook is using a random port that range from 30000 to 60000 instead of the usual port 443, how can i fix that?
    I would like all the machines connected on the LAN to be able to browse this particular website, possibly without having to configure a port forward rule for each one of them.
    Thanks

    ![Firewall PF.jpg](/public/imported_attachments/1/Firewall PF.jpg)
    ![Firewall PF.jpg_thumb](/public/imported_attachments/1/Firewall PF.jpg_thumb)
    ![Firewall PF Details.jpg](/public/imported_attachments/1/Firewall PF Details.jpg)
    ![Firewall PF Details.jpg_thumb](/public/imported_attachments/1/Firewall PF Details.jpg_thumb)
    ![Connection Error.jpg](/public/imported_attachments/1/Connection Error.jpg)
    ![Connection Error.jpg_thumb](/public/imported_attachments/1/Connection Error.jpg_thumb)



  • No solution has been Pfound, however a work around to it is by using a web proxy to bypass your own firewall…i know it isn't great but so far it works...



  • @EOC2611P:

    No solution has been Pfound, however a work around to it is by using a web proxy to bypass your own firewall…i know it isn't great but so far it works...

    Web proxy is the best way to filter http/https sites. your nat rules looks like a transparent proxy attempt, but I think they are not correct.



  • Hi Marcelloc, yes i think some of the settings are not right too, so i posted some screenshot in the hope that someone more knowledgeable than me could spot it and eventually suggest a fix…  :D



  • Did you finished your setup or still need help on it?



  • Ehrm, yes i guess i am done with the setup, thanks for helping me knowing there was something wrong, even if i know very very little about firewalls it didn't take me long to reach the same conclusion on my own  :D
    The other day i did try to twist settings a bit, hoping in a bit of luck but it got even worse, much worse, i had to resort to a restore option i found and it restarted working but still with the same problem (problem= Facebook.com goes to a blank page soon after the login).


Log in to reply