High Latency



  • I have been experiencing nothing but gaming problems when playing Starcraft on battlenet. Even when traffic shaping is disabled my games lag badly. Since I switched to my old Linksys router the problem when away. Not sure what caused it.



  • Run a tcpdump and replay in ethereal/wireshark looking for obvious errors, tcp resets, etc.



  • Yeh .. I found the problem and a work around, but no solution; Like the guys says in the thread link below If I create the games it runs flawless, so I'm ok with that.

    http://www.bsdforums.org/forums/showthread.php?t=11840



  • OK found a solution.. tried static-port to the starcraft servers, stumbled across this in on google.

    I assume you're behind a PF firewall with NAT (not bi-nat)?  The
    dynamically assigned ports are hosing it up (it seems that Starcraft
    embeds the ephemeral port number in it's payload, rather than using the
    TCP/UDP header).  Needless to say, that was a fun one to track down
    (everyone blamed my Mac at first).  You can either bi-nat the address of
    your machine that plays Starcraft, or you can use static-port on your
    nat statement.

    taken from: http://groups.google.com.jm/group/lucky.openbsd.misc/browse_thread/thread/f753b80ec32f25fc/17b79f5e491f92af%2317b79f5e491f92af



  • @Leoandru:

    OK found a solution.. tried static-port to the starcraft servers, stumbled across this in on google.

    You can either bi-nat the address of
    your machine that plays Starcraft, or you can use static-port on your
    nat statement.

    Hey. i dont know what you mean by this. Do you mean bi directional nat? Why wouldn't my nat be bi directional? I am having the exact same problem with my pfsense and starcraft. How did you fix? I can see the outbound area has a "static map" option but I have no idea what to put where.



  • Anyone figure out how to fix this? :P



  • still the same answer: use static port.
    search the forum for how to.



  • The only solution for low latency I found satisfactory is this:

    Save your current non-Gamer b]Traffic Shaper configuration.
    Modify the Traffic Shaper so you have only these Queues (4096/512 connection)

    Flags  		Priority  	Default  	Bandwidth  	Name  	 
    		0  		No		496 Kb   	qwanRoot
    		0  		No		3968 Kb   	qlanRoot
    	  	7  		No		52 %   		qGamesUp
    	  	7  		No		32 %   		qGamesDown	
    		3  		Yes		7 %   		qwandef
    		3  		Yes		1 %   		qlandef
    ACK		6		No 		40 %   		qwanacks  
    ACK		6		No 		5 %   		qlanacks 
    RED ECN		1  		No 		1 %   		qP2PUp   	
    RED ECN		1  		No 		1 %   		qP2PDown  
    

    Your IP = Gamer Queue (192.168.0.189  in my case)
    The Rest = p2p Queue (put a value for Upperlimit)

    If  		Proto  		Source  	Destination  	Target  		Description  	
    LAN->WAN	* 		192.168.0.189 	* 		qGamesUp/qGamesDown 	m_Game DC_outbound
    
    WAN->LAN	* 		* 		192.168.0.189 	qGamesDown/qGamesUp 	m_Game DC_inbound   	
    
    LAN->WAN	* 		LAN net 	* 		qP2PUp/qP2PDown 	p2pCatchAll outbound
    
    WAN->LAN	* 		* 		LAN net 	qP2PDown/qP2PUp 	p2pCatchAll inbound
    
    LAN->WAN	* 		LAN net 	* 		qP2PUp/qP2PDown 	p2pCatchAll outbound
    
    WAN->LAN	* 		*	 	LAN net 	qP2PDown/qP2PUp 	p2pCatchAll inbound  
    

    After you finish playing restore the NON-Gamer Traffic Shaper configuration

    alone without router 40ms PING
    Using normal Traffic Shaping 70-110 PING
    With this TIP +- 48-58ms PING



  • @GruensFroeschli:

    still the same answer: use static port.
    search the forum for how to.

    Well since I dont consider RTFM to be an acceptable answer, I will detail the steps I performed.

    Go into nat and go to the outbound nat tab.

    Enable advanced outbound nat, and add the ports (you have to add them one by one, theres no ranges :( ) with the source being the local network and you are going out over the wan. I believe this will force it to look like its comming out of the firewall on those particular ports. Make sure you check the box that says "static port"

    once you make the 10 or so rules (6112-6119, 4000, 27960), move them above the default wan rule created titled "auto created rule for lan". This will hopefully see them being passed first.

    I have not tested this as i need to get my 3 friends all together to try a game, but this is basically how i think static port forwarding works. There was a guy who tried to get suppreme commander working that was having similar issues.

    I will post again if things work out.



  • your step-by-step is accurate :)
    btw: this guy that had problems with supreme commander was me and i solved all my problems with this.



  • bi-nat? iv got my traffic shaper switched off because it makes ventrilo lag, but i still have the problem with starcraft

    update
    i stopped the lag with the static NAT option but i still cant create games.


Log in to reply