FAILOVER CON 2 WAN ppoe no FUNCIONA



  • Buenas,
    mi caso es bastante sencillo.
    En un primer momento configure dos router de telefonica (WAN1 WAN2) y una LAN con pfsense.
    Estaban en failover, es decir, el Gateway del WAN1 era el preferido, luego WAN1 lo puse como TIER1 y WAN2 TIER2.
    Los router no estaban en modo bridge y todo andaba bien, apagaba un router y salia por el otro, y viceversa.

    El problema llego cuando decidi poner los router en modo bridge…..le puse a ROUTER1-de WAN1 una ip 192.168.1.1 y bridge, luego al router2 de WAN2 una ip 192.168.20.1. y modo bridge tambien
    Le active el cliente ppoe a cada una de las WAN del pfsense
    Probe cada router por separado con el cliente ppoe de windowsXP por separado.
    Probe el pfsense con cada una de las WAN por separado

    Todo lo demas igual, el failover tambien.
    El tema es que no hace failover, y ademas hay varias cosas que no me cuandran.....:

    1-esto me sale en system gateways:

    GW_WAN (default) WAN1 80.58.67.111 80.58.67.111 Interfacewandynamic gateway
    GW_OPT1                 WAN2        80.58.67.111 80.58.67.111      Interfaceopt1dynamic gateway

    por que me pone MONITOR una ip que no se de donde sale y no se le puede hacver ping????
    por que si se la cambio y le pongo una personalizada.......ni caso???

    2-esto me sale en status gateways:

    GW_WAN 80.58.67.111    Gathering data    Interfacewandynamic gateway
    GW_OPT1 80.58.67.111    Offline               Interfaceopt1dynamic gateway
    No entiendo por que sale Offline si estan las dos online??????

    3- En el dashboard me salen en WAN1 una ip publica y en WAN2otra ip publica (las tengo dinamicas), esto esta bien supongo.....
    4- mi equipo de la lan, siempre me sale por la WAN2....por que???, si lo tengo WAN1 como predeterminada?
    5-el failover no va...si estoy saliendo por la WAN2 y la tiro abajo, para que salga por la WAN1, tengo que ir a GATEWAYS GROUPS de nuevo y decirle que haga failover de la WAN2 A LA WAN1, entonces si sale por la 1, si lo hago a la inversa lo mismo, o sea , manualmente....
    Estoy haciendo algo mal????por que ha cambiado la manera de comportarse cuando se ponen los routers en bridge???
    Hay una cosa que he notado, se ha eliminado una rule de la LAN....la del failover de WAN1 A WAN2, esta creo que se hace automatica cuando creas el failover o tengo que hacerla manualmente???

    GRACIAS


  • Rebel Alliance

    Hace tiempo habia realizado pruebas con 2 WAN PPPoE (del mismo ISP), y funcionó correctamente, lo único que debes hacer es cambiar las IPs de monitoreo de los GW

    http://forum.pfsense.org/index.php/topic,46969.msg247446.html#msg247446



  • Muchas gracias, según lo que leo en el link q Has puesto, hay que actualizar a la 2.01.
    Además de esto…hay q añadir reglas para la LAN, o las añade solo al hacer en grupo?



  • otra duda que tengo es por que el gw que me da el isp no responde al Ping, supongo q por eso las WAn me aparecen siempre como Offline??



  • Lo que yo hice es poner en monitor el ip de google

    puedes poner en monitor alguna ip de alguna pagina el problema es que es del mismo proveedor y el mismo servidor

    Saludos


  • Rebel Alliance

    @canaryrouter:

    Muchas gracias, según lo que leo en el link q Has puesto, hay que actualizar a la 2.01.
    Además de esto…hay q añadir reglas para la LAN, o las añade solo al hacer en grupo?

    Si, esto es valido para la Version 2.0.1

    http://blog.pfsense.org/?p=633

    » Added patch to mpd to allow multiple PPPoE connections with the same remote gateway

    Las Reglas en LAN, las tienes que crear, no se crean automaticamente.
    Si tienes unicamente la "Allow LAN to ANY  " la puedes editar y cambias el GW "*" (default) por el Grupo que creaste….
    aunque hay conexiones que no trabajan bien con "Load balance" (HTTPS <--> 443), y debes crear un grupo tipo "fail over" para esos puertos / conexiones.

    http://doc.pfsense.org/index.php/Multi-WAN_2.0

    @canaryrouter:

    otra duda que tengo es por que el gw que me da el isp no responde al Ping, supongo q por eso las WAN me aparecen siempre como Offline??

    Yo lo que hago es un "Trace route" a distintos sitios conocidos, desde cada WAN y veo alguna IP publica, que responda a los pings, por la que esten pasando y sea una de las ultimas en mi pais, y las utilizo como monitor…

    Saludos


Log in to reply