LACP No consigo aumentar el ancho de banda



  • Tengo un pfSense 2.0.1 x64 instalado en un servidor con 9 puertos de red a 1Gbps cada uno, 1 de ellos integrado y los otros 8 en 2 tarjetas PCI-X cada una con 4 puertos he configurado dos interfaces LAGG cada una con 4 puertos y con el "PROTO" en "LACP",

    LAGG-LAN (em0, em1, em2, em3)
    LAGG-DMZ (em4, em5, em6, em7)

    El primer LAGG-LAN esta conectado a un switch 3Com 4500G configurado con "Link Aggregation" static desde el puerto 1 al 4
    El segundo LAGG-DMZ esta conectado a un switch 3Com 4500G configurado con "Link Aggregation" static desde el puerto 1 al 4

    al ejecutar pruebas con Iperf no consigo aumentar el ancho de banda, he intentado desde diferentes equipos y diferentes vlan pero no supera el ancho de banda proporcionado por un solo puerto. La siguiente salida fue ejecutada desde un equipo y es el maximo q alcanza, cuando se ejecuta desde varios equipos este inicia una disminución que depende del usado por los otros equipos.

    Client connecting to 192.168.210.21, TCP port 5001
    TCP window size: 0.13 MByte (default)
    –----------------------------------------------------------
    [  4] local 192.168.1.133 port 55251 connected with 192.168.210.21 port 5001
    [ ID] Interval       Transfer     Bandwidth
    [  4]  0.0- 1.0 sec  63.1 MBytes   530 Mbits/sec
    [  4]  1.0- 2.0 sec  60.5 MBytes   508 Mbits/sec
    [  4]  2.0- 3.0 sec  61.9 MBytes   519 Mbits/sec
    [  4]  3.0- 4.0 sec  64.4 MBytes   540 Mbits/sec
    [  4]  4.0- 5.0 sec  61.6 MBytes   517 Mbits/sec
    [  4]  5.0- 6.0 sec  63.2 MBytes   531 Mbits/sec
    [  4]  6.0- 7.0 sec  63.0 MBytes   528 Mbits/sec
    [  4]  7.0- 8.0 sec  62.2 MBytes   522 Mbits/sec
    [  4]  8.0- 9.0 sec  63.2 MBytes   531 Mbits/sec
    [  4]  9.0-10.0 sec  56.8 MBytes   476 Mbits/sec
    [  4]  0.0-10.0 sec   620 MBytes   520 Mbits/sec

    he buscado información pero no consigo mucha documentación en este tema, de ante mano gracias por cualquier aporte.



  • Mira que tráfico está soportando cada interface y comprueba que protocolo de balanceo LACP estás utilizando, es posible que siempre esté balanceando por el mismo interface al hacer las pruebas.



  • En las pruebas que he realizado solo veo q el trafico es enviado por una interfaz, donde debería configurar el protocolo de balanceo para LACP en el switch he probado de manera dinamica y estatica.



  • Eso depende del switch, normalmente si usas 802.3ad te permitirá balancear por nivel2 (segun las macs del paquete balancea) o por nivel3-4 (segun las ips y puertos balancea). Configuralo de forma que balancee según ip y puerto y así conseguirás un balanceado mucho más eficiente.



  • No estoy seguro si el switch que estoy utilizando soporte esta configuración, tengo un 3Com 4500G con la ultima version del software 5.2 emitida por HP, si es nivel3-4 donde debería configurarlo ?



  • No conozco ese switch pero en el manual seguro que viene como configurar el balanceo para LACP.


Log in to reply