Sıfır Kurulum sonrası Squid ve Squidguard Start etmiyor



  • Arkadaşlar selamlar,
    Periyodik olarak 2 yıldır sistem çalışır durumda idi 15-20 günlük uptime aralıklarında makineyi reboot ediyordum gayet sorunsuz bir şekilde çalışıyordu en son reboot ettikten sonra squid ve squidguard servisleri start olmuyor start olacakken aşağıdaki hataları system loglarına düşüyor Pfsense 1.2.3 ve 2.0 versiyonlarını tüm sistemi baştan kurdum ettim yok yok yok servisler start olmuyor bu hataları internette aradım bulduğum sayfalardaki adımları uyguladım fakat nafile daha önce böyle bir sorunla karşılaşan arkadaşlar varsa onlardan destek bekliyorum saygılar.

    Sistem kurulurken ve paketlerin kurulum aşamasında hiçbir sorun olmadan kuruyor fakat start etmiyor servisleri

    Jul 27 07:29:51 php: : SQUID is installed but not started. Not installing "filter" rules.
    Jul 27 07:29:51 php: : SQUID is installed but not started. Not installing "nat" rules.



  • buradaki açılmış konuda da aynı sorun var oradaki gösterilenleri yaptım fakan squid  squidguard start olmuyor :S
    http://forum.pfsense.org/index.php?topic=44525.0#msg231265



  • kimsenin bir fikri yokmu? 30 kişi read etmiş konuyu



  • kardeş  pfsense  makinaya  putty  ile  bağlan
    sonra  komut  satırında squid çalıştırmaya  çalış.

    squid -z 
    

    komutuyla tekrar squid'i başlat



  • @nmnoztrk:

    kardeş  pfsense  makinaya   putty  ile  bağlan
    sonra  komut  satırında squid çalıştırmaya  çalış.

    squid -z 
    

    komutuyla tekrar squid'i başlat

    kardeş öncesinden
    rm -rf /var/squid/cache/* (cache klasörü boşaltıldı)
    rm -rf /var/squid/logs/* (loglar silindi)
    Squid -z komutu girilerek cache directoryleri oluşturulmuştur

    Bu şekilde yaptığımda Squid servisi sadece  cache altındaki directoryler oluşturulana kadar STARTED oluyor directoryler oluştuktan sonra tekrar STOPED durumuna geliyor ve system loglarında  aşağıdaki bilgi düşüyor
    php: : SQUID is installed but not started. Not installing "filter" rules.
    php: : SQUID is installed but not started. Not installing "nat" rules



  • winscp ile bağlanıp squid in kurulu dosyalarının izinlerinde bi problem olmasın.istersen onları bi kontrol et.
    bugün ben  yeni  bir  kurulum  yaptım.sağlıklı  çalışıyor bende. hemde  sanal  makinada.



  • şimdi    sanal  makinada  sıfırdan kurdum.  bendeki  loglar bunlar

    bendede  hatalar  verdi  ama  sorunsuz  çalışıyor.

    check_reload_status: Syncing firewall
    Jul 27 08:54:47 php: /pkg_mgr_install.php: Beginning package installation for squid.
    Jul 27 08:54:48 check_reload_status: Syncing firewall
    Jul 27 08:56:38 php: /pkg_mgr_install.php: Creating squid cache subdirs in /var/squid/cache
    Jul 27 08:56:38 check_reload_status: Syncing firewall
    Jul 27 08:56:38 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k shutdown' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Jul 27 08:56:44 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k kill' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Jul 27 08:56:44 squid[62928]: Failed to make swap directory /var/squid/cache/00: (13) Permission denied
    Jul 27 08:56:44 kernel: pid 62928 (squid), uid 100: exited on signal 6
    Jul 27 08:56:44 php: /pkg_mgr_install.php: Stopping any running proxy monitors
    Jul 27 08:56:45 php: /pkg_mgr_install.php: Creating squid cache subdirs in /var/squid/cache
    Jul 27 08:56:45 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k shutdown' returned exit code '1', the output was 'squid: ERROR: Could not read pid file /var/squid/logs/squid.pid: (13) Permission denied'
    Jul 27 08:56:50 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k kill' returned exit code '1', the output was 'squid: ERROR: Could not read pid file /var/squid/logs/squid.pid: (13) Permission denied'
    Jul 27 08:56:50 squid[2781]: Failed to make swap directory /var/squid/cache/00: (13) Permission denied
    Jul 27 08:56:50 php: /pkg_mgr_install.php: Starting Squid
    Jul 27 08:56:50 kernel: pid 2781 (squid), uid 100: exited on signal 6
    Jul 27 08:56:50 php: /pkg_mgr_install.php: Starting a proxy monitor script
    Jul 27 08:56:50 squid[3435]: Squid Parent: child process 3878 started
    Jul 27 08:56:50 check_reload_status: Reloading filter
    Jul 27 08:56:50 squid[3878]: Cannot open '/var/squid/logs/access.log' for writing. The parent directory must be writeable by the user 'squid', which is the cache_effective_user set in squid.conf.
    Jul 27 08:56:50 squid[3435]: Squid Parent: child process 3878 exited due to signal 6
    Jul 27 08:56:50 kernel: pid 3878 (squid), uid 100: exited on signal 6
    Jul 27 08:56:50 check_reload_status: Syncing firewall
    Jul 27 08:56:50 php: /pkg_mgr_install.php: Creating squid cache subdirs in /var/squid/cache
    Jul 27 08:56:50 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k shutdown' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Jul 27 08:56:53 squid[3435]: Squid Parent: child process 5913 started
    Jul 27 08:56:53 squid[5913]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Jul 27 08:56:53 squid[3435]: Squid Parent: child process 5913 exited due to signal 6
    Jul 27 08:56:53 kernel: pid 5913 (squid), uid 62: exited on signal 6
    Jul 27 08:56:55 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k kill' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Jul 27 08:56:56 squid[3435]: Squid Parent: child process 11614 started
    Jul 27 08:56:57 squid[11614]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Jul 27 08:56:57 squid[3435]: Squid Parent: child process 11614 exited due to signal 6
    Jul 27 08:56:57 kernel: pid 11614 (squid), uid 62: exited on signal 6
    Jul 27 08:57:00 squid[3435]: Squid Parent: child process 17329 started
    Jul 27 08:57:01 squid[17329]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Jul 27 08:57:01 squid[3435]: Squid Parent: child process 17329 exited due to signal 6
    Jul 27 08:57:01 kernel: pid 17329 (squid), uid 62: exited on signal 6
    Jul 27 08:57:04 squid[3435]: Squid Parent: child process 18031 started
    Jul 27 08:57:04 squid[18031]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Jul 27 08:57:04 squid[3435]: Squid Parent: child process 18031 exited due to signal 6
    Jul 27 08:57:04 kernel: pid 18031 (squid), uid 62: exited on signal 6
    Jul 27 08:57:04 squid[3435]: Exiting due to repeated, frequent failures
    Jul 27 08:57:06 php: /pkg_mgr_install.php: Starting Squid
    Jul 27 08:57:06 squid[19072]: Squid Parent: child process 19447 started
    Jul 27 08:57:06 check_reload_status: Reloading filter
    Jul 27 08:57:06 php: /pkg_mgr_install.php: Reloading Squid for configuration sync
    Jul 27 08:57:06 check_reload_status: Reloading filter
    Jul 27 08:57:07 check_reload_status: Syncing firewall
    Jul 27 08:57:08 check_reload_status: Syncing firewall



  • Birşey soracagım önce sqidguard'ı mı kurdunuz?



  • @nmnoztrk:

    şimdi    sanal  makinada  sıfırdan kurdum.  bendeki  loglar bunlar

    bendede  hatalar  verdi  ama  sorunsuz  çalışıyor.

    check_reload_status: Syncing firewall
    Jul 27 08:54:47 php: /pkg_mgr_install.php: Beginning package installation for squid.
    Jul 27 08:54:48 check_reload_status: Syncing firewall
    Jul 27 08:56:38 php: /pkg_mgr_install.php: Creating squid cache subdirs in /var/squid/cache
    Jul 27 08:56:38 check_reload_status: Syncing firewall
    Jul 27 08:56:38 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k shutdown' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Jul 27 08:56:44 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k kill' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Jul 27 08:56:44 squid[62928]: Failed to make swap directory /var/squid/cache/00: (13) Permission denied
    Jul 27 08:56:44 kernel: pid 62928 (squid), uid 100: exited on signal 6
    Jul 27 08:56:44 php: /pkg_mgr_install.php: Stopping any running proxy monitors
    Jul 27 08:56:45 php: /pkg_mgr_install.php: Creating squid cache subdirs in /var/squid/cache
    Jul 27 08:56:45 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k shutdown' returned exit code '1', the output was 'squid: ERROR: Could not read pid file /var/squid/logs/squid.pid: (13) Permission denied'
    Jul 27 08:56:50 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k kill' returned exit code '1', the output was 'squid: ERROR: Could not read pid file /var/squid/logs/squid.pid: (13) Permission denied'
    Jul 27 08:56:50 squid[2781]: Failed to make swap directory /var/squid/cache/00: (13) Permission denied
    Jul 27 08:56:50 php: /pkg_mgr_install.php: Starting Squid
    Jul 27 08:56:50 kernel: pid 2781 (squid), uid 100: exited on signal 6
    Jul 27 08:56:50 php: /pkg_mgr_install.php: Starting a proxy monitor script
    Jul 27 08:56:50 squid[3435]: Squid Parent: child process 3878 started
    Jul 27 08:56:50 check_reload_status: Reloading filter
    Jul 27 08:56:50 squid[3878]: Cannot open '/var/squid/logs/access.log' for writing. The parent directory must be writeable by the user 'squid', which is the cache_effective_user set in squid.conf.
    Jul 27 08:56:50 squid[3435]: Squid Parent: child process 3878 exited due to signal 6
    Jul 27 08:56:50 kernel: pid 3878 (squid), uid 100: exited on signal 6
    Jul 27 08:56:50 check_reload_status: Syncing firewall
    Jul 27 08:56:50 php: /pkg_mgr_install.php: Creating squid cache subdirs in /var/squid/cache
    Jul 27 08:56:50 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k shutdown' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Jul 27 08:56:53 squid[3435]: Squid Parent: child process 5913 started
    Jul 27 08:56:53 squid[5913]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Jul 27 08:56:53 squid[3435]: Squid Parent: child process 5913 exited due to signal 6
    Jul 27 08:56:53 kernel: pid 5913 (squid), uid 62: exited on signal 6
    Jul 27 08:56:55 php: /pkg_mgr_install.php: The command '/usr/local/sbin/squid -k kill' returned exit code '1', the output was 'squid: ERROR: No running copy'
    Jul 27 08:56:56 squid[3435]: Squid Parent: child process 11614 started
    Jul 27 08:56:57 squid[11614]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Jul 27 08:56:57 squid[3435]: Squid Parent: child process 11614 exited due to signal 6
    Jul 27 08:56:57 kernel: pid 11614 (squid), uid 62: exited on signal 6
    Jul 27 08:57:00 squid[3435]: Squid Parent: child process 17329 started
    Jul 27 08:57:01 squid[17329]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Jul 27 08:57:01 squid[3435]: Squid Parent: child process 17329 exited due to signal 6
    Jul 27 08:57:01 kernel: pid 17329 (squid), uid 62: exited on signal 6
    Jul 27 08:57:04 squid[3435]: Squid Parent: child process 18031 started
    Jul 27 08:57:04 squid[18031]: Failed to verify one of the swap directories, Check cache.log for details. Run 'squid -z' to create swap directories if needed, or if running Squid for the first time.
    Jul 27 08:57:04 squid[3435]: Squid Parent: child process 18031 exited due to signal 6
    Jul 27 08:57:04 kernel: pid 18031 (squid), uid 62: exited on signal 6
    Jul 27 08:57:04 squid[3435]: Exiting due to repeated, frequent failures
    Jul 27 08:57:06 php: /pkg_mgr_install.php: Starting Squid
    Jul 27 08:57:06 squid[19072]: Squid Parent: child process 19447 started
    Jul 27 08:57:06 check_reload_status: Reloading filter
    Jul 27 08:57:06 php: /pkg_mgr_install.php: Reloading Squid for configuration sync
    Jul 27 08:57:06 check_reload_status: Reloading filter
    Jul 27 08:57:07 check_reload_status: Syncing firewall
    Jul 27 08:57:08 check_reload_status: Syncing firewall

    nmnoztrk kardeşim izinlerle ilgili bir sorun yok olmuş olsa squid paketi kurulum sonrası  cache swap directory leri oluştururken sorun çıkartır sorunum halen devam ediyor  >:(
    Blasterreal kardesim ilk squid paketini kuruyorum ardından squidguard paketini kuruyorum.



  • Jul 28 09:15:30 php: : SQUID is installed but not started. Not installing "filter" rules.
    Jul 28 09:15:30 php: : SQUID is installed but not started. Not installing "nat" rules.
    Jul 28 09:15:29 check_reload_status: reloading filter
    Jul 28 09:15:17 php: /pkg_mgr_install.php: Starting Squid
    Jul 28 09:15:08 php: : SQUID is installed but not started. Not installing "filter" rules.
    Jul 28 09:15:08 php: : SQUID is installed but not started. Not installing "nat" rules.
    Jul 28 09:15:08 check_reload_status: reloading filter
    Jul 28 09:14:53 php: /pkg_mgr_install.php: Starting Squid
    Jul 28 09:14:47 php: : SQUID is installed but not started. Not installing "filter" rules.
    Jul 28 09:14:47 php: : SQUID is installed but not started. Not installing "nat" rules.
    Jul 28 09:14:46 check_reload_status: reloading filter
    Jul 28 09:14:31 php: /pkg_mgr_install.php: Starting Squid
    Jul 28 09:14:09 php: /pkg_mgr_install.php: Beginning package installation for squidGuard.
    Jul 28 08:56:39 php: : SQUID is installed but not started. Not installing "filter" rules.
    Jul 28 08:56:39 php: : SQUID is installed but not started. Not installing "nat" rules.
    Jul 28 08:56:39 check_reload_status: reloading filter
    Jul 28 08:56:28 php: : SQUID is installed but not started. Not installing "filter" rules.
    Jul 28 08:56:28 php: : SQUID is installed but not started. Not installing "nat" rules.
    Jul 28 08:56:28 php: /pkg_edit.php: Starting Squid
    Jul 28 08:56:27 check_reload_status: reloading filter
    Jul 28 08:56:16 php: /pkg_edit.php: Starting Squid



  • Arkadaşlar merhaba;

    Tanıdığım bir kaç işletme dede pfsense ver. 1,2,3 kullanılıyor durum vaziyet ve servislerin start almaması oralarda da aynı ben bugünden itibaren versiyon 2ye geçtim 6saattir uptime da makina herhangi bir sıkıntı yok paketlerden squid+squidguard +lightsquid +imspector sorunsuz çalışıyor yinede açmış olduğum konuya karşılık olarak desteğini veren arkadaşlara teşekkürlerimi iletir iyi çalışmalar Güvenli günler dilerim.


Log in to reply