Migrate voucher settings to new computer not succesful



  • Hi,

    When I migrate all settings using the backup/restore functionality from the webgui; all vouchers are marked "ready" also the vouchers that were marked "used" in the old situation.

    How do I backup and restore the original status of the vouchers?

    Background info:
    I'm migrating pfSense 2.0.1 from a x86 machine where it is installed on the harddisk to a KVM-x64 Virtual Machine.
    The pfSense on the x86 is fully operational in production and the pfSense on the VM is tested and working in the test stage.
    All settings are migrated correctly using the backup/restore functionality, except for the original status of the vouchers.
    The backup is performed from the webgui with the option "all" and also includes the RRD data.

    Searching this forum I did not find the answer to my question. I was however able to locate the files concerned under:
    /var/db/voucher_active_x.db and voucher_used_x.db

    Is there an easy way of migrating the status of the vouchers?
    If this needs to be done by coping the db's, what other db's do I need to copy? captiveportal.db for example?



  • I saw the same problem on upgrading from pfSense 2.0.1 to 2.1 some months ago. To the best of my knowledge it hasn't been addressed.



  • This indicates that a simple migration of the status of vouchers is not an option.

    Then these questions remain:
    1. What files to transfer after the regular Backup/Restore ?
    2. How to transfer the files?



  • I would be interested in this questions, too.
    What will happen if both machines a running in a CARP cluster ? Will this sync the vouchers ?



  • Seems this topic is not solved since today.
    An update from 2.0.2 to 2.0.3 does not work for me, so I decided to install 2.0.3 and restore the backup configuration where also the active voucher status is stored.
    After restoring the backup in 2.0.3 the configuration is back fine, but not the status of the active vouchers. All are unused again.

    I filed a bug report and hope this will be solved soon:
    https://redmine.pfsense.org/issues/3128

    Anyone another idea how to restore the active voucher status?

    Thanks.
    Klaus



  • @klausf:

    Seems this topic is not solved since today.
    An update from 2.0.2 to 2.0.3 does not work for me, so I decided to install 2.0.3 and restore the backup configuration where also the active voucher status is stored.
    After restoring the backup in 2.0.3 the configuration is back fine, but not the status of the active vouchers. All are unused again.

    I filed a bug report and hope this will be solved soon:
    https://redmine.pfsense.org/issues/3128

    Anyone another idea how to restore the active voucher status?

    Thanks.
    Klaus

    That's also our problem, I wish some pf experts in this forum would lend a hand.



  • i had gone through the same probelm any find the solution??????????



  • @ishtiaqaj:

    i had gone through the same probelm any find the solution??????????

    ishtiaqaj,

    See if the proposed work around resolve your issue.

    https://forum.pfsense.org/index.php?topic=97457.msg543099#msg543099