Problema con OpenVPN



  • Buenos días, me estoy iniciando en el mundo de pfsense, ya logré configurar un equipo AMD Athlon con DD de 40gb y 1GB Ram, tiene una lan interna de 10/100 y le coloque 2 PCI 10/100/1000 ya que tengo 2 redes que administrar y no tenemos un switch que haga vlan, todo anda muy bien, el problema es que necesitamos que los ejecutivos de ventas se conecten vía OpenVPN a una de las redes LAN, lei el manual de OpenVPN-Road-Warrior y anda muy bien pero en mi red Local, realiza la conexión con éxito, ahora cuando me voy a casa e intento conectarme me da error y me dice que no puede conectarse, el archivo .conf esta bien con la dirección Ip de la WAN de mi oficina sin embargo no logró conectarme, agradezco la ayuda de antemano. :)



  • Hola.

    Puedes mostrar las pantallas de configuracion de tu pfsense y la configuracion que estas usando desde tu casa.

    Saludos!!!



  • Buenos días gracias por tu respuesta, ya logré que se establezca la conexión sin embargo no he logrado acceder a ninguna de mis redes LAN, debo crear alguna regla ? por lo que leí el asistente hace todo, se que se establece la conexión porque tengo asignando a la vpn un rango 172.16.7.10 y esa es la Ip que obtengo, ademas apunto a la 172.16.7.1 y me aparece la pantalla de login de pfsense(que me dice que no es una red interna así que no me dejará lobearme). pero hago ping a mi lan que está en 172.16.0.1 y nada.. agradezco de antemano su ayuda



  • Hola.

    Agregastes los comandos: push, route?

    Push routes to the client to allow it

    to reach other private subnets behind

    the server.  Remember that these

    private subnets will also need

    to know to route the OpenVPN client

    address pool (10.8.0.0/255.255.255.0)

    back to the OpenVPN server.

    ;push "route 192.168.10.0 255.255.255.0"

    EXAMPLE: Suppose the client

    having the certificate common name "Thelonious"

    also has a small subnet behind his connecting

    machine, such as 192.168.40.128/255.255.255.248.

    First, uncomment out these lines:

    ;route 192.168.40.128 255.255.255.248

    Por ultimo recuerda que la version 2.0.1 ya hay reglas en el firewall para la interface de la vpn.

    Saludos!!!



  • periko gracias por tu ayuda, fijate que tengo dos PC´s, una Macbook pro que me conecto a la vpn con viscosity y anda muy bien, todo correcto, pero mi pc con Windows se establece la conexión, me asigna la IP y todo bien, pero no logro hacer ping a la LAN de la oficina, es muy extraño, sin embargo desde pfsense veo que si aparezco como conectado con la de windows, hay algo que configurar dependiendo del SO ?, Gracias amigo Periko por tu ayuda



  • De otras maquinas si puedes llegarle a red externa?
      Solo el problema lo tienes con ese equipo?
      Saludos!!!



  • Hola disculpa que antes no respondí los equipos con ubuntu y Mac se conectan normal solo la de Windows no tiene acceso



  • solo la de Windows no tiene acceso

    Prueba deshabilitando el cortafuegos de Windows… y/o el antivirus.

    Puede que tengas que ajustar el cortafuegos de Windows y/o el antivirus.

    ¿Qué versión de cliente OpenVPN tienes en Windows? ¿Qué versión de Windows?

    Saludos,

    Josep Pujadas-Jubany


Locked