Cannot Access GUI pfsense version 2.0



  • I have a very interesting problem: I can no longer access the web GUI on my main pfsense router. Attempting to go to the page results in an eventual "the connection has timed out" msg in Firefox. Attempted with other browsers on other computers; same result.

    
    telnet 192.168.1.1 80
    GET /
    
    

    Does produce terminal output from lighttpd (a 400 bad request).

    I was able to retrieve a copy of the config from "/cf/conf/config.xml" by using scp. I don't see any problems with the config.

    Here is where things get really interesting: I installed pfsense 2.0 on another box thinking that the hard drive on the original might be going. The new box exhibits the exact same behavior (timeout for accessing the GUI).

    Note that the network is continuing on fine; IPSEC is connected and there are no hiccups. I just cannot access the web GUI.



  • Clarification: I have attempted option 11 (reset webconfigurator). I copied the config from the main router to the new box (it worked just fine right after the install).



  • I ran a tcpdump on the test box- looks like the connection to the box is being sent to https even though I had https disabled in the GUI.

    Looking into this.



  • Under the "<webgui>" section in the config.xml, I changed the "<protocol>" from http to https and was able to access the test box GUI.

    I changed the protocol back to "http" in the GUI, and did not experience the issue again.

    I have no clue as to why that happened.</protocol></webgui>


Locked