OpenBGPd проблемы после установки



  • Здравствуйте.
    Не так давно настраивал связку: http://forum.pfsense.org/index.php?PHPSESSID=52nviguncg3ngqpinfqfhjfe66&topic=46671.0
    Всё хорошо работало.

    Прошло время. настраиваю такую же связку затык на OpenBGPd происходит.
    После установки не стартует. Забивал настройки, не стартует.
    Путём научного тыка выяснилось, что не создаются настройки в /usr/local/etc/
    Создал там файл bgpd.conf, пишет что нет файла в /var/etc/openbgpd/
    Создал и там, поменял права на 644 и root:wheel
    запустилось. Перезапускаю - болт. Настройки через веб не применяются. Файлы конфига и там и там разные. Сделал потом в /usr/local/etc/ ссылку на /var/etc/openbgpd, запустилось. НО! При перезапуске права на файл становятся _bgpd:bgpd - то есть меняется владелец, и в логах появляется строка о том, что конфиг файл не принадлежит root:wheel. Что за фигня такая никто не скажет? Это так "обновилось" всё классно что ли?
    Вещь критичная и нужная. Не хотелось бы переходить с pfsense.

    зы: до этого пытался поставить Quagga. Может из-за неё беда? Но её удалил полностью и подчистил вроде всё.

    Проверил на тачке, где не стоит и не ставилась Quagga - всё то же самое.

    использую последнюю версию PfSense: 2.0.1-RELEASE

    upd: Интересная особенность - после перезагрузки сервера заработало, но стоит перезапустить сервис - падает. Чтобы запустить заново необходимо поменять владельца в папке /var/etc/openbgpd на root:wheel и ребутнуться.



  • ап теме!  ???



  • @NvAriec:

    Здравствуйте.
    Не так давно настраивал связку: http://forum.pfsense.org/index.php?PHPSESSID=52nviguncg3ngqpinfqfhjfe66&topic=46671.0
    Всё хорошо работало.

    Пардон, а можно ли в скринах увидеть как Вы настраивали всю ту чудо-связку , что по Вашей ссылке. Буду оч. признателен.

    P.s. Думается что пригодится не только мне одному.  ;)
    P.s.s. Может Ваш мануал и в FAQ попадет.



  • Скрины будут если я заведу эту вещь снова)

    Сейчас ещё копаюсь с Qaggoй. тоже коряво что-то. В настройках откуда-то появляется сеть 8.0.0.0/5 НИГДЕ в настройках её нет и не было. Что-то разочаровываюсь то ли в себе, то ли в pfsense после обновления…



  • Снова ААП)



  • И опять АПП.


Locked