от IPSEC к OpenVpn 2 офиса нет соединения



  • Добрый день уважаемые товарищи прошу помощи!
    2й день не удается соединить 2 офиса по ipsec , мозг пухнет уже(((
    Единственный раз они соединились, когда были в разных сетях 1) 192,168,1,1 2) 192,168,0,1
    но после того как я перенес их в одну коннект между ними бесследно пропал, возврат обратно не помог(((
    вот мои настройки одной из точек по порядку



  • Удалите все настройки и во всех вкладках IP-SECа. Иногда бывают такие глюки, что хоть настройки и поменяли, но остались старые. Уже сам неоднократно натыкался на такое.



  • @NvAriec:

    Удалите все настройки и во всех вкладках IP-SECа. Иногда бывают такие глюки, что хоть настройки и поменяли, но остались старые. Уже сам неоднократно натыкался на такое.

    Удалял и заново создавал, эффект тот же :-\



  • решил уйти на OpenVpn, настраивал по мануалу http://forum.pfsense.org/index.php/topic,32662.msg168997.html#msg168997

    все соединяется, клиент загорается зеленым, получает внутренний IP но  ping не идет , в фаерволе все везде разрешено, в чем может быть дело ?



  • @KAKEP:

    решил уйти на OpenVpn, настраивал по мануалу http://forum.pfsense.org/index.php/topic,32662.msg168997.html#msg168997

    все соединяется, клиент загорается зеленым, получает внутренний IP но  ping не идет , в фаерволе все везде разрешено, в чем может быть дело ?

    Пинг не идет куда? На шлюз ? на сеть за сервером? Смотрите логи fw + конфиг-файлы сервера\ клиента.
    Как вариант - http://forum.pfsense.org/index.php/topic,35815.0.html. Обратите внимание на строчки push route



  • сервер выдает клиенту ip но ничего не происходит, пинг не идет ни внутри ни на сеть  за сервером.
    логи фаервола и  OpenVPN чисты…
    Клиент получает ip из моей сетки, но маска у него не моя и шлюз он получает какой то непонятный...



  • А показать настройки openVPN сервера и клиента можно?



  • есть, на скрине видно, но они почему то не отрабатывают
    @werter:

    @KAKEP:

    сервер выдает клиенту ip но ничего не происходит, пинг не идет ни внутри ни на сеть  за сервером.

    Обратите внимание на строчки push route !!!

    Эти команды вообще есть у вас в конфиге сервера?



  • А почему у вас Tunnel Network и Local Network одинаковые?



  • это я от безисходности пробовал , сейчас вернулTunnel Network 10.0.8.0/24, Local Network 192.168.1.0/24 , пинг так и не пошел
    @werter:

    А почему у вас Tunnel Network и Local Network одинаковые?



  • @KAKEP:

    это я от безисходности пробовал , сейчас вернулTunnel Network 10.0.8.0/24, Local Network 192.168.1.0/24 , пинг так и не пошел
    @werter:

    А почему у вас Tunnel Network и Local Network одинаковые?

    А в настройках сервера в Advanced route и push route изменили ? Да и у клиента и сервера внутренние сети разные?



  • А сеть клиента какая? Должны быть разные с сетью сервера



  • изменил сеть клиента , теперь 192,168,0,1 прописал push route, такое ощущение что push route вообще не срабатывает клиент получает маску 255,255,255,252 , результат тот же пинга нет((
    может я не там его прописываю push route ?



  • В advansed при вашем подключении вообще не надо ничего писать (в конфиг все равно идет запись). И для пробы снять галочки в client setting.



  • Как вариант, снести этот опенвпн сервер, ребутнуть pf и вдумчиво, неспеша и внимательно настроить заново.
    Имхо, вы так больше времени убьёте на поиски где правильно, а где нет, чем "поднимите" опенвнп заново. Проверено на себе :)


Locked