Parameters of atheros wireless nic at startup


  • I'm experiencing the following weird behavior.

    I have tried to pass the following parameters to my atheros CM9 minipci card installed in my pfsense box (x86 PC).

    sysctl dev.ath.1.rfkill=0
    sysctl dev.ath.1.slottime=16
    sysctl dev.ath.1.txantenna=1
    sysctl dev.ath.1.rxantenna=1
    sysctl dev.ath.1.diversity=0
    sysctl dev.ath.1.acktimeout=39
    sysctl dev.ath.1.ctstimeout=39

    I have tried to put them in config.xml with <shellcmd>and <afterfilterchangeshellcmd>or execute them by a startup script put in  /usr/local/etc/rc.d

    I have the same problem in both configurations.

    Diversity and slottime are returning to the original values (diversity=1, slottime=9) after reboot. Everything else is taking the requested value.

    I'm I missing something or it is a FreeBSD driver related issue?

    I'm running pfsense 1.0.1.</afterfilterchangeshellcmd></shellcmd>


  • It seems that the problem occurs only when the CM9 card is working in client mode.

    I have managed to overcome this by making a shell script, executed by crontab every 5 minutes, that sets the correct values.

    I have not noticed any problem with that for about 7 days of constant operation.