Lightsquid package Test



  • How add new themes
    Download http://diskatel.narod.ru/pfSense/packages/lightsquid_theme.zip
    Unpack and move 2 catalog's to '/usr/local/www/lightsquid/tpl'
    In gui this 2 themes now present



  • Updated installation new themes with transition to 'main report page' and pfSense GUI



  • hello, after last upgrade pf package stop working for me, I tried to reinstall package but reistall command stops after a while and nothing happned…

    Removing package…
    Loading package configuration lightsquid.xml...
    Loading package instructions...

    I do not know how to repair it…
    ???



  • @mbedyn:

    hello, after last upgrade pf package stop working for me, I tried to reinstall package but reistall command stops after a while and nothing happned…

    Removing package…
    Loading package configuration lightsquid.xml...
    Loading package instructions...

    I do not know how to repair it…
    ???

    Looking bottom page - any messages exists?



  • hi dvserg, thanks for great job, one question only, about logs, you have some plan to clear logs or what? like after some months clear olders, something that, and a big thank for this great addon for pfsense!

    Rafael



  • @rafael.cardoso:

    hi dvserg, thanks for great job, one question only, about logs, you have some plan to clear logs or what? like after some months clear olders, something that, and a big thank for this great addon for pfsense!
    Rafael

    GUI logs have fix size - 500 strings(if i have remeber) This isn't big size, but if this need - i can add option 'enable log', what 'if disabled' will empty log file (or delete - on you selection).

    And also you can setup 'rotate Squid log'. It depending on the number of users You must define rotation period. Squid have 10 rotating files 0>1>2>3>…>9 Current file, where rotating, maked 0, 0 maked 1 .. and all others shift to up. If you setup monthly rotation, then will have logs with last 10 month. If weekly - have statistic with last 10 week.

    Lightsquid not clearing his DB statistic, but this not need (I have not seen such issues )  
    You comment's?



  • @dvserg:

    Looking bottom page - any messages exists?

    You are right… there is a message at bottom

    Warning: delete_package(lightsquid.inc): failed to open stream: No such file or directory in /etc/inc/pkg-utils.inc on line 728 Fatal error: delete_package(): Failed opening required 'lightsquid.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /etc/inc/pkg-utils.inc on line 728



  • Deleted pkg gui files 'lightsquid.xml' and 'lightsquid.inc'
    May be because of  unchancy installation
    Need manually put this to 'usr/local/pkg' directory and try once more.
    May be need try different deinstall and them install procedure (not reinstall)

    ps I don't test this on captive portal, but nothing 'magic' in package not presented.



  • With deinstall i got the same message… I do not use captive...??
    with reinstall GUI components i got

    Fatal error: Call to undefined function: lightsquid_deinstall() in /etc/inc/pkg-utils.inc(498) : eval()'d code on line 1



  • I can't say how package work with captive portal - need test. But you messages mean what broken or deleted .xml and .inc files of package. Did you plasing this files to '/usr/local/pkg/' catalog before try deleting? (need manually download from pfSense site
    http://www.pfsense.com/packages/config/lightsquid/lightsquid.inc
    http://www.pfsense.com/packages/config/lightsquid/lightsquid.xml)



  • hello
    I have put these files into the /usr/local/pkg
    Package works again but it seems to do not call crontab jobs for refresh. I have setting sheduler to refresh every 24 hour

    crontab file has proper entries, but nothing happend…
    Problems with theese starts just after I upgraded from 5-29 snapshot to 6-28.

    crontab

    0      */24    *      *      *      root    /usr/bin/perl /usr/local/www/lightsquid/lightparser.pl today
    0      0      */30    *      *      root    /usr/local/etc/squid /usr/local/sbin/squid -k rotate > /dev/null



  • @mbedyn:

    hello
    I have put these files into the /usr/local/pkg
    Package works again but it seems to do not call crontab jobs for refresh. I have setting sheduler to refresh every 24 hour

    crontab file has proper entries, but nothing happend…
    Problems with theese starts just after I upgraded from 5-29 snapshot to 6-28.

    crontab

    0       */24    *       *       *       root    /usr/bin/perl /usr/local/www/lightsquid/lightparser.pl today
    0       0       */30    *       *       root    /usr/local/etc/squid /usr/local/sbin/squid -k rotate > /dev/null

    Pls test short time period (hourly for example)



  • hello
    I have done some tests.. and shortest periods refresh correctly…
    :-\



  • @mbedyn:

    hello
    I have done some tests.. and shortest periods refresh correctly…
    :-\

    Fixed updateR 24h and 30 min options error.
    Please test.



  • I would like to, but I do not know how to reinstall the package… As I mentioned before, I have got errors when trying to reinstall the package..  ???

    I repaired package putting manually inc and xml files into /usr/local/pkg.



  • @mbedyn:

    I would like to, but I do not know how to reinstall the package… As I mentioned before, I have got errors when trying to reinstall the package..   ???

    I repaired package putting manually inc and xml files into /usr/local/pkg.

    This also good. Now i can't create captive for test install/deinstall. May be in current of month i do it.



  • BUG REPORT : After each reboot of pfsense

    
    Syncing packages: phpSysInfo nmap snort stunnel squid Lightsquid
    
    Beginning package installation for Lightsquid...
     9% 19% 30% 41% 51% 62% 73% 83% 94% 100%
    
    Installing Lightsquid and its dependencies.
     6% 13% 20% 27% 34% 42% 49% 56% 63% 70% 77% 85% 92% 99% 100% 6% 13% 21% 28% 36%
    43% 51% 58% 65% 73% 80% 88% 95% 100%
    
    Removing package...
    Removing Lightsquid components...
    
    Beginning package installation for Lightsquid...
     9% 19% 30% 41% 51% 62% 73% 83% 94% 100%
    
    Installing Lightsquid and its dependencies.
     2% 5% 8% 10% 13% 16% 18% 21% 23% 26% 29% 31% 34% 37% 39% 42% 45% 47% 50% 53% 55
    % 58% 61% 63% 66% 69% 71% 74% 77% 79% 82% 85% 87% 90% 93% 95% 98% 100% 6% 13% 20
    % 27% 34% 42% 49% 56% 63% 70% 77% 85% 92% 99% 100% 6% 13% 21% 28% 36% 43% 51% 58
    % 65% 73% 80% 88% 95% 100%
    
    

    I have this problem with fresh install with pfsense versions :
    1.2 beta 1
    1.2 beta 2
    1.2 RC1



  • Show the log entry from system logs.  It will say missing file blah blah.



  • I made a new install from ISO 1.2 RC1 built  Jul 21, but when I try to install Lightsquid I get this message:
    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading Lightsquid and its dependencies... done.
    Checking for successful package installation... failed!

    Installation aborted.

    Any idea,

    Thanks Alfredo



  • Hi to all,

    I've same problem with 1.2-TESTING-SNAPSHOT-07-21-2007

    Installing Lightsquid and its dependencies.

    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading Lightsquid and its dependencies... done.
    Checking for successful package installation... failed!

    Installation aborted.

    You have find a solution?  ???

    Thanks



  • Not,

    I still have the problem, could be a problem with the snapshot version?

    regards
    Alfredo



  • I have a problem with squidlogs not rotating, and I think it's because of a bad crontab entry.  Here is what it says:

    /usr/local/etc/squid /usr/local/sbin/squid -k rotate > /dev/null

    I believe it should say:
    /usr/local/sbin/squid -k rotate > /dev/null

    anyone have any thoughts?



  • I have the same problem ..

    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading Lightsquid and its dependencies... done.
    Checking for successful package installation... failed!

    Installation aborted.

    Version: 1.2-BETA-2
    built on Mon Jul 2 20:14:07 EDT 2007

    any ideas ? i will try to re-install the Squid and then i will try again with the Lightsquid i will let you know guys..



  • I already re-install squid an i got the same error with lightsquid

    Downloading package configuration file… done.
    Saving updated package information... done.
    Downloading Lightsquid and its dependencies... done.
    Checking for successful package installation... failed!

    Installation aborted.

    any ideas ?



  • I'm getting the same thing and alls I did was shutdown the box temporarily and rebooted and I got this as well….Beginning package installation for Lightsquid...
    9% 19% 30% 41% 51% 62% 73% 83% 94% 100%

    Installing Lightsquid and its dependencies.
    6% 13% 20% 27% 34% 42% 49% 56% 63% 70% 77% 85% 92% 99% 100% 6% 13% 21% 28% 36%
    43% 51% 58% 65% 73% 80% 88% 95% 100%

    Removing package...
    Removing Lightsquid components...

    Beginning package installation for Lightsquid...
    9% 19% 30% 41% 51% 62% 73% 83% 94% 100%

    Installing Lightsquid and its dependencies.
    2% 5% 8% 10% 13% 16% 18% 21% 23% 26% 29% 31% 34% 37% 39% 42% 45% 47% 50% 53% 55
    % 58% 61% 63% 66% 69% 71% 74% 77% 79% 82% 85% 87% 90% 93% 95% 98% 100% 6% 13% 20
    % 27% 34% 42% 49% 56% 63% 70% 77% 85% 92% 99% 100% 6% 13% 21% 28% 36% 43% 51% 58
    % 65% 73% 80% 88% 95% 100%

    I'm on the latest snapshot. I tried re-installing lightsquid and I get this as well.
    Installing Lightsquid and its dependencies.

    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading Lightsquid and its dependencies... done.
    Checking for successful package installation... failed!

    Installation aborted.



  • Lightsquid package updated to 1.7.1_1.
    Need wait update global pkg_config.xml.



  • It works again.

    Great job!!



  • Great !! it's working now



  • Reinstallation-update fix bug already found, but not updated. Near time will be fixed  ::)

    Include files in lightsquid.xml !must have full path!



  • Now works perfect.

    many thanks
    Alfredo



  • pfSense RC1
    Lightsquid 1.7.1

    404 error when trying to view report



  • @Seth:

    pfSense RC1
    Lightsquid 1.7.1

    404 error when trying to view report

    squid transparent?



  • @dvserg:

    squid transparent?

    Yes. Same here. Squid tranparent and also 404 - Not Found
    on /lightsquid/index.cgi



  • @Shackattack:

    @dvserg:

    squid transparent?

    Yes. Same here. Squid tranparent and also 404 - Not Found
    on /lightsquid/index.cgi

    Do you test with non-transparent squid mode? And pls test access from browser as
    'http://youpfsense/lightsquid/index.cgi'
    This different with url from GUI



  • I have tested it with transparent and non-transparent, with both configurations it´s a 404 - index.cgi not found…. and the report is not going on
    Reinstall lightsquid package is not helpful.
    Greetings
    heiko



  • Transparent non-transpart modes fail.  'http://youpfsense/lightsquid/index.cgi' also fails with a 404 error.



  • @Seth:

    Transparent non-transpart modes fail.  'http://youpfsense/lightsquid/index.cgi' also fails with a 404 error.

    • delete package lightsquid
    • go to command prompt and execute 'pkg_delete lightsquid-1.7.1_1' command
    • install lightsquid

    bug exists on deletion package. Will looking for this bug..



  • for me it works, thanks a lot dvserg



  • That did the trick

    Thanks for your help  ;)



  • I am having a problem with this version of lightsquid on the 1.2 release versions (final not the RC's).

    I updated from 1.2RC2 to RC3 and then to 1.2 final and lightsquid quit working. I tried reinstalling the package to no avail.

    I get a 500 internal server error when attempting to access the index.cgi. I tried the command prompt pkg_delete but I get this:

    pkg_delete lightsquid-1.7.1_1

    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt
    pkg_delete: the package info for package 'pcre-6.6_1' is corrupt

    if I install it again, I have my old configuration still and all the processed logs are still there, but it still doesn't work right.

    I noticed there is some issue with one of the cgi files being compiled for the older version of perl or something? Is there a fix for 1.2 final for this?


Log in to reply