Captive Portal Authentication page stopped working???



  • Hi,

    for some reason my captive portal authntication stopped working after it worked for a short while. Everything is as default, i have read many post on here to no robust solution. if i type manual http://pfsenseip:8000 it works, any idea how i can fix this please as i have a limited knowledge of pfsense!

    this is the version-

    2.0.1-RELEASE (i386) built on Mon Dec 12 17:53:52 EST 2011 FreeBSD 8.1-RELEASE-p6

    Thanks very much.  :)



  • The clients which should use the CP must have the IP address of CP as DNS server.



  • Thats how it is, pfsense configured as DHCP?



  • @zaf:

    Thats how it is, pfsense configured as DHCP?

    It is not neccessary that pfsense is the DHCP server. The DNS is important.
    Do you have squid running on this pfsense - could cause problems in some situations if I remember correct.
    Is the client which wants to connect to CP on the same subnet as the CP interface or is there some additional routing between both ? Then you must disable the "MAC address check" on CP.



  • the ip of pfsense LAN interface is 192.168.0.1 (so i guess this the DNS for the clients correct)?
    i dont even know what squid is….?

    I am connecting direct to the pfsense for captive portal on the same subnet, but wirelessly, does this mean i have to "disable mac address check" if so how do i do that?

    Here is my setup -

    Vigin Modem>TP-LINK Wireless Router>PFsense>LAN

    so basically i have a Virgin Modem connected to a hardware router IP- 192.168.5.1 which is connected to Pfsense IP 192.168.0.1 . (Virtual Machine)

    The WAN IP for the Pfsense is 192.168.5.6 and the LAN IP is 192.168.0.1

    Cheers




  • ok ive figured it out, i had a couple of server ip addresses in "allowed ip addresses" which had the subnet /24 bits and it should have been 32 for one ip only- changing it to /32 and captive portal working again. :)

    Thanks


Locked