PfSense + alix2d3



  • Estou encontrando dificuldades para acessar a interface web, fica extremamente lento..

    Dai depois de um tempo, volta ao normal, mas ao selecionar qualquer opção.. Lento de novo…

    Alguém sabe dizer se preciso configurar algo para melhorar o desempenho do acesso via web ?

    Agradeço qualquer ajuda...



  • Maiores detalhes seriam bem-vindos. Você quer dizer acesso à GUI pela LAN? Por acesso remoto? Se for remoto, quantos mega tem a conexão? Qual a porta de acesso à GUI?



  • @johnnybe:

    Maiores detalhes seriam bem-vindos. Você quer dizer acesso à GUI pela LAN? Por acesso remoto? Se for remoto, quantos mega tem a conexão? Qual a porta de acesso à GUI?

    Olá Johnny, tudo bem ?

    Acesso através dentro da LAN mesmo.. Algumas opções demoram muito.. Outras vão rápido.. Tentei trocar o tema pra ver..
    Porta padrão…



  • Essa Alix é boa. Não seria para acontecer isso. Por acaso você está usando o IE? Com outros navegadores não tenho dor de cabeça mas a "coisa" do IE sempre me deu problemas, em especial com a GUI do pfSense.



  • @johnnybe:

    Essa Alix é boa. Não seria para acontecer isso. Por acaso você está usando o IE? Com outros navegadores não tenho dor de cabeça mas a "coisa" do IE sempre me deu problemas, em especial com a GUI do pfSense.

    Graças a Deus que não.. Meu browser default é o Safari (Mac).. Mas tentei no chrome.. e aconteceu a mesma coisa…

    Minha pergunta é no sentido de ter que customizar algo na configuração...

    [ ]s

    Wendell



  • @perlporter:

    @johnnybe:

    Essa Alix é boa. Não seria para acontecer isso. Por acaso você está usando o IE? Com outros navegadores não tenho dor de cabeça mas a "coisa" do IE sempre me deu problemas, em especial com a GUI do pfSense.

    Graças a Deus que não.. Meu browser default é o Safari (Mac).. Mas tentei no chrome.. e aconteceu a mesma coisa…

    Minha pergunta é no sentido de ter que customizar algo na configuração...

    Entendi perfeitamente sua questão desde o início, Wendell. Mas faltavam informações e por isso tanta pergunta. Não existe configuração que melhore a performance do acesso à GUI, há não ser concorrente e externo, mas acho que esse não é seu caso. E se houver, desconheço. Porém, não desanime. Vamos verificar outros pontos.
    1- Qual a versão do pfSense
    2- Você usa proxy?
    3- Quanto tem de memória nessa Alix?
    4- Como está seu MBUF Usage, no dashboard?
    5- Como está seu State table size, no dashboard?
    5- Em System: Advanced: Networking > a opção Hardware TCP Segmentation Offloading está marcada?
    6- Em System: Advanced: Networking > a opção Hardware Large Receive Offloading está marcada?



  • @johnnybe:

    Entendi perfeitamente sua questão desde o início, Wendell. Mas faltavam informações e por isso tanta pergunta. Não existe configuração que melhore a performance do acesso à GUI, há não ser concorrente e externo, mas acho que esse não é seu caso. E se houver, desconheço. Porém, não desanime. Vamos verificar outros pontos.

    1- Qual a versão do pfSense
    2.0.1-RELEASE (i386)

    2- Você usa proxy?
    Não…

    3- Quanto tem de memória nessa Alix?
    256MB

    4- Como está seu MBUF Usage, no dashboard?
    518/8640

    5- Como está seu State table size, no dashboard?
    473/23000

    5- Em System: Advanced: Networking > a opção Hardware TCP Segmentation Offloading está marcada?
    Sim

    6- Em System: Advanced: Networking > a opção Hardware Large Receive Offloading está marcada?
    Sim

    Informação relevante: Instalado em um Compact Flash de 2gb…



  • @perlporter:

    @johnnybe:

    Entendi perfeitamente sua questão desde o início, Wendell. Mas faltavam informações e por isso tanta pergunta. Não existe configuração que melhore a performance do acesso à GUI, há não ser concorrente e externo, mas acho que esse não é seu caso. E se houver, desconheço. Porém, não desanime. Vamos verificar outros pontos.

    1- Qual a versão do pfSense
    2.0.1-RELEASE (i386)

    2- Você usa proxy?
    Não…

    3- Quanto tem de memória nessa Alix?
    256MB

    4- Como está seu MBUF Usage, no dashboard?
    518/8640

    5- Como está seu State table size, no dashboard?
    473/23000

    5- Em System: Advanced: Networking > a opção Hardware TCP Segmentation Offloading está marcada?
    Sim

    6- Em System: Advanced: Networking > a opção Hardware Large Receive Offloading está marcada?
    Sim

    Informação relevante: Instalado em um Compact Flash de 2gb…

    Bem… acho que o problema está aí. Não sei dizer ao certo porque não conheço a fundo essa Alix. Porém, acredito que 256Mb de RAM é pouco. E, talvez, tenha um outro pequeno gargalo no Compact Flash. Portanto, cheguei ao meu limite de ajuda, infelizmente.  :-[
    Sei que há alguns outros membros aqui do fórum que usam esse modelo de Alix e acredito que possam ser mais específicos quanto ao que ocorre. É só ter paciência e aguardar que um deles veja o tópico.

    Desculpe não poder ajudar mais.



  • Valeu Johnny.. Mas as Alix só vem com 256Mb RAM…

    Mesmo assim valeu a ajuda... Vamos aguardar ;-)

    [ ]s
    Wendell



  • @perlporter:

    Valeu Johnny.. Mas as Alix só vem com 256Mb RAM…

    É mesmo, máximo de 256Mb RAM, acabei de revisitar o site da Alix. A Soekris é que disponibiliza maiores quantidades de RAM. Mas que a Alix é boa, é.  ;D



  • Estou usando uma ALIX2d3 normalmente..



  • @mantunespb:

    Estou usando uma ALIX2d3 normalmente..

    mantunespb, tudo bem ?

    Então o equipamento funciona bem.. só o que chama a atenção é o fato de ser extremamente lento em determinadas opções dentro da GUI;

    Aparentemente ele não apresenta qualquer "atraso" nas conexões… Usuário nunca reclamou... Mas quando vamos mexer na GUI.. dependendo da opção demora......



  • Não notei essa demora.. aqui no meu. !!! viu como anda o consumo, existe quantos usuarios, esta usando squid ?



  • @mantunespb:

    Não notei essa demora.. aqui no meu. !!! viu como anda o consumo, existe quantos usuarios, esta usando squid ?

    States - > 278/23000
    MBUF - > 518/8640
    CPU - > Não esta mostrando (Updating in 10 seconds)
    Memoria - > 32%
    Disco - > 17%

    Não uso Squid e tem 5 usuários…

    Olha o que vi no log:

    Sep 6 14:45:06 syslogd: kernel boot file is /boot/kernel/kernel
    Sep 6 14:45:06 syslogd: exiting on signal 15



  • estou usando essa versão

    pfSense-2.0.1-RELEASE-1g-i386-nanobsd.img.gz

    veja se o seu compactflash esta perfeito..



  • @mantunespb:

    estou usando essa versão

    pfSense-2.0.1-RELEASE-1g-amd64-nanobsd.img.gz

    veja se o seu compactflash esta perfeito..

    Estou usando esta: pfSense-2.0.1-RELEASE-2g-i386-nanobsd.img.gz



  • eu errei.. é igual a sua.

    pfSense-2.0.1-RELEASE-2g-i386-nanobsd.img.gz



  • @mantunespb:

    eu errei.. é igual a sua.

    pfSense-2.0.1-RELEASE-2g-i386-nanobsd.img.gz

    UFAA !! Pensei que estivesse errado na instalação..

    Então estou testando por aqui.. estou percebendo que são em alguns itens que ele perde em média 1:30min para voltar a mexer nele…

    Em todo caso. estou comprando outro CF..

    olha a saida do top

    last pid:  5201;  load averages:  0.01,  0.04,  0.05  up 1+04:38:58    15:13:18
    88 processes:  2 running, 73 sleeping, 13 waiting

    Mem: 46M Active, 22M Inact, 35M Wired, 120K Cache, 34M Buf, 130M Free
    Swap:

    PID USERNAME  PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
      10 root      171 ki31     0K     8K RUN     27.8H 90.97% idle
    35359 root       50    0 34140K 23244K piperd   1:26  2.98% php

    Fiz alguns testes aqui:

    Ao escolher a opção Updater Settings (System/Firmware) demora 01:30min para mostrar a tela;

    Tentando adicionar o Traffic Graphs no Dashboard, quando clico em Save Settings, demora 01:15min;
    Tentando deletar, 01:20min;

    São coisas pontuais.. As demais opções vão de boa ;-)



  • Gostaria de avisar a todos.. que descobri o "problema", era o DNS que o Speedy passou na configuração da WAN… Retirei eles.. Está uma beleza agora..

    Muito obrigado a todos....



  • Que bom que o problema está resolvido…

    Só pra saber, onde você comprou a Alix?
    Estou querendo uma pra colocar aqui em casa no lugar do meu servidorzinho que é um Itx com um C7 barulhento pra caramba...rs



  • Amigo,

    comprei aqui

    http://www.mini-box.com/Alix-2D-Board-3-LAN-1-MINI-PCI-RTC-battery?sc=8&category=1361

    saiu uns +/- 660,00 reais com impostos + compacflash que eu já tinha

    aqui no brasil tem o http://www.cfide.com.br
    só que está fora do ar faz tempos.



  • @mantunespb:

    aqui no brasil tem o http://www.cfide.com.br
    só que está fora do ar faz tempos.

    Conheci os produtos da Alix mais ou menos na mesma época que me inscrevi aqui no fórum, maio de 2009.
    Desde então, só vi o site da cfide online por umas quatro vezes. :(
    E numa dessas vezes, o site mostrava essa Soekris que, com certeza, é demais:
    http://soekris.com/products/net6501.html

    Eu gostaria de ter capital para distribuir esses produtos aqui no Brasil.  ;D



  • @johnnybe:

    Eu gostaria de ter capital para distribuir esses produtos aqui no Brasil.  ;D

    tenho este mesmo pensamento..



  • Comprei de fora uma vez e saiu mais caro que um netbook.

    preço original: U$ 250
    preço final com frete + cotação do dolar + impostos: R$ 1.200,00  :o

    chamo ele carinhosamente de firewall mais caro do mundo.  :(



  • @Thiago:

    Que bom que o problema está resolvido…

    Só pra saber, onde você comprou a Alix?
    Estou querendo uma pra colocar aqui em casa no lugar do meu servidorzinho que é um Itx com um C7 barulhento pra caramba...rs

    Eu comprei direto da Pc Engines http://pcengines.ch
    Dei sorte e não fui taxado :-)

    USD 153.75

    [ ]s

    Wendell


Locked