OpenVPN- brak dostępu z LAN do klientów w sieci VPN



  • Witam,
    postawiłem OpenVPN na pfsense. Połączenie działa doskonale, mam pełne dojście do sieci firmowej.
    Problem jest w drugim kierunku.
    Z maszyn w sieci LAN nie mam dostępu do klientów z zestawionym tunelem VPN.

    Adresacja sieci VPN: 10.0.8.0/24
    Adresacja sieci lokalnej: 100.100.0.0/16
    Brama dla sieci LAN: 100.100.100.1/16
    Brama dla sieci VPN 10.0.8.5/24

    Jeśli znacie rozwiązanie tego problemu proszę o pomoc.

    Pozdrawiam



  • @yodacki:

    Witam,
    postawiłem OpenVPN na pfsense. Połączenie działa doskonale, mam pełne dojście do sieci firmowej.
    Problem jest w drugim kierunku.
    Z maszyn w sieci LAN nie mam dostępu do klientów z zestawionym tunelem VPN.

    Adresacja sieci VPN: 10.0.8.0/24
    Adresacja sieci lokalnej: 100.100.0.0/16
    Brama dla sieci LAN: 100.100.100.1/16
    Brama dla sieci VPN 10.0.8.5/24

    Jeśli znacie rozwiązanie tego problemu proszę o pomoc.

    Pozdrawiam

    Witaj !

    Nie stawiałem jeszcze VPN-a i w sumie to moje początki z pfSense ale spróbuj poszukać tutaj : http://www.openvpn.org.pl/index.php lub tutaj: http://mikrotik.net.pl/wiki/OpenVPN

    Powodzenia i daj znać jak poszło bo też mnie powoli zaczyna interesować ten temat.

    Pawel



  • Dzięki za linki, na pewno się przydadzą.

    Co do mojego problemu to udało się go rozwiązać.

    Wystarczyło z routera wypchnąć statyczny routing dla komputerów w LAN

    Przypomnę raz jeszcze:
    Adresacja sieci VPN: 10.0.8.0/24
    Adresacja sieci lokalnej: 100.100.0.0/16
    Brama dla sieci LAN: 100.100.100.1/16
    Brama dla sieci VPN 10.0.8.5/24

    W tym przypadku wystarczyło dać w maszynie windowsowej polecenie

    route add 10.0.8.0 mask 255.255.255.0 100.100.8.10
    

    Adres 100.100.8.10 jest adresem interfejsu serwera OpenVPN wpiętego do sieci LAN.

    Odpowiednia regułka na routerze (Vyatta) załatwiła sprawę na stałe.

    Pozdrawiam


Log in to reply