Can't get captive portal to work



  • my captive portal is on a vlan and i can access the splash page by visiting the vlan url 10.10.10.1:8000

    i dont have any authentication, so pressing continue reloads the page.  i have not tweaked the default config, or added my own, so i tried entering google.com and it works.  prior to clicking continue google.com didnt load.

    this is where my problem starts.  when i connected to the wifi with the Captive Portal, nothing loads, it attempts to load the home page and nothing pops up.  that is when i typed in 10.10.10.1:8000 to make sure it would load.

    what am i missing?  why isnt the default splash page kicking in?  i want to make sure the basics/defaults work before i start editing pages.

    everything else seems to work once i click continue and type in a URL, but i need the splash page to load on its own, that is step 1.

    thanks.

    edit-

    2.0.1-RELEASE (i386)
    built on Mon Dec 12 18:24:17 EST 2011
    FreeBSD 8.1-RELEASE-p6

    You are on the latest version.



  • more info…

    good news- i tried with a windows 7 PC, chrome browser and my default website is google.com and when i loaded the browser it redirected me to the CP splash page...so i guess it works.  the other good news is that as soon as i connected to the captive portal AP on the vlan, windows gave me a notification that additional credentials might be required, so again, it saw that the CP was active (windows pop up balloon in the bottom right in the system tray).

    bad news- the computer i was originally testing with was a mac with chrome browser, that is strange that it doesnt work with mac .

    does anyone have any idea why it doesnt work with mac?

    side note- i tried accessing with my ipad and that gave me the splash page when i tried going to a browser, that is what made me try with a windows 7 OS.




Log in to reply