Cannot Get Bridged Modem to work with WAN PPPoE- what am I doing Wrong?



  • I have a Netcomm NB6 Rev2 modem and have placed it in bridging mode to my single Wan / Single LAN pfsense box.

    Have attached a screen shot of my WAN settings on PFsense - it is saying 'WAN Disabled' on the dashboard even though it is enabled under the WAN tab.

    Also attached is screenshots of the NB6 config.

    Any help would be greatly appreciated.

    thanks
    noddy

    PS I tried a Tplink-8840T as well in bridge mode with no luck
    ![dashboard - wan showing as disabled.jpg](/public/imported_attachments/1/dashboard - wan showing as disabled.jpg)
    ![dashboard - wan showing as disabled.jpg_thumb](/public/imported_attachments/1/dashboard - wan showing as disabled.jpg_thumb)
    ![nb6 config.jpg](/public/imported_attachments/1/nb6 config.jpg)
    ![nb6 config.jpg_thumb](/public/imported_attachments/1/nb6 config.jpg_thumb)
    ![wan screen.jpg](/public/imported_attachments/1/wan screen.jpg)
    ![wan screen.jpg_thumb](/public/imported_attachments/1/wan screen.jpg_thumb)
    ![NB6 screen - no ppp defined.jpg](/public/imported_attachments/1/NB6 screen - no ppp defined.jpg)
    ![NB6 screen - no ppp defined.jpg_thumb](/public/imported_attachments/1/NB6 screen - no ppp defined.jpg_thumb)



  • What happens if you set up the ppp settings on the modem and put your pfsense wan into dhcp?

    Are you sure your ISP will do pppoe?



  • Hi chpalmer

    Well i am having problems getting port forwarding to work.  refer:
    http://forum.pfsense.org/index.php/topic,54463.msg291429.html#msg291429

    I had it set up like you suggested (refer pic attached of network setup)- Modem connecting to ISP with PPPoE stored it it, and WAN of pfsense connecting to Modem through DCHP  - works fine - but port forwarding doesnt.

    Any ideas?
    Cheers.

    ![network diagram - pbx items only shown.jpg](/public/imported_attachments/1/network diagram - pbx items only shown.jpg)
    ![network diagram - pbx items only shown.jpg_thumb](/public/imported_attachments/1/network diagram - pbx items only shown.jpg_thumb)



  • @noddy184:

    I had it set up like you suggested (refer pic attached of network setup)- Modem connecting to ISP with PPPoE stored it it, and WAN of pfsense connecting to Modem through DCHP  - works fine - but port forwarding doesnt.

    Then your modem is probably acting as a router and you will probably need to specify port forwards in the modem/router as well as in pfSense.

    What is in the pfSense PPP log?



  • Hi Wallabybob

    -I forwarded the ports on the Modem to the WAN port of the PFSENSE BOX, then forwarded them in PFSENSE to my desired pc (3CX Pbx - my other post details including screenshots). And it did not work.

    -when can i check this ppp log you talk of and how do i open it?

    ta



  • My thought is that the modem may be able to do the pppoe while passing on the public address to your pfsense wan.  But looks like your ISP may have their own firmware in the modem??

    Set your modem back up as a bridge and your pfsense box to do the pppoe and then share your ppp logs here as wallabybob asked.



  • @noddy184:

    -when can i check this ppp log you talk of and how do i open it?

    In the web GUI, Status -> System Logs, click on PPP tab to see most recent "n" entries.

    pfSense shell command```

    clog /var/log/ppp.log



  • Two or three years ago I attempted to get pfSense PPPoE working with two different ADSL modem/routers set in bridge mode. Unfortunately I was unable to do so in "reasonable" time so  figured I might be better off buying a $25 ADSL modem and that proved to be the case in that I got it working in very quick time. A major problem in getting the modem/routers working was the very limited troubleshooting capabilities available, in particular no packet capture and no counters. Even though packet capture on pfSense was showing outgoing PPP packets there didn't seem to be any way to gather any evidence the modem/routers were seeing the PPP packets. But that was while ago and my recollections might not be entirely accurate. I have felt no need to revisit the issue.



  • here is the log

    Wallabybob- what modem make/ model did you get - that you can confirm works?

    [system log PPP.txt](/public/imported_attachments/1/system log PPP.txt)



  • @noddy184:

    here is the log

    Wallabybob- what modem make/ model did you get - that you can confirm works?

    Chech out the Zoom 5715.  I think Zytel makes one also.



  • @noddy184:

    Wallabybob- what modem make/ model did you get - that you can confirm works?

    Tenda D820B.



  • @noddy184:

    here is the log

    For comparison, here is an extract from my PPP log when it restarted after I powered cycled the modem.

    Oct  7 21:40:27 pfsense ppp: [wan_link0] Link: reconnection attempt 27 in 4 seconds
    Oct  7 21:40:31 pfsense ppp: [wan_link0] Link: reconnection attempt 27
    Oct  7 21:40:31 pfsense ppp: [wan_link0] PPPoE: Connecting to ''
    Oct  7 21:40:34 pfsense ppp: PPPoE: rec'd ACNAME "pe5.dc1-vars"
    Oct  7 21:40:40 pfsense ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Oct  7 21:40:40 pfsense ppp: [wan_link0] Link: DOWN event
    Oct  7 21:40:40 pfsense ppp: [wan_link0] LCP: Down event
    Oct  7 21:40:40 pfsense ppp: [wan_link0] Link: reconnection attempt 28 in 4 seconds
    Oct  7 21:40:44 pfsense ppp: [wan_link0] Link: reconnection attempt 28
    Oct  7 21:40:44 pfsense ppp: [wan_link0] PPPoE: Connecting to ''
    Oct  7 21:40:53 pfsense ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Oct  7 21:40:53 pfsense ppp: [wan_link0] Link: DOWN event
    Oct  7 21:40:53 pfsense ppp: [wan_link0] LCP: Down event
    Oct  7 21:40:53 pfsense ppp: [wan_link0] Link: reconnection attempt 29 in 4 seconds
    Oct  7 21:40:57 pfsense ppp: [wan_link0] Link: reconnection attempt 29
    Oct  7 21:40:57 pfsense ppp: [wan_link0] PPPoE: Connecting to ''
    Oct  7 21:41:06 pfsense ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Oct  7 21:41:06 pfsense ppp: [wan_link0] Link: DOWN event
    Oct  7 21:41:06 pfsense ppp: [wan_link0] LCP: Down event
    Oct  7 21:41:06 pfsense ppp: [wan_link0] Link: reconnection attempt 30 in 2 seconds
    Oct  7 21:41:08 pfsense ppp: [wan_link0] Link: reconnection attempt 30
    Oct  7 21:41:08 pfsense ppp: [wan_link0] PPPoE: Connecting to ''
    Oct  7 21:41:08 pfsense ppp: PPPoE: rec'd ACNAME "pe5.dc1-vars"
    Oct  7 21:41:08 pfsense ppp: [wan_link0] rec'd proto LCP while dead
    Oct  7 21:41:08 pfsense ppp: [wan_link0] PPPoE: connection successful
    Oct  7 21:41:08 pfsense ppp: [wan_link0] Link: UP event
    Oct  7 21:41:08 pfsense ppp: [wan_link0] LCP: Up event
    Oct  7 21:41:08 pfsense ppp: [wan_link0] LCP: state change Starting –> Req-Sent
    Oct  7 21:41:08 pfsense ppp: [wan_link0] LCP: SendConfigReq #3
    Oct  7 21:41:08 pfsense ppp: [wan_link0]  PROTOCOMP
    Oct  7 21:41:08 pfsense ppp: [wan_link0]  MRU 1492
    Oct  7 21:41:08 pfsense ppp: [wan_link0]  MAGICNUM 31abc0a9
    Oct  7 21:41:08 pfsense ppp: [wan_link0] LCP: rec'd Configure Ack #3 (Req-Sent)
    Oct  7 21:41:08 pfsense ppp: [wan_link0]  PROTOCOMP
    Oct  7 21:41:08 pfsense ppp: [wan_link0]  MRU 1492
    Oct  7 21:41:08 pfsense ppp: [wan_link0]  MAGICNUM 31abc0a9
    Oct  7 21:41:08 pfsense ppp: [wan_link0] LCP: state change Req-Sent –> Ack-Rcvd
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: rec'd Configure Request #2 (Ack-Rcvd)
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MRU 1492
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  AUTHPROTO PAP
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MAGICNUM 4c71f0f4
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MP MRRU 1524
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  ENDPOINTDISC [LOCAL] 70 65 35 2e 64 63 31 2d 76 61 72 73
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: SendConfigRej #2
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MP MRRU 1524
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: state change Ack-Rcvd –> Req-Sent
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: SendConfigReq #4
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  PROTOCOMP
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MRU 1492
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MAGICNUM 31abc0a9
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: rec'd Configure Request #3 (Req-Sent)
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MRU 1492
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  AUTHPROTO PAP
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MAGICNUM 4c71f0f4
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  ENDPOINTDISC [LOCAL] 70 65 35 2e 64 63 31 2d 76 61 72 73
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: SendConfigAck #3
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MRU 1492
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  AUTHPROTO PAP
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MAGICNUM 4c71f0f4
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  ENDPOINTDISC [LOCAL] 70 65 35 2e 64 63 31 2d 76 61 72 73
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: state change Req-Sent –> Ack-Sent
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: rec'd Configure Ack #4 (Ack-Sent)
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  PROTOCOMP
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MRU 1492
    Oct  7 21:41:10 pfsense ppp: [wan_link0]  MAGICNUM 31abc0a9
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: state change Ack-Sent –> Opened
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: auth: peer wants PAP, I want nothing
    Oct  7 21:41:10 pfsense ppp: [wan_link0] PAP: using authname "xxx@dsl.onthenet.net"
    Oct  7 21:41:10 pfsense ppp: [wan_link0] PAP: sending REQUEST #1 len: 39
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: LayerUp
    Oct  7 21:41:10 pfsense ppp: [wan_link0] PAP: rec'd ACK #1 len: 5
    Oct  7 21:41:10 pfsense ppp: [wan_link0] LCP: authorization successful
    Oct  7 21:41:10 pfsense ppp: [wan_link0] Link: Matched action 'bundle "wan" ""'
    Oct  7 21:41:10 pfsense ppp: [wan_link0] Link: Join bundle "wan"
    Oct  7 21:41:10 pfsense ppp: [wan] Bundle: Status update: up 1 link, total bandwidth 64000 bps
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: Open event
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: state change Initial –> Starting
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: LayerStart
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: Up event
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: state change Starting –> Req-Sent
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: SendConfigReq #5
    Oct  7 21:41:10 pfsense ppp: [wan]  IPADDR 0.0.0.0
    Oct  7 21:41:10 pfsense ppp: [wan]  COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: rec'd Configure Request #1 (Req-Sent)
    Oct  7 21:41:10 pfsense ppp: [wan]  IPADDR 121.50.212.9
    Oct  7 21:41:10 pfsense ppp: [wan]    121.50.212.9 is OK
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: SendConfigAck #1
    Oct  7 21:41:10 pfsense ppp: [wan]  IPADDR 121.50.212.9
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: state change Req-Sent –> Ack-Sent
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: rec'd Configure Reject #5 (Ack-Sent)
    Oct  7 21:41:10 pfsense ppp: [wan]  COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: SendConfigReq #6
    Oct  7 21:41:10 pfsense ppp: [wan]  IPADDR 0.0.0.0
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: rec'd Configure Nak #6 (Ack-Sent)
    Oct  7 21:41:10 pfsense ppp: [wan]  IPADDR 120.29.18.243
    Oct  7 21:41:10 pfsense ppp: [wan]    120.29.18.243 is OK
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: SendConfigReq #7
    Oct  7 21:41:10 pfsense ppp: [wan]  IPADDR 120.29.18.243
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: rec'd Configure Ack #7 (Ack-Sent)
    Oct  7 21:41:10 pfsense ppp: [wan]  IPADDR 120.29.18.243
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: state change Ack-Sent –> Opened
    Oct  7 21:41:10 pfsense ppp: [wan] IPCP: LayerUp
    Oct  7 21:41:10 pfsense ppp: [wan]  120.29.18.243 -> 121.50.212.9
    Oct  7 21:41:11 pfsense ppp: [wan] IFACE: Up event

    My ISP is OntheNet who have their own DSLAM in my local telephone exchange. It appears your ISP is Dodo. I can't vouch that pfSense will work "out of the box" with Dodo. (I had to tweak pfSense PPP configuration to get pfSense to talk with Virgin Mobile PPP on 3G but that didn't seem necessary to talk with Optus 3G. Dodo might have their own requirements on PPPoE.)



  • One forum reader has reported being unable to get PPPoE started UNLESS the physical interface had a static IP address. The physical interface will have a static IP address if you follow the configuration how to in the pfSense documentation pages (see http://doc.pfsense.org) for being able to use PPP and access ADSL modem. I certain followed that howto when I configured pfSense for use with the Tenda ADSL modem. I suspect I didn't perform a similar configuration when I attempted to use the two different ADSL modem/routers in bridge mode.

    It is not clear to me why it would be necessary for the physical interface to have a static IP, but it is so useful to be able to access the modem web page (and the static IP is necessary for that) I haven't explored the consequences of not having  static IP on the physical interface. (strictly speaking, I should probably point out I don't quite have that configuration: my PPPoE runs over a VLAN, the pfSense VLAN interface has the static IP and the underlying physical interface doesn't).

    Hope I haven't written "too much" and confused you.



  • @wallabybob:

    One forum reader has reported being unable to get PPPoE started UNLESS the physical interface had a static IP address.

    Which interface are we talking about here? (that needs the static IP) is this the modem itself? Or the WAN of PFSENSE?

    I have followed these instructions to set the Netcomm NB6 Modem up in bridge mode: http://www.google.com.au/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&ved=0CC8QFjAB&url=http%3A%2F%2Fmedia.netcomm.com.au%2Fpublic%2Fassets%2Fpdf_file%2F0020%2F41645%2FBCS-NB6.pdf&ei=AcVzUOWUGLG0iQeS74DgCQ&usg=AFQjCNE2NWvnIW2qvCGe75QrWSsMwsZ3AQ&sig2=_ZrLRyEQ-ij4ww_2yQualg&cad=rja

    So do i need to put a static address somewhere , if so, where?

    What about the static IP address that my ISP gives me (which I know)- does that come in to it?

    Guess I'm asking for clarification of where this static IP needs to go/what you mean/how to set up?

    @wallabybob:

    The physical interface will have a static IP address if you follow the configuration how to in the pfSense documentation pages (see http://doc.pfsense.org) for being able to use PPP and access ADSL modem. I certain followed that howto when I configured pfSense for use with the Tenda ADSL modem. I suspect I didn't perform a similar configuration when I attempted to use the two different ADSL modem/routers in bridge mode.

    Any chance you'd be able to point out the specific section I need to review in the docs?

    Many thanks Wallabybob :)



  • @chpalmer:

    My thought is that the modem may be able to do the pppoe while passing on the public address to your pfsense wan.  But looks like your ISP may have their own firmware in the modem??

    Set your modem back up as a bridge and your pfsense box to do the pppoe and then share your ppp logs here as wallabybob asked.

    Just confirming the ISP does not have firmware in the modem, bought it elsewhere, and multiple other modems work (in standard non pfsense type configuration.


  • Netgate Administrator



  • @noddy184:

    @wallabybob:

    One forum reader has reported being unable to get PPPoE started UNLESS the physical interface had a static IP address.

    Which interface are we talking about here? (that needs the static IP) is this the modem itself? Or the WAN of PFSENSE?

    The page http://doc.pfsense.org/index.php/Accessing_modem_from_inside_firewall describes configuration of pfSense to access a web server on a DSL or cable modem. Hereafter I assume you are running pfSense 2.x so you should ignore the first part of that document. If things aren't clearer after reading that, ask for clarification.



  • Having the exact same issue here. Only difference in my general setup is that i'm using a bridged TP-Link TD-8817 modem connected to WAN and my ISP is Clubtelco (dodo reseller) so same provider as the original poster of this topic. This setup works if i use another router in place of pfsense. If i have pfsense deal with the pppoe connection it fails to connect to the internet at all but it does show signs in the log that the connect attempt is getting through to the ISP.

    I have attached the ppp.log file to this post

    ppp.log.txt



  • So tasdevil, does your PFsense dashboard show a red "x" for WAN like mine? I'm going to try the tips from Wallabybob in regards to http://doc.pfsense.org/index.php/Accessing_modem_from_inside_firewall , will report findings shortly



  • @tasdevil123:

    If i have pfsense deal with the pppoe connection it fails to connect to the internet at all but it does show signs in the log that the connect attempt is getting through to the ISP.

    I don't have a lot of experience in interpreting PPP logs but my suspicion is that the server (ISP) is insisting on a MRU (Maximum Receive Unit) of 1500 while your end (pfSense) is insisting on a MRU of 1454. Have you specified a non-default MTU on the PPP interface in pfSense?



  • @wallabybob:

    I don't have a lot of experience in interpreting PPP logs but my suspicion is that the server (ISP) is insisting on a MRU (Maximum Receive Unit) of 1500 while your end (pfSense) is insisting on a MRU of 1454. Have you specified a non-default MTU on the PPP interface in pfSense?

    Tried manually specifying values 1500 and 1492 but it still didn't connect. I have attached another log output.

    @noddy184:

    So tasdevil, does your PFsense dashboard show a red "x" for WAN like mine? I'm going to try the tips from Wallabybob in regards to http://doc.pfsense.org/index.php/Accessing_modem_from_inside_firewall , will report findings shortly

    Yes i get the red x too, with or without the ethernet cable plugged into the WAN port. I do notice a difference when comparing the output of both our log files. In my log it is clear that there is communication happening between my pfsense box and the ISP but in yours the output is very much the same thing that i get if i unplug the ethernet cable from the WAN port. I would check to see if your interfaces are correctly assigned. pppoe0 should be selected in the WAN dropdown list under the Interface assignments tab. Also under the ppp tab the pppoe0 interface should be linked to your physical WAN port. In my case pppoe0 is linked to em0.

    Another issue that may crop up for you if your internet is provided through a telstra port at the exchange. If there are too many failed attempts to connect via pppoe then the port will lock any more attempts out for around 5 minutes. I always have to pull the WAN cable for a bit before i can try to connect again. You can see this happening at the end of the log i provided attached to this post.

    ppp.log.txt



  • @tasdevil123:

    Tried manually specifying values 1500 and 1492 but it still didn't connect. I have attached another log output.

    Something wrong with letting it default?



  • @wallabybob:

    Something wrong with letting it default?

    Sorry i should have mentioned that letting it default was the last thing i tried and the result of that is in the last log file i posted.



  • Ok some progress:

    1.  @ TasDevil.  Understand your advice to check Wan dropdown list is set to PPPoE….yes...it it is.  Second part you say "under ppp tab the ppoe0 interface should be linked to physical WAN port"  Mate where do i find the "ppp tab" . do u mind clarifying.

    2. @ Wallabybob - i have SUCCESSFULLY configured an additional interface to be able to access my modem, as detailed in your & Steve's  instructions link.  So Lan is still on 192.168.2.1  , but when i key in 192.168.1.1 it successfully brings up my modem GUI

    That's all well and good, but what do I do now? Am i still trying to put my router in bridge mode?



  • @noddy184:

    1.  @ TasDevil.  Understand your advice to check Wan dropdown list is set to PPPoE….yes...it it is.  Second part you say "under ppp tab the ppoe0 interface should be linked to physical WAN port"  Mate where do i find the "ppp tab" . do u mind clarifying.

    Go to (menus along the top) Interfaces –-> (assign) then use the tabs on that page. Tabs you want to check are "Interface assignments" and "PPPs". On the first tab i mentioned check that the WAN dropdown list has pppoe0 or pppoe1,2,3 etc selected as the network port. On the PPPs tab check that pppoe0 is linked to your physical interface for the WAN. In my case pppoe0 is linked to interface em0.

    Hope this helps



  • @noddy184:

    Am i still trying to put my router in bridge mode?

    If you want pfSense to talk PPPoE to your ISP the modem/router needs to be in bridge mode so PPP gets from your ISP to pfSense.



  • wallabybob, not sure what i need to do next?

    I can access the modem's web interface when it is not in bridge mode, once it's in the bridge mode it wont even ping.

    Have attached the latest PPP log and screenshots of my settings.

    Still getting red X on dashboard for wan when it is in PPPoE mode, it will only work showing greeen and connection up when in DCHP mode

    ![dashboard - wan is showing cross.jpg](/public/imported_attachments/1/dashboard - wan is showing cross.jpg)
    ![dashboard - wan is showing cross.jpg_thumb](/public/imported_attachments/1/dashboard - wan is showing cross.jpg_thumb)
    ![interface assign ports.jpg](/public/imported_attachments/1/interface assign ports.jpg)
    ![interface assign ports.jpg_thumb](/public/imported_attachments/1/interface assign ports.jpg_thumb)
    ![interfaces ppp edit.jpg](/public/imported_attachments/1/interfaces ppp edit.jpg)
    ![interfaces ppp edit.jpg_thumb](/public/imported_attachments/1/interfaces ppp edit.jpg_thumb)
    ![interfaces ppp.jpg](/public/imported_attachments/1/interfaces ppp.jpg)
    ![interfaces ppp.jpg_thumb](/public/imported_attachments/1/interfaces ppp.jpg_thumb)
    ppp.txt



  • Are you sure your ISP doesn't require pppoa?



  • @noddy184:

    wallabybob, not sure what i need to do next?

    Your screenshots show PPP using re0. You would also configure re0 with static IP address in the same subnet as the modem. You have an interface modemaccess with IP address 192.168.1.47. I presume therefore the modem has IP address in the 192.168.1.0/24 subnet. However I don't know where re2 connects. Possibly you have a multiport modem router and re0 AND re2 both connect to it.  Maybe using both ports should work, I don't know the implementation details of your router. You should be able to use re0 for pppoe0 and use re0 for IP to talk with modem. So I suggest you reconfigure so WAN interface is pppoe0 and modem access is re0 and reboot.



  • @noddy184:

    Have attached the latest PPP log and screenshots of my settings.

    Your PPP log shows no sign of a response from the ISP.

    @chpalmer:

    Are you sure your ISP doesn't require pppoa?

    I think the modem would normally make the change from PPP encapsulation on Ethernet (PPPoE) to PPP encapsulation on ATM (PPPoA).



  • I have been running wireshark in order to take a look at the pppoe communication that is happening between pppoe client and the ISP during the failed connection attempts from pfsense as well as a successful attempts from the windows 7 pppoe client to my ISP. What i have found is that the connection attempt fails because pfsense and my ISP fail to agree on an MTU value. pfsense always seems to insist on using 1492 where as my ISP demands a value of 1500. I noticed in the windows 7 pppoe client that it will initially request a value of 1480 which fails, then 1492 which also fails. Finally it tries 1500 which is accepted and the connection completes.

    I have tried forcing the MTU value to 1500 in the pppoe connection options but pfsense seems to ignore that and continues to insist on using 1492 as the MTU value during negotiation. Is there any way to force the value in a configuration file or via command line?

    noddy184 your pfsense configuration looks fine from what i have seen in your screenshots. I suspect that your issue may be that your modem is not set to bridge mode. Once you have your modem set to bridge mode i suspect you will then run into the same issue as i am having at the moment since we use the same ISP.



  • @tasdevil123:

    I have tried forcing the MTU value to 1500 in the pppoe connection options but pfsense seems to ignore that and continues to insist on using 1492 as the MTU value during negotiation. Is there any way to force the value in a configuration file or via command line?

    Where did you try changing it? I suspect it might have to be done from Interfaces -> (assign), click on PPPs tab, click on "e" to the right of the appropriate interface line, click on Show advanced options button, fill in the required MTU, click on Save (to update configuration file), click on Apply (to apply change to running system).

    The check the ppp log again. If that doesn't show an improved result check the ppp configuration file: /var/etc/mpd_wan.conf for its mtu value.



  • @wallabybob:

    Where did you try changing it? I suspect it might have to be done from Interfaces -> (assign), click on PPPs tab, click on "e" to the right of the appropriate interface line, click on Show advanced options button, fill in the required MTU, click on Save (to update configuration file), click on Apply (to apply change to running system).

    The check the ppp log again. If that doesn't show an improved result check the ppp configuration file: /var/etc/mpd_wan.conf for its mtu value.

    Yes that is where i changed it. I performed a reboot of the system just to be safe and tried again. pfsense still tries to use a value of 1492 after all that. I checked the mpd_wan.conf file and it has the correct value of 1500 for MTU so the change does apply there but pfsense seems to ignore it anyway.

    Edit: i need to also note that i have also tried other freebsd based firewall OSs and they all have the same behaviour. None of them want to connect via pppoe. I have also tried linux based firewall OSs and those connect just fine.



  • I just tried bridging mode on a third modem, a Dlink DSL2750b, with no luck, refer log and screenshot.  Says it's connected but it's not.

    Getting frustrated it must be something simple!

    ![dlink in bridging mode says connected.jpg](/public/imported_attachments/1/dlink in bridging mode says connected.jpg)
    ![dlink in bridging mode says connected.jpg_thumb](/public/imported_attachments/1/dlink in bridging mode says connected.jpg_thumb)
    [system log PPP dlink.txt](/public/imported_attachments/1/system log PPP dlink.txt)


  • Netgate Administrator

    When it's in bridge mode correctly the modem will never show connected since pfSense is handling the PPPoE and IP level connection. It will show the dsl link status though.
    For example see the attached screenshot from my modem that I'm using to write this!

    Steve






  • @noddy184:

    I just tried bridging mode on a third modem, a Dlink DSL2750b, with no luck, refer log and screenshot.  Says it's connected but it's not.

    Getting frustrated it must be something simple!

    Actually… have a look at the last ppp log you posted.

    Oct 11 15:51:17 ppp: [wan_link0] MRU 1492
    Oct 11 15:51:17 ppp: [wan_link0] MAGICNUM 6bda01c0
    Oct 11 15:51:17 ppp: [wan_link0] LCP: rec'd Configure Nak #22 (Ack-Sent)
    Oct 11 15:51:17 ppp: [wan_link0] MRU 1500
    Oct 11 15:51:17 ppp: [wan_link0] LCP: not converging
    Oct 11 15:51:17 ppp: [wan_link0] LCP: parameter negotiation failed

    Oct 11 15:51:17 ppp: [wan_link0] LCP: state change Ack-Sent –> Stopped
    Oct 11 15:51:17 ppp: [wan_link0] LCP: LayerFinish
    Oct 11 15:51:17 ppp: [wan_link0] PPPoE: connection closed

    Your bridged modem is now set up correctly. From the looks of that log there is communication happening between pfsense and your ISP (dodo). Congrats! you are now having the same issue as me with pppoe negotiation failing due to MTU. This only happens for me on pfsense. Every other firewall OS i try connects to pppoe fine.



  • @tasdevil123:

    you are now having the same issue as me with pppoe negotiation failing due to MTU. This only happens for me on pfsense.

    Perhaps you could try a snapshot build of pfSense 2.1 whch includes a more up to date version of the PPP daemon (5.6) than is included in pfSense 8.1 (5.5).



  • @wallabybob:

    Perhaps you could try a snapshot build of pfSense 2.1 whch includes a more up to date version of the PPP daemon (5.6) than is included in pfSense 8.1 (5.5).

    Tried it just then and unfortunately the issue still exists. There must be an incompatibility with pppd and dodo's configuration on their end. I remember trying out pfsense back when i was on iinet and internode before that and pppoe worked perfectly fine.



  • Wonder if Dodo could do true bridged mode for you on their end.

    I.E. no log in.  Its basically an ethernet connection using a DSL modem.



  • @chpalmer:

    Wonder if Dodo could do true bridged mode for you on their end.

    I.E. no log in.  Its basically an ethernet connection using a DSL modem.

    Can't be done. All home ADSL connections here in Australia use PPPoA and PPPoE to my knowledge. It's just the way the network is set up here.

    The above shouldn't have to be done anyway. If the Windows and Linux PPPoE clients can deal with dodo's configuration just fine then why can't pppd and pfsense or any other freebsd based routing OS? all that i've tried have the exact same issue.


Log in to reply