[Resolvido] Comunicação entre interfaces



  • Obrigado pela ajuda irei verificar e ver oque encontro.



  • Boa Tarde !

    Bem fiz uma regra em cada interface liberando tudo, mas memso assim as duas redes diferentes não se enxergam.

    Alguém sabe me dizer qual o próximo passo para as duas redes se comunicarem?

    Muito obrigado.



  • Cole aqui as 2 telas com as respectivas regras!



  • usando o additional Options para anexar as telas  ;)



  • Segue Jack.

    Obrigado Pela ajuda.

    ![Firewall - TGL.jpg](/public/imported_attachments/1/Firewall - TGL.jpg)
    ![Firewall - TGL.jpg_thumb](/public/imported_attachments/1/Firewall - TGL.jpg_thumb)
    ![Firewall - LAN.jpg](/public/imported_attachments/1/Firewall - LAN.jpg)
    ![Firewall - LAN.jpg_thumb](/public/imported_attachments/1/Firewall - LAN.jpg_thumb)



  • gleisonpc,

    Quando vc diz que não consegue comunicação de uma LAN pra outra, refere-se exatamente ao que? Acesso de compartilhamentos? Ping?

    Você não consegue acessar da 10 para 172, ao contrário ou em ambas?

    Você tem alguma regra na aba "Floating"?

    Já desativou o fw do Windows das estações que você está usando para testar comunicação em ambas as redes?

    Nota: Procure rodar a WebGUI do seu pfSense via HTTPS e não HTTP (questão de segurança). Na sua aba "LAN", deixe apenas a segunda (apague a terceira). Siga o mesmo conceito na aba "TGL", ou seja, sempre especifique o campo "source"!

    Abraços!
    Jack



  • vou continuar com a chuva de perguntas…  :)

    as redes estão fisicamente separadas?

    já tentou passar o outbound nat para manual para ter certeza que não está fazendo nat de uma rede para outra?

    já monitorou via tcpdump se os pacotes passam de uma interface para outra?



  • Bom Dia Pessoal Vamos Lá!

    Quando digo que não consigo acessar siginifica que não consigo pingar nem acessar as redes, tanto da 10 para 172 como vice versa.

    Não tenho nenhuma regra no floating.

    Já desativei os firewalls nas maquinas de teste.

    Agora marcelo,

    As redes estão em predios diferente sendo interligadas por radios em modo brigde.

    O outbound já esta em modo manual.

    E como verifico esse tcpdump?

    Pessoal muito obrigado pela ajuda.

    Gleison



  • Consegui da o tcpdum dei o seguinte comando e deu a seguinte mensagem:

    tcpdump -ni re0 host 172.20.6.1

    packet captured 64 packet received by filter
    packets dropped by kernel

    Gleison



  • Não tem nenhum pacote neste seu tcpdump????

    Você está usando uma interface de rede/vlan para cada segmento?

    Este rádio em modo bridge cai no switch ou no pfsense?



  • Criei uma vlan e coloquei na wan… ai desabilitei a wan...

    Deixa uma interface na LAN e outra na OPT1 = TGL...

    A antena chega diretamente no pfsense...

    O tcpdump me retornou essa mensagem que coloquei acima...

    Obrigado...



  • @gleisonpc:

    Criei uma vlan e coloquei na wan… ai desabilitei a wan...
    Deixa uma interface na LAN e outra na OPT1 = TGL...

    Tem alguma interface com vlan tagged e untagged configurada no pfsense ou porta no switch?

    @gleisonpc:

    A antena chega diretamente no pfsense…

    Seu tcpdump não retornou nada, tente escutar tudo o que chega na interface para ver o que está passando.
    tcpdump -ni re0

    re0 é a interface la LAN ou do RÁDIO?



  • re0 = LAN
    xl0 = Radio

    Fazendo o comando que você disse vejo log assim:

    re0 se comunica com o range de ip referente a ele = 10.100.172.x
    xl0 se comunica com o range de ip referente a ele = 172.20.6.x

    apenas entre eles não tem nada de um range se comunicando com o outro.

    Exclui a VLAN…

    Ou vou usa-la para comunicar as duas interfaces?



  • @gleisonpc:

    Fazendo o comando que você disse vejo log assim:

    use o tcpdump para investigar onde o pacote esta parando, dispare um ping -t para uma maquina na outra rede e use o tcpdump nas duas interfaces para ver se o pacote icmp está chegando em uma interface e passando para a outra, veja também se ao passar pelo pfsense o pacote está passando pelo nat(mudando o ip de origem para o ip do firewall).

    É essencial que as maquinas nas duas redes tenham rotas para se "encontrarem".

    quem é o default gateway das maquinas no outro lado do link de rádio?
    quem é o gateway das maquinas que estão atrás do pfsense?



  • Marcelo você tem skype ou alguma forma de bate papo para conversarmos???

    Ai eu consigo te explicar melhor oque estou tentando fazer…

    Porque na verdade não estou tentando interligar duas maquinas e sim duas redes distintas...

    um tem o gateway como 172.20.6.1 e a outra 10.100.172.1.



  • @gleisonpc:

    Marcelo você tem skype ou alguma forma de bate papo para conversarmos???

    tenho, mas primeiro precisamos acertar o valor da hora de consultoria em pvt.

    @gleisonpc:

    um tem o gateway como 172.20.6.1 e a outra 10.100.172.1.

    estes ips sao do pfsense?



  • Certo vou tentar explicar certinho por aqui…

    Tenho  duas redes...

    Uma no range 10.100.172.x e outra no range 172.20.6.x...

    Meu gateways são 10.100.172.1 e 172.20.6.1, coloquei o pfsense agora na rede com os ip na interface:

    re0 = 10.100.172.12
    xl0 = 172.20.6.15

    Precisava fazer com que as duas redes se comunicassem com ouma rede só...

    Obrigado Glesion.



  • @gleisonpc:

    Precisava fazer com que as duas redes se comunicassem com ouma rede só…

    Coloque nos servidores que são gateways da rede uma rota estática para chegar na outra rede

    ex:

    no 172.20.6.1
    route add 10.100.172.0/24 172.20.6.15

    e no 10.100.172.1
    route add 172.20.6.0/24 10.100.172.12

    Só lembrando que isto não tem nada com a configuração do pfsense, você está com problemas de roteamento, ou no conceito ou na aplicação dele.



  • Mecelo você tinha razão…

    Agora estou criando as rotas na rede...

    So mais uma duvida.

    Minha rota aponta para o IP 10.100.172.12 que o IP do pfsense do meu lado...

    Depois eu crio uma rota para o destino 172.20.6.0 para o gateway 172.20.6.15 que o meu pfsense do outro lado ou para o gatewy que pe o 172.20.6.1?

    Obrigado pela ajuda.



  • Queria agradecer a todos que me ajudaram…

    Consegui fechar a conexão...

    Mantive as configurações no pfsense e configurei o roteamento entre as redes e funcionou....

    Se algum precisar de ajuda em algo parecido estou a disposição.


Log in to reply