OpenVPN Timeout nach 60Min verhindern



  • Hallo zusammen

    ich habe ein Problem mit OpenVPN. Grundsätzlich funktioniert alles problemlos. Nur nach 60min wird die Verbindung getrennt und sich muss mich wieder authentisieren. Wie kann ich ein Timeout verhindern, oder auf einen hohen Wert setzen?

    Im Log des OVPN Server steht dann folgendes:

    Oct 22 12:14:53
    openvpn[29175]: xxx/193.xx.xx.202:2020 Fatal TLS error (check_tls_errors_co), restarting
    Oct 22 12:14:53
    openvpn[29175]: xxx/193.xx.xx.202:2020 TLS Error: TLS handshake failed
    Oct 22 12:14:53
    openvpn[29175]: xxx/193.xx.xx.202:2020 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

    Beim Client:
    Mon Oct 22 12:13:53 2012 TLS: soft reset sec=0 bytes=797235/0 pkts=2750/0

    Es gibt sicher eine Variable welche ich bei der Client Config verwenden kann?

    Habe pfSense 2.01 auf einem ALIX Board am laufen

    Gruss twisters



  • Hi,

    ich have dieses problem nicht. Ich nutze als zusätzlichen Parameter in der client config:

    keepalive 5 30
    

    Es wird alle 5 Sekunden ein ping gesendet. Wird nach 30s keine Antwort gesendet (also 6pings a 5s später), dann wird der Tunnel neu aufgebaut.

    Benutzer SSL/TLS



  • Danke für die Antwort. Ich habe die keepalive Variable getestet. Aber er bricht die Verbindung trotzdem genau nach 60 min ab, und dann erscheit wieder die Aufforderung den User und Passwort anzugeben.

    hier mal meine Client Config.

    client
    dev tun
    proto tcp
    remote 84.xx.xx.xxx 443
    resolv-retry infinite
    nobind
    persist-key
    persist-tun
    http-proxy proxy 3128
    ca MeineCA.crt
    cert Meins_VPN.crt
    key Meins_VPN.key
    tls-auth tls.key 1
    cipher AES-128-CBC
    comp-lzo
    verb 3
    auth-user-pass
    auth-nocache
    keepalive 5 30
    

    Gruss twisters



  • Hi,

    
    --auth-nocache
        Don't cache --askpass or --auth-user-pass username/passwords in virtual memory.
    
        If specified, this directive will cause OpenVPN to immediately forget username/password inputs after they are used. As a result, when OpenVPN needs a username/password, it will prompt for input from stdin, which may be multiple times during the duration of an OpenVPN session.
    
    

    Warum nutzt du diese Funktion ? Du könntest versuchen, diese einmal zu entfernen. Standardmässig ist sie nicht drin.



  • Hast recht, ohne die Funktion auth-nocache funktioniert es. Ich habe es reingetan weil mir der OVPN Client beim Starten das empfohlen hat  ???

    WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
    

    aber in dem Fall lass ich das Weg.

    danke

    twisters


Log in to reply