Captive portal+freeradius2: Control de usuario por tiempo no funciona bien.



  • Hola.

    Llevo algunos dias tratando de configurar un pfsense 2.0.1 para controlar mis usuarios via inalambrica atraves de CP(Captive Portal) con Freeradius2.

    E leido varias veces el manual que hay en ingles pero aun no logro ponerlo a operar como debiera.

    Mi problema radica que cuando genero los usuarios y cada uno con distinto tiempo x dia, FR2 los saca antes de tiempo.

    Veo el log y observo que exactamente cada minuto FR2 esta autenticando a el usuario, pero le corta la sesion antes de tiempo.

    Directamente en consola puedo consultar cada usuario y veo que sus limites de tiempo esta correctos, ejemplo:

    user1 psw1 "Amount of Time"=15
    user2 psw2 "Amount of Time"=5
    user3 psw3 "Amount of Time"=20

    En consola pruebo y todo bien:

    radtest user1 psw1 172.16.1.1 100 secret
    Sending Access-Request of id 48 to 172.16.1.1 port 1812
            User-Name = "user1"
            User-Password = "psw1"
            NAS-IP-Address = 192.168.50.1
            NAS-Port = 100
            Message-Authenticator = 0x00000000000000000000000000000000
    rad_recv: Access-Accept packet from host 172.16.1.1 port 1812, id=48, length=26
            Session-Timeout = 900

    900 segundos = 15 minutos correcto.

    Ahora vamos a ver cuanto tiempo en realidad duran:

    20:14:12    20:19:41 user1 real time: 5 minutes
    20:30:30    20:33:00 user2 real time: 3 minutes
    20:35:28    20:42:16 user3 real time: 7 minutes

    Esos tiempos los saque yo leyendo el log, son los tiempos que duro cada sesion, pero no son reales, ayer di de alta un usuario x 5 horas y lo saco como a los 40 minutos.

    Mis configuraciones aqui estan:

    http://www.flickr.com/photos/89483731@N03/8143843432/
    http://www.flickr.com/photos/89483731@N03/8143811669/
    http://www.flickr.com/photos/89483731@N03/8143811593/
    http://www.flickr.com/photos/89483731@N03/8143811557/
    http://www.flickr.com/photos/89483731@N03/8143811501/

    Si alguien por aqui tiene funcionando esta mezcla sin problema y pueda hecharme la mano se los agradecere mucho, gracias!!



  • Importante postear las imágenes en Additional Options… Attach

    (abajo a la izquierda de los mensajes)

    Quedan en el propio foro y son más manejables.

    Concretamente en este caso no logro verlas bien. A pesar de engrandecerlas están como desenfocadas.

    ¡Gracias!



  • Lo tenia pensado hacer solo que el limite de los post, tenia que hacer varios post para las imagenes, pero gracias por la sugerencia, voy hacer algo al respecto.
    Saludos bellera.


Log in to reply