Multiple Xbox360's can't connect



  • I have spent hours upon hours reading here, searching online, making changes to pfSense, re-installing pfSense and nothing works.  We have 2 Xbox 360's (and about to buy another 1 or two for Media Center use) and only 1 can ever be on at a time.  I don't want to do the port forward method but instead want to use UPNP.  I am using Traffic Shaping, but I am not sure if that matters.  So you can see exactly how I have it set up, I am going to post the screen shots and hope that someone sees my error right away and can help me get this working.

    Both current Xbox's use DHCP but have a static address assigned.  Let me know if I need to include any other screen shots to help find a solution.



  • What version of pfSense are you running, that UPnP screenshot doesn't look like mine.



  • 1.2.3

    It runs rock solid for me (except for UPNP, I guess) and I'm worried about upgrading to v2.  I actually tried one of the beta versions and never could get it to load on my AMD based system, while v1.2.3 installs without a problem.



  • Your settings look good as far as I can tell.  Are your XBoxes connected to the same switch?

    UPnP might be blocked somewhere else within your network for example if you happen to use a managed switch then ensure that multicast filtering is not enabled.

    I personally don't use the multicast firewall rules in pfSense LAN and I have 2 XBoxes and 2 PS3s all working simultaneously without issue with settings similar to yours except i have the "default deny access to UPnP" checked and setup specified permissions for my consoles.

    I'm up to 2.1 Beta right now but this setup has been working for me even when i was using 1.2.3 years ago.



  • Everything is home runed back to the same switch (D-Link DGS-1024D Unmanaged 24 Port 10/100/1000 Mbps).

    I have tried it with and without the multicast rules and it didn't make a difference.



  • Anyone have any ideas?  As stated above, I have re-installed pfSense (more than once), used a different system to install it on and now even tried a different unmanaged switch and still we can't get more than one Xbox online at a time.  UPnP just does not work no matter what I try.



  • Shot in the dark but try this:

    I'm using 2.1 Beta right now and they've changed the Manual Outbound NAT code slightly so under NAT Address, mine says WAN Address while yours states * (Any).  Double check this setting, and change Translation Address to Interface Address or WAN.  It should look like this for you then:

    WAN  192.168.1.81/32 * * * WAN address *      YES
    WAN  192.168.1.82/32 * * * WAN address *      YES
    WAN  192.168.1.0/24 * * * WAN address *      NO

    In the UPnP page check the box that says "By default deny access to UPnP."

    In the "user specified permissions" box below that enter the following two lines:

    allow 88-65535 192.168.1.81/32 88-65535
    allow 88-65535 192.168.1.82/32 88-65535

    Now hit the Change button at the very bottom.

    Now clear your states in the GUI by going to Diagnostics/States/Reset States/Reset, or you can simply reboot your pfSense.

    Now turn your Xboxes on one at a time with at least 5 minutes apart, do not start them simultaneously.

    If it doesn't work then there is nothing in the pfSense settings I believe that can help you.  You are not the only one who states that these UPnP instructions doesnt work for them.  But there are users like myself that this is all that is required.  I can only imagine that there is something upstream of your pfSense that is blocking you from getting this to work.



  • In the past I have found the only reliable way to get 2 (or more) Xboxes running is either:

    1. Easy Solution
      DMZ to individual external IP's

    2. More unusual Solution
      Port Triggering - see this posting if you want to contribute:
      http://forum.pfsense.org/index.php/topic,39638.0.html

    The above was with DD-wrt or similar router with port triggering facility. 
    One specific router I had (sorry long gone) simply required uPnP enabled - as long as the XBoxes received IP by DHCP (and therefore gave MAC addresses) the router managed the two through automatic triggering.

    Not knowledgeable enough with pfs to know if this is possible

    Good Luck


Locked