Snom Phone and OpenVPN



  • Hi Everybody,

    After beating my head on this for like a week and searching for everything possible I need to ask for help.

    I have successfully connected a remote Snom 821 to my work pfsense openvpn server but I cannot access the phone's webpage from the LAN behind the pfsense box.

    Remote LAN: 10.0.0.0/24
    Local LAN: 192.168.1.0/24
    VPN Pool: 10.0.8.0/24
    Snom phone Virtual Address: 10.0.8.6

    Shouldn't the 192.168.1.0/24 LAN be able to access the phone on the virtual address pool? What am I doing wrong?

    I don't really know what to post here to help troubleshoot, so please let me know what other info is required.

    thanks



  • I have a similar config except my snom is on a remote vlan and not on the remote lan.
    To get to it, I needed to add an Client Specific override with "iroute 192.168.4.0 255.255.255.0" where the net is the remote phone vlan. Not sure of the specifics for your case.



  • Where did you add this override? On Pfsense or in the vpn.cnf file?



  • pfsense -> vpn -> openvpn -> ClientSO



  • Ah, I see.

    But where do I put that line? I'm thinking I need a bit more in depth explanation.  Can you please post a screenshot of your override?

    thanks



  • Paste it into the 'Advanced' section at the bottom of the Client Specific Overrides.



  • Thanks for the help, but this doesn't seem to be working.  I can't register the phone on the PBX because it can't access the Local Network behind pfsense.

    Can anybody else please help me out?



  • Okay, I have this working now.

    I put the```
    push "iroute 10.0.0.0 255.255.255.0"

    
    Ini order to register the phone I had to manually provision the phone. It will not auto-provision, I assume because pfsense doesn't pass the option 66 for TFTP to the Virtual Lan clients? Either that or OpenVPN doesn't support passing said option?
    
    Thanks for the help thermo!

Log in to reply