Subnet ( redes em diferentes subnets não nevega na internet )



  • Boa tarde a todos,

    Como muitos aqui primeiramente gostaria de agradecer pela oportunidade de participar deste forum, e tb de informar que estou conhecendo agora o PfSense e estou maravilhado com todas as funções que o mesmo tem. Vamos ao meu problema.

    Ambiente.:
    Estou com uma máquina instalada o PFsense 2.0.1, onde esta com os pacotes Squid, SquidGuard e LightSquid instalado sem problemas.
    Existe 2 placa de redes neste servidor. Wan e Lan.
    Wan : DHCP ( OK )
    Lan  : 192.168.0.10 ( setei este ip como teste inicial, o mesmo esta normal ), testei a navegações de uma máquina física da rede com o Gateway 192.168.0.10 e a mesma navegou normalmente, realizei testes de bloqueio de sites no Proxy e esta funcionando perfeitamente. Até aqui tudo ok.

    Problema. : Na minha rede eu configurei escopo no servidor DHCP para distribuir a faixa 192.168.0.0 , 192.168.1.0, 192.168.2.0 que funciona a anos assim, tudo ok.
    Mas como quero usar o pfsense como firewall principal começa o problema. Nos testes as maquinas que estão na mesma subrede navega normalmente na internet, ou seja, maquinas que estão na subrede 192.168.0.0 navegam normalmente.

    Mas quando as maquinas recebem o ip na subrede 192.168.1.0 e 192.168.2.0 os mesmos não navegam ???

    O que esta acontecendo, sem que para vcs pode ser algo simples mas pra mim sera a sulução.

    Grato



  • Qual é a máscara que você está usando na Interface LAN e no DHCP server? O pfSense é seu DHCP server?



  • @slackware:

    Mas quando as maquinas recebem o ip na subrede 192.168.1.0 e 192.168.2.0 os mesmos não navegam ???

    slackware, Bem vindo ao fórum! :)

    Você configurou os ips virtuais de cada rede no seu pfsense e o definiu como gateway de cada segmento?

    O mais indicado seria um segmento de rede para cada faixa de ip no lugar de várias faixas.

    att,
    Marcello Coutinho



  • @johnnybe:

    Qual é a máscara que você está usando na Interface LAN e no DHCP server? O pfSense é seu DHCP server?

    Bom dia Johnnybe,

    Cara todas as máscaras estão classe C. /24

    ex.
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24

    Não sei o que fazer. kkk help



  • @marcelloc:

    @slackware:

    Mas quando as maquinas recebem o ip na subrede 192.168.1.0 e 192.168.2.0 os mesmos não navegam ???

    slackware, Bem vindo ao fórum! :)

    Você configurou os ips virtuais de cada rede no seu pfsense e o definiu como gateway de cada segmento?

    O mais indicado seria um segmento de rede para cada faixa de ip no lugar de várias faixas.

    att,
    Marcello Coutinho

    Bom dia Marcello,

    Depois que vc informou sobre os ips virtuais, ae fui ver se dava serto.
    Pelo que vi para a configuração dos Ips Virtuais não pede muita coisa, configurei para network e adicionei o IP das subredes e mesmo assim o problema continua.
    Chequei a instalar o Squid3 pra ver se tem algo a ver e mesmo problema.



  • @slackware:

    @johnnybe:

    Qual é a máscara que você está usando na Interface LAN e no DHCP server? O pfSense é seu DHCP server?

    Cara todas as máscaras estão classe C. /24

    ex.
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24

    Onde e como você definiu isso? Poderia colocar cópias de tela clicando em Additional Options? Está usando mais e uma placa de rede? Está usando ips virtuais de cada rede no seu pfsense?



  • @johnnybe:

    @slackware:

    @johnnybe:

    Qual é a máscara que você está usando na Interface LAN e no DHCP server? O pfSense é seu DHCP server?

    Cara todas as máscaras estão classe C. /24

    ex.
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24

    Onde e como você definiu isso? Poderia colocar cópias de tela clicando em Additional Options? Está usando mais e uma placa de rede? Está usando ips virtuais de cada rede no seu pfsense?

    Segue a tela de onde coloquei as informaçoes acima.
    Esta tela salvei da net mas é a mesma que coloquei as configurações de minha empresa.




  • Essa imagem é do Proxy. Eu falei da interface LAN e do DHCP server.  ::)



  • @johnnybe:

    Essa imagem é do Proxy. Eu falei da interface LAN e do DHCP server.  ::)

    Bom dia,

    Vou ver as configurações da Lan, e ja respondo.
    Mas pelo que me lembro se não estou enganado a LAN solicita apenas o IP fixo e a masc que coloquei /24 e o meu DHCP Server esta desabilitado. Só DHCP da WAN esta ativo.

    Vou dar uma olhada e ja respondo seu questionamento.



  • @slackware:

    Cara todas as máscaras estão classe C. /24

    Seu print do squid mostra somente uma rede.

    Você esta usando rede 10 ou 192?

    varias redes /24 costumam ser representadas por um /16 na configuração do squid

    exemplo:
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24
    .
    .
    .

    fica 192.168.0.0/16 (192.168.0.1 até 192.168.255.254)



  • @marcelloc:

    @slackware:

    Cara todas as máscaras estão classe C. /24

    Seu print do squid mostra somente uma rede.

    Você esta usando rede 10 ou 192?

    varias redes /24 costumam ser representadas por um /16 na configuração do squid

    exemplo:
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24
    .
    .
    .

    fica 192.168.0.0/16 (192.168.0.1 até 192.168.255.254)

    Legal,

    Na realidade o meu problema são as Subredes, que que só uma uma subrede navega na internet que é a 192.168.0.0 a 192.168.1.0 e 192.168.2.0 não navega na internet.
    eu cheguei a colocar 192.168.0.0/16 e não esta dando certo.

    Não tem nenhuma rede diferente não tem rede 10 só 192.



  • @slackware:

    @marcelloc:

    @slackware:

    Cara todas as máscaras estão classe C. /24

    Seu print do squid mostra somente uma rede.

    Você esta usando rede 10 ou 192?

    varias redes /24 costumam ser representadas por um /16 na configuração do squid

    exemplo:
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24
    .
    .
    .

    fica 192.168.0.0/16 (192.168.0.1 até 192.168.255.254)

    … eu cheguei a colocar 192.168.0.0/16 e não esta dando certo.

    Onde você colocou isso?
    Seja mais específico. Quando perguntei "O pfSense é seu DHCP server?", você não respondeu.  Estamos querendo ajudar, mas suas informações são vagas.
    E quando eu digo nós, eu quero dizer:  Eu, o Marcello e talvez mais alguém que se aventurar a "adivinhar" suas configurações.  ???



  • @johnnybe:

    @slackware:

    @marcelloc:

    @slackware:

    Cara todas as máscaras estão classe C. /24

    Seu print do squid mostra somente uma rede.

    Você esta usando rede 10 ou 192?

    varias redes /24 costumam ser representadas por um /16 na configuração do squid

    exemplo:
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24
    .
    .
    .

    fica 192.168.0.0/16 (192.168.0.1 até 192.168.255.254)

    … eu cheguei a colocar 192.168.0.0/16 e não esta dando certo.

    Onde você colocou isso?
    Seja mais específico. Quando perguntei "O pfSense é seu DHCP server?", você não respondeu.  Estamos querendo ajudar, mas suas informações são vagas.
    E quando eu digo nós, eu quero dizer:  Eu, o Marcello e talvez mais alguém que se aventurar a "adivinhar" suas configurações.  ???

    Boa tarde,

    Hoje nao consegui pegar o Pfsense para corrigir este problema, amanhã será mais calmo aqui na empresa e terei como explicar melhor, agradeço a ajuda mesmo.



  • @slackware:

    @johnnybe:

    @slackware:

    @marcelloc:

    @slackware:

    Cara todas as máscaras estão classe C. /24

    Seu print do squid mostra somente uma rede.

    Você esta usando rede 10 ou 192?

    varias redes /24 costumam ser representadas por um /16 na configuração do squid

    exemplo:
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24
    .
    .
    .

    fica 192.168.0.0/16 (192.168.0.1 até 192.168.255.254)

    … eu cheguei a colocar 192.168.0.0/16 e não esta dando certo.

    Onde você colocou isso?
    Seja mais específico. Quando perguntei "O pfSense é seu DHCP server?", você não respondeu.  Estamos querendo ajudar, mas suas informações são vagas.
    E quando eu digo nós, eu quero dizer:  Eu, o Marcello e talvez mais alguém que se aventurar a "adivinhar" suas configurações.  ???

    Boa tarde,

    Hoje nao consegui pegar o Pfsense para corrigir este problema, amanhã será mais calmo aqui na empresa e terei como explicar melhor, agradeço a ajuda mesmo.

    Boa tarde johnnybe,

    Só respondendo sua pergunta, a LAN do pfsense não esta DHCP esta fixo.



  • Não foi isso que perguntei. Deixa pra lá.  :)



  • @johnnybe:

    Não foi isso que perguntei. Deixa pra lá.  :)

    Cara desculpas mas então não estou entendendo.

    VC perguntou se o meu pfsense é dhcp eu disse que não, e disse tb que o Ip da lan é lixo, me desculpa mas realmente não estou entendendo



  • @johnnybe:

    Não foi isso que perguntei. Deixa pra lá.  :)

    Cara desculpas, mas vc me perguntou se "O pfSense é seu DHCP server?".
    Eu respondi que não, e disse que a LAN esta com ip fixo.

    Realmente não estou entendendo então.



  • @slackware:

    @johnnybe:

    Não foi isso que perguntei. Deixa pra lá.  :)

    Cara desculpas mas então não estou entendendo.

    VC perguntou se o meu pfsense é dhcp eu disse que não, e disse tb que o Ip da lan é lixo, me desculpa mas realmente não estou entendendo

    Eu perguntei se o seu pfSense é seu DHCP server. Só para lembrar:

    @johnnybe:

    Qual é a máscara que você está usando na Interface LAN e no DHCP server? O pfSense é seu DHCP server?

    Nenhuma dessa questões foram respondidas. E também não perguntei se na interface LAN o IP está fixo, perguntei outra coisa, conforme quote acima.
    O que deve estar errado na sua interface LAN, o marcelloc já apontou, apesar dele ter citado apenas o Squid:

    @marcelloc:

    @slackware:

    Cara todas as máscaras estão classe C. /24

    Seu print do squid mostra somente uma rede.

    Você esta usando rede 10 ou 192?

    varias redes /24 costumam ser representadas por um /16 na configuração do squid

    exemplo:
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24
    .
    .
    .

    fica @marcelloc:

    @slackware:

    Cara todas as máscaras estão classe C. /24

    Seu print do squid mostra somente uma rede.

    Você esta usando rede 10 ou 192?

    varias redes /24 costumam ser representadas por um /16 na configuração do squid

    exemplo:
    192.168.0.0/24
    192.168.1.0/24
    192.168.2.0/24
    .
    .
    .

    fica 192.168.0.0/16 (192.168.0.1 até 192.168.255.254)

    (192.168.0.1 até 192.168.255.254)

    Acredito que sua configuração na LAN, também deveria ter esse CIDR 192.168.0.0/16.



  • @slackware:

    @johnnybe:

    Não foi isso que perguntei. Deixa pra lá.  :)

    Cara desculpas, mas vc me perguntou se "O pfSense é seu DHCP server?".
    Eu respondi que não, e disse que a LAN esta com ip fixo.

    Onde você respondeu isso, antes? Sinceramente não vi. Eu vi outra resposta diferente dessa, conforme abaixo:

    @slackware:

    @slackware:

    @johnnybe:


    Seja mais específico. Quando perguntei "O pfSense é seu DHCP server?", você não respondeu.

    Boa tarde,

    Hoje nao consegui pegar o Pfsense para corrigir este problema, amanhã será mais calmo aqui na empresa e terei como explicar melhor, agradeço a ajuda mesmo.

    Boa tarde johnnybe,

    Só respondendo sua pergunta, a LAN do pfsense não esta DHCP esta fixo.



  • @johnnybe:

    @slackware:

    @johnnybe:

    Não foi isso que perguntei. Deixa pra lá.  :)

    Cara desculpas, mas vc me perguntou se "O pfSense é seu DHCP server?".
    Eu respondi que não, e disse que a LAN esta com ip fixo.

    Onde você respondeu isso, antes? Sinceramente não vi. Eu vi outra resposta diferente dessa, conforme abaixo:

    @slackware:

    @slackware:

    @johnnybe:


    Seja mais específico. Quando perguntei "O pfSense é seu DHCP server?", você não respondeu.

    Boa tarde,

    Hoje nao consegui pegar o Pfsense para corrigir este problema, amanhã será mais calmo aqui na empresa e terei como explicar melhor, agradeço a ajuda mesmo.

    Boa tarde johnnybe,

    Só respondendo sua pergunta, a LAN do pfsense não esta DHCP esta fixo.

    Talvez a minha falta de conhecimento do pfsense esteja dificultando nas minhas respostas, mas o que respondi anteriormente ajuda algo.



  • @slackware:

    @johnnybe:

    @slackware:

    @johnnybe:

    Não foi isso que perguntei. Deixa pra lá.  :)

    Cara desculpas, mas vc me perguntou se "O pfSense é seu DHCP server?".
    Eu respondi que não, e disse que a LAN esta com ip fixo.

    Onde você respondeu isso, antes? Sinceramente não vi. Eu vi outra resposta diferente dessa, conforme abaixo:

    @slackware:

    @slackware:

    @johnnybe:


    Seja mais específico. Quando perguntei "O pfSense é seu DHCP server?", você não respondeu.

    Boa tarde,

    Hoje nao consegui pegar o Pfsense para corrigir este problema, amanhã será mais calmo aqui na empresa e terei como explicar melhor, agradeço a ajuda mesmo.

    Boa tarde johnnybe,

    Só respondendo sua pergunta, a LAN do pfsense não esta DHCP esta fixo.

    Talvez a minha falta de conhecimento do pfsense esteja dificultando nas minhas respostas, mas o que respondi anteriormente ajuda algo.

    Esquece, ok? Como dizia o Caetano Veloso: Você não está entendendo quase nada do que eu digo. Na boa, tá bem?  :)



  • @johnnybe:

    @slackware:

    @johnnybe:

    @slackware:

    @johnnybe:

    Não foi isso que perguntei. Deixa pra lá.  :)

    Cara desculpas, mas vc me perguntou se "O pfSense é seu DHCP server?".
    Eu respondi que não, e disse que a LAN esta com ip fixo.

    Onde você respondeu isso, antes? Sinceramente não vi. Eu vi outra resposta diferente dessa, conforme abaixo:

    @slackware:

    @slackware:

    @johnnybe:


    Seja mais específico. Quando perguntei "O pfSense é seu DHCP server?", você não respondeu.

    Boa tarde,

    Hoje nao consegui pegar o Pfsense para corrigir este problema, amanhã será mais calmo aqui na empresa e terei como explicar melhor, agradeço a ajuda mesmo.

    Boa tarde johnnybe,

    Só respondendo sua pergunta, a LAN do pfsense não esta DHCP esta fixo.

    Talvez a minha falta de conhecimento do pfsense esteja dificultando nas minhas respostas, mas o que respondi anteriormente ajuda algo.

    Esquece, ok? Como dizia o Caetano Veloso: Você não está entendendo quase nada do que eu digo. Na boa, tá bem?  :)

    Bom dia johnnybe,

    Eu agradeço toda a ajuda sua e de todos, quero informar que conseguir resolver o problema, acho que tava com algum problema de instalação havia configurado de todas as formas e não tinha nenhum resultado positivo.

    Então resolvi formatar e instalar novamente o PFsense 2.0.1. E refis a mesma configuração que havia feito anteriormente porém agora deu certo.

    Apenas configurei na LAN um IP fixo e mascara /16 funcionou que foi uma beleza. kkk
    O esquisito porque antes havia testado na mascara /16 e o pfsense parava de funcionar tinha q voltar para a marcara /24.

    OBS.: Já tava comedo do johnnybe kkk, ae brincadeira.



  • @slackware:

    Bom dia johnnybe,

    Eu agradeço toda a ajuda sua e de todos, quero informar que conseguir resolver o problema, acho que tava com algum problema de instalação havia configurado de todas as formas e não tinha nenhum resultado positivo.

    Então resolvi formatar e instalar novamente o PFsense 2.0.1. E refis a mesma configuração que havia feito anteriormente porém agora deu certo.

    Apenas configurei na LAN um IP fixo e mascara /16 funcionou que foi uma beleza. kkk
    O esquisito porque antes havia testado na mascara /16 e o pfsense parava de funcionar tinha q voltar para a marcara /24.

    OBS.: Já tava comedo do johnnybe kkk, ae brincadeira.

    ;D
    Bom dia!
    Excelente! O ideal seria que você utilizasse VLANs para as subnets, ou placas de rede extras. Mas tudo bem, valeu.
    E obrigado pelo feedback.



  • @johnnybe:

    @slackware:

    Bom dia johnnybe,

    Eu agradeço toda a ajuda sua e de todos, quero informar que conseguir resolver o problema, acho que tava com algum problema de instalação havia configurado de todas as formas e não tinha nenhum resultado positivo.

    Então resolvi formatar e instalar novamente o PFsense 2.0.1. E refis a mesma configuração que havia feito anteriormente porém agora deu certo.

    Apenas configurei na LAN um IP fixo e mascara /16 funcionou que foi uma beleza. kkk
    O esquisito porque antes havia testado na mascara /16 e o pfsense parava de funcionar tinha q voltar para a marcara /24.

    OBS.: Já tava comedo do johnnybe kkk, ae brincadeira.

    ;D
    Bom dia!
    Excelente! O ideal seria que você utilizasse VLANs para as subnets, ou placas de rede extras. Mas tudo bem, valeu.
    E obrigado pelo feedback.

    Legal, mas não sei muito bem como fazer essas VLANs, como estou em ambiente de teste a hora de erra é agora.
    Vou dar uma lida em algum documento referente ao assunte para melhor entendimento. Tem algum site com essas informações ?



  • @slackware:

    Vou dar uma lida em algum documento referente ao assunte para melhor entendimento. Tem algum site com essas informações ?

    O google vai ser sua principal fonte de busca.  ;)

    Vlans são muito usadas para segmentação, mas não esquece de arrumar um switch com suporte a vlans.



  • @marcelloc:

    @slackware:

    Vou dar uma lida em algum documento referente ao assunte para melhor entendimento. Tem algum site com essas informações ?

    O google vai ser sua principal fonte de busca.  ;)

    Vlans são muito usadas para segmentação, mas não esquece de arrumar um switch com suporte a vlans.

    Ditto!
    Assim mesmo, com dois Ts:
    https://pt.wiktionary.org/wiki/ditto
    ;)


Locked