Hotspot login cannot open….



  • Hi,
    I'm getting an error on my captive portal:

    hotspot login cannot open the page because the server cannot be found….

    has anybody had this before?



  • Is this a new install?

    Is DNS working?

    TT



  • yes, i checked DNS.

    i deleted the captive portal and the custom pages etc and stripped it back to the default.
    everything works as expected. i log onto the wireless and the pfsense captive portal page comes up.
    i enter my user/pass and i get the above error. however, because i am successful with the login (apart from it not redirecting me), i get this error.
    i can still browse the internet etc if i open a browser.



  • i have now place www.google.co.uk into the "After Authentication URL" and it stops this error from appearing. however, it redirects me back to the authentication page rather than google.

    and it seems related to this thread:
    http://forum.pfsense.org/index.php/topic,55387.0.html

    as once i put http://www.google.co.uk instead of www.google.co.uk, it worked. leaving the redirect blank doesn't work and gives me the hotspot error



  • what do you type in the explorer bar to initiate you initial connection to the portal?

    TT



  • nothing. my iphone logs on to the wireless and the portal pops up asking for a password. i suppose it doesn't know where to go after that unless i specify a post authentication page.



  • this is what it says in the "After Authentication Redirection URL" option

    "If you provide a URL here, clients will be redirected to that URL instead of the one they initially tried to access after they've authenticated."

    So if you try to authenticate using a blank URL, it won't do anything.

    Just put in a redirect url.

    Rob


Locked