I can't access the webGUI after changing the http port !



  • Greetings everyone,

    I'm posting here after lots of online searching… don't know what to do!
    All I did is that I changed the WebGUI http port to 77 which is stupid.. I know :(

    now I can't access the WebGUI... I tried to restart the WebGUI using ssh.. but that didn't solve it.
    I also tried to reassign IP addresses for the interfaces... but it never asked me for the http port as some people said it should!

    I tried to search for a shell command to would enable me to change the http port.. but I couldn't find that command?

    Any one knows that shell command guys?

    Any one knows any other way to fix this?

    I'm thinking about using the factory defaults restore... but I don't wanna lose the users list for the captive portal or the FreeRADUIS !

    You are my only hope.. and I can't wait for long :(



  • I've solved it.. Thanks to Allah :)

    I used the shell (option 8) and typed the following:

    cd ..
    cd conf
    ee config.xml
    
    

    then I scrolled few lines down to the port of webgui and changed the port to 80 while making sure it's still in http protocol
    then press Esc… the menu will show up... go to file operation and choose "save file".... then just restart the system and that's it ;)

    Thank you guys anyway :)



  • Another possibility from ssh would be to chose option "select LAN IP address".
    When you set the new old LAN IP it resets the webGUI port back to the original state. And you do not need a reboot  :)


Locked