Captive portal - Allow hostnames problems



  • Hi at all,
    this is my first post. I'm a newbie!!!! ???

    I activated the Captive Portal service on my pfsense. It's works fine but I don't understand how to enable resolution of my hostnames in  the tab "allow hostnames". By IP it's ok instead if i add a hostname doesn't works.

    I show my system configuration :
    Router netgear  <-> Pfsense <-> LAN Lab

    Router -> gateway 192.168.0.1
    Pfsense
    Wan 192.168.0.254 
    Lan  192.168.1.1
    hostname: pfsense
    domain: pippo.it
    dns 8.8.8.8, 208.67.220.220, 208.67.222.222, 192.168.1.22 (DC w2k8 in LAN lab enviroment). All with "use gateway" = none
    Enable -> dns forwarder

    If i work with IP all works fine. I'd like to use the hostnames of the active directory.
    I hope someone tell me where I'm wrong.
    Thank you very much



  • I solved!!  I unchecked :  Do not use the DNS Forwarder as a DNS server for the firewall -> in System: General Setup.

    Now DNS lookup in -> Diagnostics  resolve in my FQDN .

    thanks
    bye


Locked