Authentification distante du serveur Radius ne marche pas



  • Bonjour,

    J'ai implementé le portail captif de pfsense,et configuré un serveur freeradius pour l'authentification distante. Eux tous marchent bien.
    Sur mon serveur pfsense, je peux pinger www.yahoo.fr, le serveur DNS et le serveur freeradius.
    Maintenant le problème est que dans les configs du portail captif de pfsense j'ai indiqué l'adresse de mon serveur radius sur lequel l'authentification doit se faire.
    Mais quand je tente de m'authentifier à travers le formulaire d'authentification proposé par pfsense, il me dit "aucune reponse valide du serveur radius n'a été reçu".
    Vu que les pings marchent, quel peut être la cause de ce problème que je ne comprends pas?

    Merci bien de votre aide!



  • Sur mon serveur pfsense, je peux pinger www.yahoo.fr, le serveur DNS et le serveur freeradius.

    C'est bien, c'est nécessaire et cela permet de valider que la communication fonctionne correctement au niveau de la couche réseau. Comme vous le voyez ce n'est pas suffisant.

    Mais quand je tente de m'authentifier à travers le formulaire d'authentification proposé par pfsense, il me dit "aucune reponse valide du serveur radius n'a été reçu".

    Il y a fort à parier que les informations transmises ne sont pas correctes ou suffisante pour que l'authentification puisse être réalisée. Radius, comme tous les protocoles, à ces règles de fonctionnement. Il faut les respecter en vérifiant que tous vos paramètres sont cohérents, à commencer par le secret partagé avec le radius.
    Une capture de trames des échanges réalisés avec le serveur radius pourrait sans doute montrer ce qui pose problème.



  • Le schéma est :

    • le portail demande l'authentification à Radius,
    • Radius demande l'authentification à un autre serveur.

    Vous ne précisez quasiment rien :

    • ou est le service Radius ?
    • Est ce vraiment FreeRadius ou FreeRadius2 ? (incompatible)
    • comment est-il lui-même configuré ?
    • quel machine fournit l'authentification réelle à Radius ?

    Je vous encourage à d'abord chercher sur le forum des exemples réussis (il y en a mais … il faut lire l'anglais).

    (Cela ne peut être réussi en juste claquant des doigts : il FAUT vérifier chaque étape, chaque paramétrage ...)



  • Merci à vous pour ces reponses;

    En fait c'est une base mysql que j'utilise et elle se trouve sur la meme machine que radius(Freeradius 2).
    Je vous explique une configuration où l'authentification radius marche:
    LAN de mon pfsense: 176.50.1.2
    WAN de mon pfsense:192.168.0.20

    IP de mon serveur Radius: 176.50.1.3

    IP de mon routeur wifi linksys: 192.168.1.1
    Le serveur radius et le lan de mon pfsense sont branchés à mon routeur wifi
    Le routeur wifi et le wan de mon pfsense sont branchés au mur (reseau de l'entreprise).
    Quand je teste l'authentification radius marche bien; mais c'est la page internet demandée qui n'arrive pas à se charger.

    Par ailleur quand j'essai de tester les utilisateurs mysql dans ma base sur le serveur radius (radtest) en local ça marche.
    Merci bien de votre aide!



  • @Abou:

    LAN de mon pfsense: 176.50.1.2
    WAN de mon pfsense:192.168.0.20

    IP de mon serveur Radius: 176.50.1.3

    IP de mon routeur wifi linksys: 192.168.1.1
    Le serveur radius et le lan de mon pfsense sont branchés à mon routeur wifi

    Pas cohérent ou mal expliqué : routeur wifi linksys: 192.168.1.1 et d'autre part IP de mon serveur Radius: 176.50.1.3 ?

    Le routeur wifi et le wan de mon pfsense sont branchés au mur (reseau de l'entreprise).

    Au mur de feu ??
    Sur FreeRadius 2 je crois que jdh a dit quelque chose …



  • J'ai lu qu'il ne faut pas installer FreeRadius et FreeRadius2, simultanément ou non, sur pfSense …
    On choisit l'un ou l'autre ...


Locked