2.0.2 - Open VM Tools not working



  • Just noticed a bunch of these entries in the syslog (all since updating to 2.0.2):

    kernel: VMware memory control driver initialized
    

    and

    root: /usr/local/etc/rc.d/vmware-guestd.sh: WARNING: failed to start vmware_guest
    

    I did have the Open-VM-Tools-8.8.1 version installed probably clicked the wrong one when re-installing the other day.  I removed that and installed 8.7.0.3046 (build-31302), which I had used with 2.0.1.

    Neither package installs properly now and, after a reboot of pfSense, I've got this:

    Reinstalling package Open-VM-Tools because its include file(/usr/local/pkg/open-vm-tools.inc) is missing!
    

    followed by hundreds of other error lines.

    I'll try reinstalling 2.0.2 and see what happens.



  • That VM must have been totally corrupted.  Didn't matter what I installed (2.0.1 or 2.0.2), I pretty much got the same results with VMware Tools.  Very odd.

    I finished up deleting that VM and resurrecting a 2.1 VM from months ago.  Updated it to the 24 December build and, once I sorted out all the changes I've made since then, I'm back on line again.


Locked