Problemas con el RRD Graphs



  • Buenas compañeros

    Tengo un inconveniente con mis gráficas del (RRD GRAPHS) de uno de los pfsense con los que trabajo, por alguna razón dejaron de funcionar y no puedo ver las gráficas , haber si alguno tiene una solución o si han pasado por algo parecido. Les dejo las imágenes y estaré a la espera de sus respuestas.

    Como nota: Si hay internet y los usuarios puedan navegar sin problemas con squid que instale en el pfsense.

    Saludos y bendiciones.







  • En la pestaña Settings tienes un botón que dice Reset RRD Data.

    Te quedarás sin histórico pero eso sirve para recrear todos los ficheros de gráficos, que posiblemente tienes degradados.



  • Buenas Josep muchas gracias por tu muy frecuente ayuda!!

    Hice los pasos que mencionaste y no funciono!! el pfsense sigue sin demostrar las gráficas como las imágenes anteriores. Existe alguna otra solución?  la versión del pfsense es 2.0.1 64bits.



  • Raro…

    Para ver qué tienes, Diagnostics - Command Prompt - Execute Shell command

    ls -l /var/db/rrd

    Que no sea que tengas el disco lleno… Lo puedes ver en el propio Dashboard

    O con problemas, Diagnostics - SMART Status

    Puedes hacer un test Short y si no da error asegurar la comprobación con un Long.



  • Para ver qué tienes, Diagnostics - Command Prompt - Execute Shell command

    ls -l /var/db/rrd

    $ ls -l /var/db/rrd
    total 7116
    -rw-r–r--  1 nobody  wheel  194864 Dec 28 16:33 ipsec-packets.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 ipsec-traffic.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 lan-packets.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 lan-traffic.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 opt1-packets.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 opt1-traffic.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 opt2-packets.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 opt2-traffic.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 opt3-packets.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 opt3-traffic.rrd
    -rw-r--r--  1 nobody  wheel  727640 Dec 28 16:33 system-memory.rrd
    -rw-r--r--  1 nobody  wheel  243416 Dec 28 16:33 system-processor.rrd
    -rw-r--r--  1 nobody  wheel  243416 Dec 28 16:33 system-states.rrd
    -rw-r--r--  1 root    wheel    5671 Dec 28 08:40 updaterrd.sh
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 wan-packets.rrd
    -rw-r--r--  1 nobody  wheel  194864 Dec 28 16:33 wan-traffic.rrd

    Diagnostics - SMART Status

    Puedes hacer un test Short:

    Diagnostics: S.M.A.R.T. Monitor Tools

    smartctl 5.41 2011-06-09 r3365 [FreeBSD 8.1-RELEASE-p6 amd64] (local build)
    Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

    /dev/: Unable to detect device type
    Smartctl: please specify device type with the -d option.

    Use smartctl -h to get a usage summary

    y si no da error asegurar la comprobación con un Long.

    smartctl 5.41 2011-06-09 r3365 [FreeBSD 8.1-RELEASE-p6 amd64] (local build)
    Copyright (C) 2002-11 by Bruce Allen, http://smartmontools.sourceforge.net

    /dev/: Unable to detect device type
    Smartctl: please specify device type with the -d option.

    Use smartctl -h to get a usage summary

    ![disk usage.jpg](/public/imported_attachments/1/disk usage.jpg)
    ![disk usage.jpg_thumb](/public/imported_attachments/1/disk usage.jpg_thumb)



  • Los ficheros rrd están y parece que se actualizan.

    Tu disco no es SMART o la funcionalidad SMART no está activada en la BIOS. Por eso no te funcionan los tests SMART.

    El disco está bastante vacío, por la imagen que posteas.

    Postea, por favor, el resultado de:

    Diagnostics - Command Prompt - Execute Shell command

    ifconfig

    No olvides emmascarar los datos sensibles (tus MAC y posibles IPs públicas)



  • Gracias  Joseph Feliz nuevo año, este es el resultado.

    Postea, por favor, el resultado de:

    Diagnostics - Command Prompt - Execute Shell command

    ifconfig

    $ ifconfig
    bce0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=800bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate>ether 00:00:00:00:00
    inet X.X.X.X netmask 0xfffffffc broadcast X.X.X.X
    inet6 fe80::226:b9ff:fe3b:c7b0%bce0 prefixlen 64 scopeid 0x1
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    bce1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=800bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate>ether 00:06:b9:3b:87:a2
    inet 172.16.4.12 netmask 0xffffff00 broadcast 172.16.4.255
    inet6 fe80::226:b9ff:fe3b:c7b2%bce1 prefixlen 64 scopeid 0x2
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    bce2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=800bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate>ether 00:85:b9:3b:c7:t4
    inet 192.168.110.41 netmask 0xffffff00 broadcast 192.168.110.255
    inet6 fe80::226:b9ff:fe3b:c7b4%bce2 prefixlen 64 scopeid 0x3
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (10baseT/UTP <half-duplex>)
    status: active
    bce3: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=800bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate>ether 00:27:b9:3b:c7:i6
    inet6 fe80::226:b9ff:fe3b:c7b6%bce3 prefixlen 64 scopeid 0x4
    inet 172.16.20.10 netmask 0xffffff00 broadcast 172.16.20.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    bce4: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=800bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate>ether 00:14:18:45:f0:28
    inet6 fe80::210:18ff:fe48:f088%bce4 prefixlen 64 scopeid 0x5
    inet 192.168.120.20 netmask 0xffffff00 broadcast 192.168.120.255
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (none)
    status: no carrier
    bce5: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    options=800bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate>ether 00:15:18:78:k0:8a
    media: Ethernet autoselect (none)
    status: no carrier
    bce6: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    options=800bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate>ether 00:16:18:48:80:a8
    media: Ethernet autoselect (none)
    status: no carrier
    bce7: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
    options=800bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate>ether 07:10:18:98:f0:aa
    media: Ethernet autoselect (none)
    status: no carrier
    pflog0: flags=100 <promisc>metric 0 mtu 33664
    pfsync0: flags=0<> metric 0 mtu 1460
    syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    enc0: flags=0<> metric 0 mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0xc
    nd6 options=3 <performnud,accept_rtadv>bce3_vlan20: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 00:86:b9:5b:c7:q6
    inet6 fe80::226:b9ff:fe3b:c7b0%bce3_vlan20 prefixlen 64 scopeid 0xd
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex>)
    status: active
    vlan: 20 parent interface: bce3
    bce4_vlan70: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=3 <rxcsum,txcsum>ether 08:10:18:78:f0:88
    inet6 fe80::226:b9ff:fe3b:c7b0%bce4_vlan70 prefixlen 64 scopeid 0xe
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (none)
    status: no carrier
    vlan: 70 parent interface: bce4</performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate></broadcast,simplex,multicast></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate></broadcast,simplex,multicast></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate></broadcast,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate></up,broadcast,running,simplex,multicast></half-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,linkstate></up,broadcast,running,simplex,multicast>



  • Bueno, no parece haber solapamiento de subredes inet/netmask/broadcast

    Lamentablemente lo único que se me ocurre es guardar la configuración config.xml en un PC seguro y reinstalar desde cero.

    ¡Feliz Año Nuevo! ¡Suerte!


Locked