Alias problem (host list)



  • I made a list of blocked sites as an alias called "test_block" and then used alias in firewall rule. It kind of worked but not for all sites I entered on list. Then I removed some sites from the list including "youtube.com" but for some reason "youtube.com" remained blocked. I double checked the alias list and youtube.com was definitively not on a list anymore. I found that very strange but as I am fairly new to pfsense I thought I must be doing something wrong. I just disabled the rule to work around the problem.

    But then I found Diagnostics/Tables/test_block table still holding youtube.com IP address. I done "Filter Reload" several times thinking that maybe I forgot to hit apply after making changes. But no the IP address was still there.

    Then I added some dummy ip adresses 111.111.111.111 - 115 to the same "test_block" alias to see the behavior. After applying the change I went to check test_block table all 5 dummy IPs were there and "youtube.com" IP address was gone! OK so then I gone back and deleted all dummy IPs from the alias, hit save, then apply. Head back to test_block table and still can see all dummy IPs showing.

    That can't be right can it? Am I doing something wrong? Any clues?

    pfsense version:
    2.0.2-RELEASE (i386)
    built on Fri Dec 7 16:30:38 EST 2012
    FreeBSD 8.1-RELEASE-p13

    thanks in advance

    Andrius



  • I think you might have come across a bug.

    On my 2.0.2 system, when I try to create url alias, I am given 2 choices for the option "type", "Url" and "Url Table".

    If I try and create a url alias with option - type set as "Url" it throws out an error.

    The following input errors were detected:

    You must provide a valid URL. Could not fetch usable data.

    I've tried with and w/out "http://" but no joy.

    And creating a url alias with the option - type set as "Url Table" throws out the following error.

    Jan 3 18:08:12 php: : There were error(s) loading the rules: no IP address found for persist file "/var/db/aliastables/FreeSites.txt"
    Jan 3 18:08:12 php: : New alert found: There were error(s) loading the rules: no IP address found for persist file "/var/db/aliastables/FreeSites.txt"
    Jan 3 18:08:12 php: : The command '/sbin/pfctl -o basic -f /tmp/rules.debug' returned exit code '1', the output was 'no IP address found for

    I also noticed some GUI differences between "URL" and "URL Tables" which I have attatched, also attatched is the content of /var/db/aliastable/FreeSites.txt

    EDIT: I just realised in the 2nd photo the drop down list denotes "days" for the label "update freq".





    FreeSites.txt



  • Hi Abdsalem,

    If you are giving a host name you want on a list then you're doing it wrong. The field for URL expects a link to a text file that contains list of sites ie http://192.168.1.100/banned_sites.txt

    Or select Alias type Host(s) and enter site names line by line. But then you might encounter the problem I have. Let's see if anyone else has some input.



  • Ahh I should of read your post (& the settings more clearly!)

    I can confirm deleting url and then checking them under Diagnostics/Tables/ they are still listed there, they are also still present in /var/db/aliastables


Locked