Wireless becomes unavailable after a few hours [solved]



  • I run pfSense 2.0.2 on a Alix 2D13. The wireless card in use is a Compex WLM54G, miniPCI. The card runs in accesspoint mode, with one WLAN.

    The problem I'm experiencing currently is that the wireless works fine when the box is fresh started. But after a while (about 6 to 8 h) the wireless becomes suddenly unreachable, and I have to reboot the box to get it working again. I suffered the same with a ralink USB WLAN stick before.

    I wonder if anyone could give me a hint what could possible the problem here? If I should provide more information, let me know.

    -grimneko



  • I think I figured out the cause for this.

    When the last time this problem occured I checked via serial console the system.log and found the following message multiple times:

    ath0: ath_rx_proc: no mbuf!

    After a bit googling I found a some mailist entrys like this one http://marc.info/?l=pfsense-support&m=129098214008714.
    Disabling the traffic sharpner seems to do the trick, it runs now way longer without trouble and still uses about the same MBUF amount constant.


Locked