Captive Portal on VLANS.



  • Hey everyone,

    Have a question dealing with implementing captive portals on VLANS.

    So far the setup is:

    WAN = re0 10.1.10.11
    LAN = re1 192.168.10.1
    Vlan11 = on re1 192.168.11.1
    Vlan12 = on re1 192.168.12.1
    Vlan13 = on re1 192.168.13.1
    Vlan14 = on re1 192.168.14.1

    Modem –-> Pfsense ---> Switch ---> VLans 11-14.

    Everything works fine before enabling the captive portal.  When it is active, the splash page does not come up and the only way to access it is through the config IP, 192.168.10.1.  I did some research and found out that you can not have the parent interface assigned to anything.  This is a small problem since I can not add anymore NIC.

    However I did find this thread:
    http://forum.pfsense.org/index.php?topic=20491.0

    They apparently made a VLAN for the LAN.  Is this still possible and how is it done?

    Thank you in advance.



  • Create another VLAN with eg VLAN10 and with 192.168.10.0/24
    and then delete the parent interface.

    I am using a similar configuration.
    I first created 6 VLANs and then deleted the parent interface.
    No I am able to run CP on the VLAN interfaces.

    Remember:
    Your VLAN11 - VLAN14 interfaces are TAGGED interfaces.
    Your LAN is by default an untagged interface for VLAN1

    So I would suggest - create VLAN10 on pfsense, delete prant interface on pfsense and create VLAN10 on your switch.



  • @HappyChubbs:

    I did some research and found out that you can not have the parent interface assigned to anything.

    This is no longer true, hasn't been for at least a couple years.

    Your problem sounds like what happens when you block access to your DNS servers with the portal.


Locked