Open-VM-Tools and ESXi 5.1



  • After a problem with the upgrade from 2.0.1 to 2.0.2, I did some testing of the two versions of Open-VM-Tools that are available as pfSense packages.  I did this testing with fresh installs of both pfSense 2.0.1 and 2.0.2 (all 32-bit) on a clean install of ESXi 5.1.

    Although version 8.7.0 appeared to install OK on 2.0.1 and 2.0.2, ESXi 5.1 didn't recognize it as installed.

    Marcelloc's version 8.8.1 installed OK on 2.0.1 and 2.0.2 but gave an error when starting: "link_elf: symbol HgfsDebugPrintVattr undefined".  This error was reported in another thread: http://forum.pfsense.org/index.php/topic,48060.0.html.  The error doesn't appear to affect operation of the 8.8.1 package - ESXi recognizes the package as installed and running.

    I suspect my original 2.0.1 to 2.0.2 update problem was related to the fact that the 8.7.0 version of the package was uninstalled and reinstalled as part of the update.

    Any chance of an updated, official Open-VM-Tools package?


Locked