Firewall aliases unavailable - web gui loads forever



  • I'm running 2.0.1-RELEASE (i386), nanobsd on an Intel D2500CCE.  I'm using pfsense as a basic firewall/gateway/router for a home LAN.  It's been running wonderfully for several months now.

    Last night, I added a firewall alias.  Now, when I click on Firewall -> Aliases, the web GUI appears to load forever.  At least, it's been 10 minutes, and the screen hasn't changed.  My mouse cursor indicates that the page is loading (the "rolling circle" in Chrome).  Note that the web GUI isn't actually hung: I can click on just about anything else, and those pages load instantly (I say "just about" because I haven't tried clicking on every single link, but the few I spot checked worked just fine).

    I don't see any obvious errors in the log.  I also tried rebooting, and watched the boot on serial console.  (Note that the serial console only semi-works with this motherboard.  But everything up to where it says "FreeBSD/i386" looked normal, i.e. no obvious errors.)

    I'm a little worried that I may have done something that messed up my alias configuration.  Hoping it's easily fixable without having to re-install.

    Thanks for any help or assistance!



  • Well, apparently I was a bit too quick to post… after approximately 15 minutes, the Aliases page finally loaded.  I only had two: the "EasyRuleBlockHostsWAN", which is auto-created from functionality provided in the logs.

    I added a second alias table last night.  I copied my "config.xml" before deleting the alias tables, so hopefully I can re-create fairly easily.

    Still curious what caused pfSense to get in this state.


Locked