Wireless real slow - What can I do to fix it?



  • I am trying to connect an iPhone to my pfsense router. The connection is real slow. What are the ways you guys would go about troubleshooting the problem?

    I have set the wlan0 interface set to access point. I know there is no interference like a fish tank, microwave, or cordless cell phone. I own none of those things. I am using the alix board and pfsense 2.0.2. I had it working fine with version 2.0 but after the upgrade something went wrong and I had to start all over from scratch.



  • Does the iPhone get an IP address from pfSense?

    Please post the output of pfSense shell commands```
    /etc/rc.banner;  netstat -i; ifconfig; ping -c 10 w.x.y.z



  • Here is the output of the command:

    
    *** Welcome to pfSense 2.0.2-RELEASE-nanobsd (i386) on shertoo ***
    
      WAN (wan)                 -> vr1        -> 33.44.125.42 (DHCP)
      LAN (lan)                 -> vr0        -> 192.168.2.2 
      WLAN (opt1)               -> ath0_wlan0 -> 172.16.0.15  
    
    ath0_wlan0        1500 <link#9>22:1b:b1:24:bc:c4      38834    33     0    55854    53     0
    ath0_wlan0        3500 fe60:9::23c:c fe60:9::23c:c3ff:        0     -     -        4     -     -
    ath0_wlan0        1500 172.0.0.0      172.16.0.15               32     -     -        0     -     -
    
    ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	ether 22:1b:b1:24:bc:c4
    	inet6 fe81::32e:e1bf:fe05:aca5%ath0_wlan0 prefixlen 64 scopeid 0x9 
    	inet 172.16.0.15 netmask 0xffff0000 broadcast 172.0.0.255
    	nd6 options=43 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>status: running
    	ssid shertoo_wifi channel 11 (2462 MHz 11g) bssid 22:1b:b1:24:bc:c4
    	country US ecm authmode WPA2/802.11i privacy MIXED deftxkey 3
    	TKIP 2:128-bit TKIP 3:128-bit txpower 23.5 scanvalid 60 protmode OFF
    	burst -apbridge dtimperiod 1 -dfs
    
    PING 172.16.0.15 (172.16.0.15): 32 data bytes
    32 bytes from 172.16.0.15: icmp_seq=0 ttl=64 time=3 ms
    32 bytes from 172.16.0.15: icmp_seq=1 ttl=64 time=2 ms
    32 bytes from 172.16.0.15: icmp_seq=2 ttl=64 time=3 ms
    32 bytes from 172.16.0.15: icmp_seq=3 ttl=64 time=6 ms
    32 bytes from 172.16.0.15: icmp_seq=4 ttl=64 time=4 ms
    32 bytes from 172.16.0.15: icmp_seq=5 ttl=64 time=3 ms
    32 bytes from 172.16.0.15: icmp_seq=6 ttl=64 time=7 ms
    32 bytes from 172.16.0.15: icmp_seq=7 ttl=64 time=577 ms
    32 bytes from 172.16.0.15: icmp_seq=8 ttl=64 time=3 ms
    32 bytes from 172.16.0.15: icmp_seq=9 ttl=64 time=4 ms
    
    --- 172.16.0.15 ping statistics ---
    10 packets transmitted, 10 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 2/147/577/1 ms</hostap></performnud,accept_rtadv></up,broadcast,running,simplex,multicast></link#9> 
    

    When I ping the wlan0 interface from my wired machine on the LAN the average time is 0.152 ms. That is a big difference.



  • By the way, I used this command:

    /etc/rc.banner ; echo " " ; echo " " ; netstat -i | grep ath0_wlan0 ; echo " " ; ifconfig ath0_wlan0 ; echo " " ; ping -c 10 172.0.0.15
    

    I thought it would cut out a lot of the unnecessary stuff.
    It seems that all devices that connect to the wlan interface all have the same slowness problem.



  • @joebobfrank:

    When I ping the wlan0 interface from my wired machine on the LAN the average time is 0.152 ms. That is a big difference.

    You are not comparing like with like. A full duplex wired interface can talk whenever it wants. A WiFi device generally has to wait its turn because it has to share the communications channel.


Log in to reply