Web UI unavailable



  • the webUI on my new pfsense install box dies. this seems to happen randomly and is not reproduceable. the only way to bring it back is with a reboot. the console menu (option #11) doesn't bring it back. i've also tried "killall -9 php; killall -9 lighttpd; /etc/rc.restart_webgui
    " as suggested to others here with similar issues. i'm do see some errors in /var/log/lighttpd.error.log after the webUI becomes unavailable.

    (log.c.166) server started
    (mod_fastcgi.c.1732) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    (mod_fastcgi.c.3002) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
    (log.c.166) server started
    (mod_fastcgi.c.1732) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    (mod_fastcgi.c.3002) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
    (mod_fastcgi.c.1732) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    (mod_fastcgi.c.3002) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
    (log.c.166) server started
    (server.c.1546) server stopped by UID = 0 PID = 23343
    (log.c.166) server started
    (server.c.1546) server stopped by UID = 0 PID = 1

    i've found some older posts here that indicate the same issue, however they refer to the older pre 2.x releases and don't really mention a fix.
    all other functions (routing/firewalling/nat/ssh etc.) seem to stay intact for the duration that the webUI is down.
    if it helps, i've installed using the iso within pfSense-LiveCD-2.0.2-RELEASE-i386.iso.gz. hardware is an old p4 2.8 w/ 3gigs of RAM.



  • that's the problem with fastcgi crashing in 2.0.2 that some people are seeing, you can gitsync to 2.0.3 or grab the pre-release image.

    http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_RELENG_2_0/?C=M;O=D
    http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/amd64/pfSense_RELENG_2_0/?C=M;O=D


Locked