Mailscanner package not found



  • Hello,

    running pfsense on release 2.02.
    I am trying to re-install mailscanner, but get an error it cannot be downloaded from the server:

    Beginning package installation for mailscanner-dev...
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading mailscanner-dev and its dependencies... 
    Checking for package installation... 
     Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/MailScanner-4.83.5.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/amd64/packages-8.1-release/All/MailScanner-4.83.5.tbz.
    of MailScanner-4.83.5 failed!
    
    Installation aborted.Backing up libraries... 
    Removing package...
    Starting package deletion for MailScanner-4.83.5...done.
    Skipping package deletion for perl-5.12.4_3 because it is a dependency.
    Starting package deletion for pyzor-0.5.0_1...done.
    Starting package deletion for p5-Mail-SPF-2.007...done.
    Starting package deletion for p5-IP-Country-2.27...done.
    Removing mailscanner-dev components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file mailscanner.inc could not be found for inclusion.
    Deinstall commands... 
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... Failed to install package.
    
    Installation halted.
    

    Navigating with filezilla manually to the requested uRL shows the folder packages-8.1-release does not exist.

    Any idea what is going wrong?

    Any help appreciated.

    Hoger



  • http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ has the necessary file: MailScanner-4.83.5.tbz
    When I navigate there, other files are also listed. I can click on the other files and they download, but clicking on MailScanner-4.83.5.tbz jumps to a page "Locaweb Test Page". So something odd has happened to this file (its protection?).
    Perhaps the package maintainer will notice this and be able to sort out the issue.



  • My provider is removing read permission on this file(detecting testing eicar signature).

    I'll speed up process/tests to move install link to oficial repo.



  • Working again, thanks!  :)



  • I`m tring to install mailscanner for a few days now, i allwas get this error:

    Beginning package installation for mailscanner-dev…
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading mailscanner-dev and its dependencies...
    Checking for package installation...
    Downloading http://e-sac.siteseguro.ws/pfsense/8/All/MailScanner-4.83.5.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/MailScanner-4.83.5.tbz.
    of MailScanner-4.83.5 failed!

    I have tried tried to enter the uer http://e-sac.siteseguro.ws/pfsense/8/All...
    i get and web page that says : Locaweb Test Page

    Any idea`s
      tnx



  • I have download  MailScanner-4.84.5_3.tbz  from http://ftp2.freebsd.org//pub/FreeBSD/ports/i386/packages-current/All/

    Can some one please explain how it can be install manually.



  • Can you try to reinstall the package?



  • working now.  :)
    mabey someone fix the error.



  • Looks like somthing is broken again?

    Beginning package installation for mailscanner-dev...
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading mailscanner-dev and its dependencies... 
    Checking for package installation... 
     Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/MailScanner-4.84.5_3.tbz ...  (extracting)
    
       Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ca_root_nss-3.12.11_2.tbz ...  (extracting)
    
       Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/p5-IO-Compress-2.046.tbz ...  (extracting)
    
       Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/clamav-0.97.6.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/amd64/packages-8.1-release/All/clamav-0.97.6.tbz.
    of MailScanner-4.84.5_3 failed!
    
    Installation aborted.Backing up libraries... 
    Removing package...
    Starting package deletion for MailScanner-4.84.5_3...done.
    Skipping package deletion for perl-5.12.4_3 because it is a dependency.
    Starting package deletion for pyzor-0.5.0_2...done.
    Skipping package deletion for p5-Mail-SPF-2.007 because it is a dependency.
    Skipping package deletion for p5-IP-Country-2.27 because it is a dependency.
    Removing mailscanner-dev components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file mailscanner.inc could not be found for inclusion.
    Deinstall commands... 
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... Failed to install package.
    
    Installation halted.
    


  • Try again…



  • Thanks Form quick reply!
    But still an error
    
    [codeBeginning package installation for mailscanner-dev...
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading mailscanner-dev and its dependencies... 
    Checking for package installation... 
     Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/MailScanner-4.84.5_3.tbz ...  (extracting)
    
       Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/ca_root_nss-3.12.11_2.tbz ...  (extracting)
    
       Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/p5-IO-Compress-2.046.tbz ...  (extracting)
    
       Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/clamav-0.97.6.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/amd64/packages-8.1-release/All/clamav-0.97.6.tbz.
    of MailScanner-4.84.5_3 failed!
    
    Installation aborted.Backing up libraries... 
    Removing package...
    Starting package deletion for MailScanner-4.84.5_3...done.
    Skipping package deletion for perl-5.12.4_3 because it is a dependency.
    Starting package deletion for pyzor-0.5.0_2...done.
    Skipping package deletion for p5-Mail-SPF-2.007 because it is a dependency.
    Skipping package deletion for p5-IP-Country-2.27 because it is a dependency.
    Removing mailscanner-dev components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file mailscanner.inc could not be found for inclusion.
    Deinstall commands... 
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... Failed to install package.
    
    Installation halted.[/code]
    
    Hmmm...
    


  • Can you try a manual download before package install? the file is there and has read permission  ???



  • ;D Whatever happened, it is working now.

    Thanks



  • Not working again.

    Downloading http://e-sac.siteseguro.ws/pfsense/8/amd64/All/libltdl-2.4.2.tbz …  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/amd64/packages-8.1-release/All/libltdl-2.4.2.tbz.
    of MailScanner-4.84.5_3 failed!



  • I did a clean install and installed amd64 version with no missing dependencies, can you check if you get same result?



  • It is working again.  I tried both a reinstall and a full install, no problems.



  • @mschiek01:

    It is working again.  I tried both a reinstall and a full install, no problems.

    finally..  :)



  • package will not reinstall.

    Install hangs on:

    Configuring package components…
    Additional files... done.
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...

    The gui is missing and will not reinstall



  • Hi,

    I just did a fresh install but I couldn't finished the mailscanner installation.

    Downloading http://e-sac.siteseguro.ws/pfsense/8/All/MailScanner-4.84.5_3.tbz …  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/MailScanner-4.84.5_3.tbz.
    of MailScanner-4.84.5_3 failed!

    The package is there... but not downloadable. pls fix



  • It's working now, thx



  • Hm, I upgraded from 2.0.2 -> 2.0.3 (i386) and now I can't install mailscanner:

    Downloading http://e-sac.siteseguro.ws/pfsense/8/All/MailScanner-4.84.5_3.tbz …  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/MailScanner-4.84.5_3.tbz.
    of MailScanner-4.84.5_3 failed!

    Thanks,
    Fabian



  • Try again please.

    I did not had time to revise all compile options to move it to official repo.



  • Not yet:

    Beginning package installation for mailscanner…
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading mailscanner and its dependencies...
    Checking for package installation...
    Downloading http://e-sac.siteseguro.ws/pfsense/8/All/MailScanner-4.84.5_3.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-release/All/MailScanner-4.84.5_3.tbz.
    of MailScanner-4.84.5_3 failed!

    Installation aborted.Backing up libraries...
    Removing package...
    Starting package deletion for MailScanner-4.84.5_3...done.
    Skipping package deletion for perl-5.12.4_3 because it is a dependency.
    Starting package deletion for pyzor-0.5.0_2...done.
    Starting package deletion for p5-Mail-SPF-2.007...done.
    Starting package deletion for p5-IP-Country-2.27...done.
    Removing mailscanner components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Include file mailscanner.inc could not be found for inclusion.
    Deinstall commands...
    Not executing custom deinstall hook because an include is missing.
    Removing package instructions...done.
    Auxiliary files... done.
    Package XML... done.
    Configuration... done.
    Cleaning up... Failed to install package.

    Installation halted.



  • Do you have rules to deny traffic to Brazil?



  • Nope, all open.



  • Strange, from my 2.1-BETA1 (i386) built on Wed May 22 08:31:46 EDT 2013 FreeBSD 8.3-RELEASE-p8
    I can install the package, but still not on the 2.0.3. Other packages work.

    Fabian


Locked