Upgrade to 2.0.2 broke OpenVPN (Solved)



  • hello all:

    I had a working farm of nine openvpn servers running 2.0.1, all worked perfectly using TAP interface/bridge.  I upgraded all of them to 2.0.2 and now none of them work.  It seems like the clients cannot make a UDP connection on 1194 to the OpenVPN servers as I do not see anything in the server log about clients attempting to connect, and on the client side I get P_CONTROL_HARD_RESET_CLIENT_V2 kid=0.  No configuration changes have been made, this is a critical problem for me.  Is it possible to revert back to 2.0.1 or does anyone have ideas of what the problem could be?  Let me know what I need to post here



  • It seems I was able to get this going by going into the OpenVPN configuration, editing the servers, MAKING NO CHANGES, but saving the form.  Things are back to normal now at any rate.


  • Rebel Alliance Developer Netgate

    Did you have the tap bridge fix package installed?

    It's possible that when it booted up after the upgrade, the package wasn't installed, so it wrote out the "wrong" config for a tap setup, then the package got installed, and when you did the edit/save it then setup and rewrote a proper config for a tap bridge.


Log in to reply