28th jan snap wifi shows insecure where as in settings its wpa enabled



  • my wifi is bridged to lan but in system log i see the below error and this results in my wifi openly available without a password insipte of i having set wpa with a password

    Jan 29 20:31:24 hostapd: ath0_wlan0: IEEE 802.11 Fetching hardware channel/rate support not supported.



  • Hello,

    My two wifi interfaces are doing the same thing even with this morning snap shot update.

    what I have figured out so far is that it's not createing the /var/run/hostapd_run0_wlan0.pid and /var/run/hostapd_run1_wlan0.pid files.

    Yours would be /var/run/hostapd_ath0_wlan0.pid.  By it being missing caused it not to load the /var/etc/hostapd_ath0_wlan0.conf file for the configuration file from the /tmp/ath0_wlan0_setup.sh  which enables/loads the interface.  So I ran it manully removed the "-P /var/run/hostapd_auth_wlan0.pid" from the line and that allowed the interface to come up.

    I have not traced it yet in the seems like it's skipping the wireless loading. I have looked though the code and it is listed in the interfaces.php file to generate all the above.  Not sure what is broken yet but maybe somebodey else might have an idea.

    I also tried deleting the interfaces and recreating them but this still didn't fix the issue.

    Hope this helps…..



  • +1 - I just upgraded to 2G nanobsd 2.1-BETA1 (i386) built on Tue Jan 29 16:42:56 EST 2013
    My laptop is telling me that my WiFi is unsecured, but the WiFi interface settings are still all there on pfSense. Haven't looked into it at all yet, since I only just upgraded 5 minutes ago.



  • Jan 30 08:24:44 imp-rt-01 php: : The command '/sbin/ifconfig 'ath0_wlan0' country 'NP' 'indoor'' returned exit code '1', the output was 'ifconfig: SIOCS80211: Invalid argument' 
    
    

    This syslog error message does not look good.



  • the 21st jan snap had everything working fine but it seems its not longer available also to revert to



  • +1.  I'm troubleshooting other things right now but let me know if there's something related to this I can lookup for anyone.



  • what i noticed was the 21st jan snap had this

    /usr/sbin/hostapd -B /var/etc/hostapd_ath0_wlan0.conf

    and 29th jan snap had

    /usr/sbin/hostapd -B /var/etc/hostapd_ath0_wlan0.conf -P /var/run/hostapd_ath0_wlan0.pid

    in /tmp/ath0_wlan0_setup.sh



  • i reverted the changes in this commit and then reboot and once up, went to wifi under interfaces and hit save and apply and all worked fine

    http://redmine.pfsense.org/projects/pfsense/repository/revisions/b73a96b68d1d4e919a268d2e8e3a6ec902709e6d

    although in wireless system log i see the first line as
    hostapd: ath0_wlan0: IEEE 802.11 Fetching hardware channel/rate support not supported.
    but the wifi is secure now



  • I reverted the change later snapshots should be ok.
    It works for me locally here not sure why it breaks yours!



  • reverting the change make wifi work securely and the wireless systemlog also starts populating which didnt earlier but the first line always says
    hostapd: ath0_wlan0: IEEE 802.11 Fetching hardware channel/rate support not supported.

    has something changed related to its drivers etc?



  • Not really.
    Its just the clones never support that only the wireless device itself can do that iirc.

    Probably that has been like that for a long time and you didn't notice?



  • i always use to see all systemlog after ever upgrade in order to find bugs to report and after upgrading to these recent snaps only it started giving those messages when i was playing with those MTU values, i even compared saved config files from 2010, 2011 and 2012 and i dont find anything different in them that might cause this



  • there is another issue, might not be related to this or pfsense at all but just need to confirm. everytime i reboot my alix with pfsense my windows 7 PC network connection shows yellow mark and says no internet connection whereas im able to surf just fine, now if i unplug its lan cable and replug then it says internet connected. i searched a lot of windows issues and mostly all pointed to some antivirus causing this which isnt true in my case so could it be that pfsense is not offering proper dhcp lease or dns address which mayb causing this as there were recent patches to dhcp



  • I discovered that the problem was just the order of parameters on the hostapd command line.
    The pull request at https://github.com/bsdperimeter/pfsense/pull/361 fixes it.
    My WiFi comes up with proper authentication happening after this. /var/run has a pid file:
    -rw-r–r-- 1 root wheel 6 Jan 30 14:09 /var/run/hostapd_ath0_wlan0.pid
    And there is a hostapd process:
    22633 ?? Ss 0:00.02 /usr/sbin/hostapd -B -P /var/run/hostapd_ath0_wlan0.pid /var/etc/hostapd_ath0_wlan0.conf
    All seems well with the world:)



  • @phil.davis:

    I discovered that the problem was just the order of parameters on the hostapd command line.
    The pull request at https://github.com/bsdperimeter/pfsense/pull/361 fixes it.
    My WiFi comes up with proper authentication happening after this. /var/run has a pid file:
    -rw-r–r-- 1 root wheel 6 Jan 30 14:09 /var/run/hostapd_ath0_wlan0.pid
    And there is a hostapd process:
    22633 ?? Ss 0:00.02 /usr/sbin/hostapd -B -P /var/run/hostapd_ath0_wlan0.pid /var/etc/hostapd_ath0_wlan0.conf
    All seems well with the world:)

    yes tried ur patch and that works fine but i still get the
    hostapd: ath0_wlan0: IEEE 802.11 Fetching hardware channel/rate support not supported.



  • Those are setup by pfSense automagically xbipin
    Do not worry no issues arise from that.
    The backend will make sure and synchronize all your instances of wireless on the same device to your configured setting.s



  • ok fine, one more thing, is the below an error

    php: : The command '/usr/bin/killall dhcpd' returned exit code '1', the output was 'No matching processes were found'



  • Nah but fixed to not get the warning anymore.



  • Now on 2.1-BETA1 (i386) built on Wed Jan 30 04:20:39 EST 2013 - which has the fixed up code to start hostapd with a PID file. WiFi and all is working fine and secured. But I still have this in syslog amongst the startup:

    Jan 30 16:10:08 	php: : The command '/sbin/ifconfig 'ath0_wlan0' country 'NP' 'indoor'' returned exit code '1', the output was 'ifconfig: SIOCS80211: Invalid argument'
    

    I have no idea if this is a "normal" message that has been there for months, or something recent - I guess it pays to look through boot logs when eberything is working, as well as when there are evident problems :) When I have a little more time I will track down how/why it is generated.
    Can anyone say if this is a "normal" feature of the boot process or something special to my Alix2D13 with ath0 WiFi card?



  • My interface does not come up still do to the fact the pid file is missing from /var/run/.  It is generating the /tmp/run0_wlan0_setup.sh file just fine.

    Even with the code fix of it still does not allow interface to come up with missing pid:
    fwrite($fd_set, "{$hostapd} -B -P {$g['varrun_path']}/hostapd_{$if}.pid {$g['varetc_path']}/hostapd_{$if}.conf\n");

    Where in hostapd functions is it generating the pid file to go in /var/run/ because it is still not generating that file for me.

    I was looking through the interfaces.inc file and I don't see where it's creating that file or does the function check isvalidpid check and create the pid file passed to it if it does not exist?



  • The PID file does not have to be generated manually, it is created by the hostapd process where the location of the file is specified using the -P parameter.



  • @bardelot:

    The PID file does not have to be generated manually, it is created by the hostapd process where the location of the file is specified using the -P parameter.

    Thanks you are correct and thanks… I manually ran the lines in the setup file and it generated the pid file.  Now when I disable and enable the Wireless interface it comes right back up.  It should have done this without me having to run it manually but at least it's working agian.  Should have tried that first.  Many Thanks for all the good work.



  • @phil.davis:

    Now on 2.1-BETA1 (i386) built on Wed Jan 30 04:20:39 EST 2013 - which has the fixed up code to start hostapd with a PID file. WiFi and all is working fine and secured. But I still have this in syslog amongst the startup:

    Jan 30 16:10:08 	php: : The command '/sbin/ifconfig 'ath0_wlan0' country 'NP' 'indoor'' returned exit code '1', the output was 'ifconfig: SIOCS80211: Invalid argument'
    

    I have no idea if this is a "normal" message that has been there for months, or something recent - I guess it pays to look through boot logs when eberything is working, as well as when there are evident problems :) When I have a little more time I will track down how/why it is generated.
    Can anyone say if this is a "normal" feature of the boot process or something special to my Alix2D13 with ath0 WiFi card?

    Its not normal as I run almost the same hardware and I don't get that. There is something still wrong with WiFi that's y I get a different message on 2 hardwares



  • with the latest snap, wifi works fine but suppose u go to interfaces and wifi and hit save and apply then wifi comes back up and wifi to lan works fine but wifi devices loose internet access



  • You are bridging Wifi-LAN and not routing Wifi-LAN correct? I'm wondering if I should skip updating from an older snap until this is sorted…



  • My wifi seems to work fine now.  But I did have an issue similar about bridge only working with internet on Mulit-Wan Group but the bridge of LAN1, LAN2 LAN3, LAN4, WLAN1  not seeing the each other on the bridge.  I finially figured out and changed under System -> Advanced -> System Tunables -> Tunable Name -> net.link.bridge.pfil_bridge back to 0 and all went to working correctly again.  I also checked the box of System -> Advanced -> Firewall and NAT -> Disable reply-to but not real sure if this had any effect on things.



  • i tried the newest snap just today again and it seems to work fine now, saving under wifi brings back wifi back to normal without issues


Log in to reply