WLAN txpower bug ?



  • Hello everybody and hello and thank you to the developers of this very nice piece of software.

    Before referring to the alledged "bug" please allow me a short description of my setup.

    I am using a PIII/900MHz box with a realtek ethernet NIC and a 802.11 a/b/g Atheros chip PCI card (Cisco AIR-PI21AG).

    WAN is ath0, LAN is rl0 in bridging mode to configure a wireless bridge for interconnection to the local wireless network (www.awmn.net in greek only, sorry).

    In our wireless community we approach the network from a minimal rf pollution perspective.

    Given this, the first thing that I checked was txpower management.

    To be more precise, we are all using high directivity parabolic antennas and reduce the transmited power levels to those neseccary for the link i.e 1-10mW

    BGP routing is the chore of another box that serves many such interfaces.

    Now to the "bug"

    $ ifconfig -v ath0
    ath0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
    inet6 fe80::240:96ff:fea5:49c6%ath0 prefixlen 64 scopeid 0x1
    inet 10.2.8.131 netmask 0xfffffff0 broadcast 10.2.8.143
    ether 00:40:96:a5:49:c6
    media: IEEE 802.11 Wireless Ethernet autoselect mode 11b <hostap>status: associated
    ssid sw1iyf-tireas channel 11 (2462) bssid 00:40:96:a5:49:c6
    authmode OPEN privacy OFF deftxkey UNDEF powersavemode OFF
    powersavesleep 100 txpowmax 20 txpower 20 rtsthreshold 2346
    fragthreshold 2346 -pureg protmode OFF -wme burst ssid SHOW -apbridge
    dtimperiod 1 bintval 100</hostap></up,broadcast,running,promisc,simplex,multicast>

    txpowmax for this card (cisco ath0) equals 34, adjustment range is 1 to 34.

    If I try to set it up via the web interface, nothing happens.

    If I issue the command "ifconfig ath0 txpower xx", it works.

    Will you please check your code ?

    I am facing also another problem but it is not related to pfsense.

    It must be a freeBSD issue.

    I only mention it here in case someone knows more.

    In AP mode 802.11b it only transmits on channels 1-11 (FCC)

    This card is the European version where channels 1-13 (ETSI) are allowed.

    _$ sysctl dev.ath.0

    dev.ath.0.%desc: Atheros 5212
    dev.ath.0.%driver: ath
    dev.ath.0.%location: slot=9 function=0
    dev.ath.0.%pnpinfo: vendor=0x168c device=0x0013 subvendor=0x14b9 subdevice=0xcc21 class=0x020000
    dev.ath.0.%parent: pci0
    dev.ath.0.smoothing_rate: 95
    dev.ath.0.sample_rate: 10
    dev.ath.0.countrycode: 0
    dev.ath.0.regdomain: 104
    dev.ath.0.debug: 0
    dev.ath.0.slottime: 20
    dev.ath.0.acktimeout: 35
    dev.ath.0.ctstimeout: 35
    dev.ath.0.softled: 0
    dev.ath.0.ledpin: 0
    dev.ath.0.ledon: 0
    dev.ath.0.ledidle: 2700
    dev.ath.0.txantenna: 0
    dev.ath.0.rxantenna: 2
    dev.ath.0.diversity: 0
    dev.ath.0.txintrperiod: 5
    dev.ath.0.diag: 0
    dev.ath.0.tpscale: 0
    dev.ath.0.tpc: 0_

    _$ ifconfig -v ath0 list chan

    Channel   1 : 2412  Mhz 11g          Channel  52 : 5260* Mhz 11a         
    Channel   2 : 2417  Mhz 11g          Channel  56 : 5280* Mhz 11a         
    Channel   3 : 2422  Mhz 11g          Channel  60 : 5300* Mhz 11a         
    Channel   4 : 2427  Mhz 11g          Channel  64 : 5320* Mhz 11a         
    Channel   5 : 2432  Mhz 11g          Channel 100 : 5500* Mhz 11a         
    Channel   6 : 2437* Mhz 11g          Channel 104 : 5520* Mhz 11a         
    Channel   7 : 2442  Mhz 11g          Channel 108 : 5540* Mhz 11a         
    Channel   8 : 2447  Mhz 11g          Channel 112 : 5560* Mhz 11a         
    Channel   9 : 2452  Mhz 11g          Channel 116 : 5580* Mhz 11a         
    Channel  10 : 2457  Mhz 11g          Channel 120 : 5600* Mhz 11a         
    Channel  11 : 2462  Mhz 11g          Channel 124 : 5620* Mhz 11a         
    Channel  12 : 2467  Mhz 11g          Channel 128 : 5640* Mhz 11a         
    Channel  13 : 2472  Mhz 11g          Channel 132 : 5660* Mhz 11a         
    Channel  34 : 5170* Mhz 11a          Channel 136 : 5680* Mhz 11a         
    Channel  36 : 5180* Mhz 11a          Channel 140 : 5700* Mhz 11a         
    Channel  38 : 5190* Mhz 11a          Channel 149 : 5745* Mhz 11a         
    Channel  40 : 5200* Mhz 11a          Channel 153 : 5765* Mhz 11a         
    Channel  42 : 5210* Mhz 11a          Channel 157 : 5785* Mhz 11a         
    Channel  44 : 5220* Mhz 11a          Channel 161 : 5805* Mhz 11a         
    Channel  46 : 5230* Mhz 11a          Channel 165 : 5825* Mhz 11a         
    Channel  48 : 5240* Mhz 11a_



  • I'll check out the TX power setting, it used to work, but something might be "borked" in later versions.
    As for the issue you see with channel 12 and 13 not working you should take this up on freebsd-mobile mailing list. Most likely the region code of your card breaks the driver code somehow. Remeber to post all HW info on the card, all sysctls for ath, all ifconfig and pciconf -lv info. Sam Leffler maintains the driver we currently use, so he should be able to answer and possibly fix this.



  • Yes there was a bug in txpower.  I have commited a fix and will be including the fix in my snapshot this evening.



  • Indeed, my bad, I actually forgot to execute the setting.
    Checked all settings now, they should all be set correctly now.
    BTW. this seems to have been borked since september   :-[



  • Thank you for the quick responce and the proper lead for the channels problem.


Locked